Ciscoworks : Failed to fetch config using RCP.

Unanswered Question
Mar 3rd, 2008

Hi,

I am using LMS 2.6

In Archive Management, I get the following error message for some devices : Failed to fetch config using RCP.Connection timed out: connect Verify RCP is enabled or not.

It is for Primary startup and running and VLAN Running.

I am sure that SNMP read and write string is set properly.

How can I resolve this problem?

Thanks for your help,

Mehdi

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Joe Clarke Mon, 03/03/2008 - 13:43

Is RCP the protocol that you want to use to fetch configs from these devices, or should some other protocol be used? What type of the devices are these?

persepolis77 Mon, 03/03/2008 - 13:48

I really don't mind which protocol to use. I received this message in my Configuration Archival Summary. I have bunch of successful for Config Archival Status and some fails.

One of the devices that I got this message for, is a Catalyst 2960.

Joe Clarke Mon, 03/03/2008 - 13:52

The protocol that SHOULD work is important. That will dictate what credentials RME will use. If RCP is listed as the last protocol, then what you are seeing is RME failing for all the other protocols listed before it.

For SNMP/TFTP to work for config fetch, you must have a valid read-write community string or proper SNMPv3 read-write credentials configured on the device and in DCR. RME will use the CISCO-CONFIG-COPY-MIB to initiate a TFTP transfer using SNMP.

For telnet/SSH, RME needs to have the proper login and enable credentials.

To troubleshoot an issue of config archive failing, you should enable ArchiveMgmt Service debugging under RME > Admin > System Preferences > Loglevel Settings, perform a new sync on one failing device, then check the dcmaservice.log for errors.

persepolis77 Tue, 03/04/2008 - 05:49

Hello,

Thanks for reply.

I activated the debugging.

I have already the correct read-write credentials but the question is where I can set the login and enable credentials for Telnet/SSH.

Thanks again,

Mehdi

Joe Clarke Tue, 03/04/2008 - 10:15

The credentials for telnet and SSH are defined in DCR just like the SNMP credentials. Go to Common Services > Device and Credentials > Device Management, and edit credentials for one of the failing devices. The telnet/SSH credentials are defined on the first page.

persepolis77 Tue, 03/04/2008 - 10:22

In the first page, the only options that I have are :

- Primary Credential

- SNMPv2c/SNMPv1

- SNMPv3

- Rx-Boot Mode Credential

- Auto Update Server Managed Device Credential

2nd page gives me HTTP Settings and the last one gives User Defined Fields!!! I do not see any place for Telnet/SSH!!!

Joe Clarke Tue, 03/04/2008 - 10:48

The primary credentials are the telnet and SSH credentials. Fill in the fields you need. That is, if you require a Username to login, specify that username in the Username field. If you do not require a Username, then just fill in the password and enable password fields.

persepolis77 Tue, 03/04/2008 - 11:32

I had already the username and password for Primary Credential.

What I did is that I tried with another username and password and tried Sync Archive, it was successful. Then I changed them to the ones that I had when it had fialed and tried again Sync Archive, and again it archived successfully.

I do not know what the problem was, but now it is working without any error message!!!

Thanks again for your help.

Actions

This Discussion