BGP Dampening; Not seeing dampening process

Answered Question
Mar 3rd, 2008

Hi,

I've configured 2 routers and using FR in between. Each router advertising its own network and I've activated default bgp dampening on one of the router.

The problem is I can't see the dampening process using "debug ip bgp damp", "sh ip bgp sum", "sh ip bgp damp fla" when I shut/unshut lo0 and adjacency network.

as5r1(config-router)#do sh run | s router bgp

router bgp 5

no synchronization

bgp log-neighbor-changes

bgp dampening

network 5.5.5.0 mask 255.255.255.0

network 5.5.5.1 mask 255.255.255.255

neighbor 5.5.5.34 remote-as 3

no auto-summary

as5r1(config-router)#do sh ip int brief

Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 unassigned YES NVRAM administratively down down

Serial1/0 unassigned YES NVRAM up up

Serial1/0.407 5.5.5.33 YES NVRAM up up

Serial1/1 unassigned YES NVRAM administratively down down

Serial1/2 unassigned YES NVRAM administratively down down

Serial1/3 unassigned YES NVRAM administratively down down

Loopback0 5.5.5.1 YES NVRAM up up

as5r1(config-router)#do sh ip bgp damp para

dampening 15 750 2000 60 (DEFAULT)

Half-life time : 15 mins Decay Time : 2320 secs

Max suppress penalty: 12000 Max suppress time: 60 mins

Suppress penalty : 2000 Reuse penalty : 750

as5r1(config-router)#do sh ip bgp

BGP table version is 30, local router ID is 5.5.5.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

*> 3.3.3.0/24 5.5.5.34 0 0 3 i

*> 5.5.5.0/24 0.0.0.0 0 32768 i

*> 5.5.5.1/32 0.0.0.0 0 32768 i

as5r1(config-router)#do sh ip bgp sum

BGP router identifier 5.5.5.1, local AS number 5

BGP table version is 30, main routing table version 30

3 network entries using 351 bytes of memory

3 path entries using 156 bytes of memory

3/2 BGP path/bestpath attribute entries using 372 bytes of memory

1 BGP AS-PATH entries using 24 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 903 total bytes of memory

Dampening enabled. 0 history paths, 0 dampened paths

BGP activity 5/2 prefixes, 16/13 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

5.5.5.34 4 3 51 60 30 0 0 00:25:09 1

I have this problem too.
0 votes
Correct Answer by Harold Ritter about 8 years 9 months ago

David,

How do you simulate the BGP prefix flapping? Bear in mind that if you just shutdown the interface between the two routers it will not trigger BGP dampening as it is the BGP session that will be flapping rather than the BGP prefixes themselves.

I would suggest you just remove the network statement and reinstate it and repeat this process a couple of times, which should cause BGP dampening to kick in.

Hope this helps,

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
ebreniz Fri, 03/07/2008 - 14:23

I think you may have to set the dampening parameters in the route-map.. I may well be wrong but thats all I can think of...

try this:

route-map BGP-damped permit 10

match ip address prefix-list BGP-damped

set dampening XXXXXXX

exit

where 15 is the half-life decay time

and 750 is the re-use time of the dampened route

and 2000 is the value when the route starts dampening

and 60 is the max time (in mins) to suppress the route...

set some parameters like half-life , penalty to start reusing a route , penalty to start suppressing a route , Maximum duration to suppress a stable route

Correct Answer
Harold Ritter Fri, 03/07/2008 - 17:10

David,

How do you simulate the BGP prefix flapping? Bear in mind that if you just shutdown the interface between the two routers it will not trigger BGP dampening as it is the BGP session that will be flapping rather than the BGP prefixes themselves.

I would suggest you just remove the network statement and reinstate it and repeat this process a couple of times, which should cause BGP dampening to kick in.

Hope this helps,

davidsudjiman Tue, 03/11/2008 - 22:32

Thanks hritter!

Apparently your suggestion works. Removing advertised network via "no net" does the job.

Danilo Dy Tue, 03/11/2008 - 07:17

Hi,

Try multiple hard BGP reset on router without BGP dampening setting, i.e. "clear ip bgp *" to see if BGP dampening settings works on the router with BGP dampening setting.

This happens to me when I'm new to BGP :) which I learned to use soft BGP reset.

Regards,

Dandy

Actions

This Discussion