What route do I use when using a DSL line?

Unanswered Question
Mar 3rd, 2008
User Badges:

Hey guys,


I have a DSL business line and the ISP gave me /29 network. I set the DSL modem as Bridge mode and I have a Cisco 877 acting as the PPPOE client.


What do I use in my ip route 0.0.0.0 0.0.0.0 statement?


Do I put:


ip route 0.0.0.0 0.0.0.0 dialer1?


The ISP only gave me the block of 5 IPs and told me to use the last one as the default gateway, however, this IP gets placed in the dialer1 interface after I connect the router to the DSL (I found this by doing a "sh ip int br")


Any help?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (3 ratings)
Loading.
insccisco Mon, 03/03/2008 - 17:37
User Badges:

Well, physically, my FAS4 interface is the one connected to the DSL modem.


FAS4 settings:


interface FastEthernet4

no ip address

duplex auto

speed auto

pppoe enable group global

pppoe-client dial-pool-number 1

end


Then I have a Dialer1 interface. Here are its settings:


interface Dialer1

mtu 1492

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

no cdp enable

ppp authentication chap pap callin

ppp chap hostname [email protected]

ppp chap password xxx

ppp pap sent-username [email protected] password xxx

end


I hope this info helps.



sundar.palaniappan Mon, 03/03/2008 - 17:52
User Badges:
  • Green, 3000 points or more

Angel,


Though FastEthernet4 is your physical connection to the ISP dialer 1 is where the IP configuration resides on. Therefore, as you indicated earlier, you need to point the default route to dialer1.


HTH


Sundar

insccisco Mon, 03/03/2008 - 18:31
User Badges:

I see. But my confusion comes in here:


The ISP gave me an /29 network. (75.75.75.128/29). Then they told me to use 75.75.75.134 as the Default gateway and 255.255.255.248 as the subnet mask.


But when I do a "sh ip int br", 75.75.75.134 shows as the IP address for the Dialer1 interface. So how in the world am I going to use .134 as the D.G?


Based on this Network, .129 should be the default gateway and .130 up to .134 the usable IPs. Am I correct on this one?



lamav Mon, 03/03/2008 - 18:40
User Badges:
  • Blue, 1500 points or more

Sundar:


If he points his default route to the dialer interface, wont the router execute an ARP for every destination address, since it will think that the destination addresses are all directly connected to dialer 1? And in that case, wont the ISP's router have to have proxy ARP enabled?


If they are giving him a default gateway address to use, why cant he just point his default route to that and be done with it?


Thanks in advance for your time and response.


Victor

sundar.palaniappan Mon, 03/03/2008 - 19:06
User Badges:
  • Green, 3000 points or more

Victor,


You are correct that when a route points to an interface the router would rely on proxy ARP response from the device connected to the interface and moreover proxy ARP also puts extra burden on the router originating the ARP. It wouldn't be an ideal setup but there are situations that would require this configuration like when the next hop address is unknown or the IP of the interface is dynamically negotiated.


Angel,


You are correct that the route can't point to it's own address as the next hop. The router would spit out an error if you try to do that. However, you can point the route to dialer1 interface. I assume your ISP probably may have meant to say the same.


Just point the default route to dialer1 int and check the outcome.


HTH


Sundar



dennisnieuwenhuyzen Tue, 03/04/2008 - 10:51
User Badges:

Hi,


Every provider uses his own technique and design. Here in holland routed subnet configuration are used a lot. The config would look like this.


interface Dialer0

ip unnumbered Ethernet0

interface Ethernet0

ip address negotiated

ip route 0.0.0.0 0.0.0.0 Dialer0


In this setup the router is used more as a modem and a firewall or router device after the DSL router can use ip addresses in the public range with the router as Default GW.


For the routed subnet configuration you also should remove the "ip nat outside" line.



Of course you can also choose to use a natted config on the DSL router.

insccisco Tue, 03/04/2008 - 11:53
User Badges:

Seems like Im having way too many problems with th is line.


Last night, I was able to put some traffic on this line. It is used as my backup ISP and this is the config I had for my Dialer1 interface and also for the FAS4 interface (fas4 is where the dsl line is physically connected into the 871 router)


interface FastEthernet4

no ip address

duplex auto

speed auto

pppoe enable group global

pppoe-client dial-pool-number 1

end

.

.

.

interface Dialer1

mtu 1492

ip address negotiated

ip access-group 111 in

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

no cdp enable

ppp authentication chap pap callin

ppp chap hostname [email protected]

ppp chap password xxx

ppp pap sent-username [email protected] password 7 111F1F1740475B

crypto map mymap

end

.

.

.

ip route 0.0.0.0 0.0.0.0 69.69.69.25 track 125

ip route 0.0.0.0 0.0.0.0 Dialer1 200

.

.

.

ip nat inside source route-map GlobalISP1 interface Dialer1 overload

ip nat inside source route-map GlobalISP2 interface Vlan3 overload


Like I said, last night it worked but the line was dropping every 45 minutes or so. It would go down for 1 min. to 5 mins and then it would come back... so it was very unstable.


Today we called the ISP and they provided us with a new DSL modem. Whe ISP tech finished, I couldn't even get an IP address. I then asked the tech to please set the DSL modem as a Bridge only device. He went ahead and did it, however I still can't even get an IP address; my dialer1 interface shows "unassigned" for the IP-Address.


I then placed my laptop and set it up as a PPPOE client and it worked. This is perhaps telling me that the cisco 871 is the culprit.



any help please?




paolo bevilacqua Tue, 03/04/2008 - 14:02
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Posted config is complete enough to say it seems ok.

Please collect "debug pppoe-packet" and "ppp negotiation", with "term mon".

dennisnieuwenhuyzen Wed, 03/05/2008 - 06:12
User Badges:

Seems ok to me, can you post the output of the comments posted by p.bevilacqua.


please try and post the results of:

debug vpdn pppoe-events

show vpdn

debug vpdn pppoe-data

debug pppoe-errors

debug pppoe-packets

debug vpdn pppoe-events


insccisco Wed, 03/05/2008 - 08:48
User Badges:

guys, thanks for checking. I also engaged with TAC and they also said the config looks good.


So I went back to those clowns (AT&T) and asked them to investigate what was happening. They had said that the line was dirty, then the DSL modem was bad, etc.


I went onsite and personally reset that modem, called their tier2 people to have them bridge that thing again and during this process, I noticed there are few settings that need to be setup properly, like disabling the routing feature of the dsl (because it will be in bridge mode). Perhaps these are the settings that were not completely setup the few times their field techs tried.


Soon after the DSL modem was properly bridged, the cisco router quickly obtained an IP address and traffic started to flow out the dialer1 interface.


It has now been more than 16 hours and the line has not had any problems... not even a hicup.


all good guys... thank you for the helping out and making sure my my config was golden



paolo bevilacqua Wed, 03/05/2008 - 09:15
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Good to know it has been resolved. Next improvement step for you, get an 877 or even better a 1801, so you can connect the dsl line directly and apply QoS on it.

Remember to rate useful posts with the scrollbox below and good luck!


Actions

This Discussion