PPP Multilink over T1 on 1760

Unanswered Question
Mar 4th, 2008
User Badges:

Hi all,


I am configuring 2 1760 connected back-to-back using a single T1. In order to support VoIP, I want to enable PPP multilink on the T1 for fragmentation. However when I enable PPP multilink on the T1 serial interface, the link goes down and the serial interface reports framing errors and resets. If I do not enable multilink the link is clean.


I searched the documentation and I cannot find anywhere that this setup is not supported. I am running the same setup between 2811 without errors.


Is there something I am missing?


version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname pvgtwy4a

!

boot-start-marker

boot-end-marker

!

!

tdm clock T1 0/0 data import onboard internal

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

no aaa new-model

ip subnet-zero

ip cef

!

!

!

!

no ftp-server write-enable

!

!

!

!

!

!

!

!

!

!

!

!

!

!

controller T1 0/0

framing esf

linecode b8zs

cablelength short 133

channel-group 0 timeslots 1-24 speed 64

!

!

!

interface Multilink1

mtu 2000

ip address 10.255.255.2 255.255.255.252

max-reserved-bandwidth 100

ip route-cache flow

ip tcp header-compression iphc-format

ppp multilink

ppp multilink fragment delay 5

ppp multilink interleave

ppp multilink group 1

ppp multilink mrru local 2000

ppp multilink mrru remote 2000

ip rtp header-compression iphc-format

!

interface FastEthernet0/0

ip address 192.168.1.1 255.255.255.0

speed auto

full-duplex

!

interface Serial0/0:0

ip address 10.255.255.6 255.255.255.252

max-reserved-bandwidth 100

encapsulation ppp

ppp multilink

ppp multilink group 1

!

ip classless

!

no ip http server

!

!

control-plan


version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname pvgtwy4b

!

boot-start-marker

boot-end-marker

!

tdm clock T1 0/0 both export line

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

voice-card 0

!

no aaa new-model

ip subnet-zero

ip cef

!

!

!

!

no ftp-server write-enable

!

!

!

!

!

!

!

!

!

!

!

!

!

!

controller T1 0/0

framing esf

linecode b8zs

cablelength short 133

channel-group 0 timeslots 1-24 speed 64

!

!

!

interface Multilink1

mtu 2000

ip address 10.255.255.1 255.255.255.252

max-reserved-bandwidth 100

ip route-cache flow

ip tcp header-compression iphc-format

ppp multilink

ppp multilink fragment delay 5

ppp multilink interleave

ppp multilink group 1

ppp multilink mrru local 2000

ppp multilink mrru remote 2000

ip rtp header-compression iphc-format

!

interface FastEthernet0/0

ip address 192.168.0.1 255.255.255.0

speed auto

full-duplex

!

interface Serial0/0:0

ip address 10.255.255.5 255.255.255.252

max-reserved-bandwidth 100

encapsulation ppp

ppp multilink

ppp multilink group 1

!

ip classless

!

no ip http server

!

!

control-plane

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
paolo bevilacqua Tue, 03/04/2008 - 06:26
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Can be an IOS anomaly issue.

Upgrade to latest 12.3 that is like 40 or so, remove all what not essential under multilink interface and try again.

dmongrain Tue, 03/04/2008 - 06:31
User Badges:

I have upgraded already to the latest release of the train 12.3(11)T. I was running 12.3(11)T and upgraded to 12.3(11)T11 with the same result.


I get this error as soon as I enable PPP multilink on the serial interface, even if I do not specify which PPP multilink group...

paolo bevilacqua Tue, 03/04/2008 - 06:38
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Can you try 12.4(3j) that is the most stable release as of today ?

Joseph W. Doherty Tue, 03/04/2008 - 07:00
User Badges:
  • Super Bronze, 10000 points or more

Paolo,


I'm curious about your suggestion. Since within a mainline release, changes are supposed to be limited to bug fixes, wouldn't, in theory, the very latest be the most stable?


Your original post would also seem to endorse using the latest.

Joseph W. Doherty Tue, 03/04/2008 - 06:29
User Badges:
  • Super Bronze, 10000 points or more

BTW: depending on how much of the T-1's bandwidth you have, fragmention to support voice might be unnecessary.

Actions

This Discussion