EIGRP on 3560

Answered Question
Mar 4th, 2008

Hi, I want to configure EIGRP on a 3560 switch in order to eliminate static route redistribution. How would I do that. I can't find anything out there (documentation). What kind of port would that have to be a "no switchport" or a trunk? Thanks for the help!!!

I have this problem too.
0 votes
Correct Answer by Richard Burts about 8 years 9 months ago

Bart

You can run EIGRP over layer 3 interfaces on the 3560. This could either be a physical interface defined as a layer 3 interface (not access port) or a VLAN interface. You would not run EIGRP on trunk interfaces (though EIGRP might be running on the VLANs passing through that trunk).

What you would do would be to configure EIGRP in global config mode (router eigrp ) and then under the routing protocol you enter network statements to match the interfaces (and subnets) that you want to include in EIGRP.

It really is not particularly different to run EIGRP on the 3560 than it is to run EIGRP on a router.

HTH

Rick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
lamav Tue, 03/04/2008 - 07:55

Oh boy! What a loaded question :-)

You can read this link, for starters.

http://www.cisco.com/en/US/docs/ios/12_2/ip/configuration/guide/1cfeigrp.html

As far as the kind of port....I think you're a bit confused.

But, in short, to create a routed port, which is what you would want to do so that you can send and receive EIGRP routing updates, you would enter the "no switchport" command under the interface configuration mode. That will convert the port from a layer 2 switched port to a layer 3 routed interface.

Example:

interface gigabitethernet 1/1

no switchport

ip address 10.10.10.19 255.255.255.252

no shut

router eigrp 100

network 10.10.10.8 0.0.0.3

HTH

If so, please rate my post.

Victor

bsudol79p Tue, 03/04/2008 - 08:14

OK, I have two layer 3 switches, one of them is connected to the router, and the switches are connected to each other. Should I also configure routed ports between the switches as well? Should I make the routed ports on the management vlan? We have vlan 1 configured a management vlan. Thanks again!!

lamav Tue, 03/04/2008 - 08:21

Hi:

You can think of it this way:

If you configure an EIGRP routing process on your switch, it is then a layer 3-enabled switch and you must have routed ports configured from which to send and receive routing updates.

If the switch remains a layer 2 switch, then traffic will be sent/received to/from another network device through the use of a trunk, which is a layer 2/switched connection.

As far as the management vlan, you will want to advertise that interface under EIGRP so that you can have a route to it for remote access.

HTH

Victor

Correct Answer
Richard Burts Tue, 03/04/2008 - 08:01

Bart

You can run EIGRP over layer 3 interfaces on the 3560. This could either be a physical interface defined as a layer 3 interface (not access port) or a VLAN interface. You would not run EIGRP on trunk interfaces (though EIGRP might be running on the VLANs passing through that trunk).

What you would do would be to configure EIGRP in global config mode (router eigrp ) and then under the routing protocol you enter network statements to match the interfaces (and subnets) that you want to include in EIGRP.

It really is not particularly different to run EIGRP on the 3560 than it is to run EIGRP on a router.

HTH

Rick

Richard Burts Tue, 03/04/2008 - 08:29

Bart

We are at a disadvantage in trying to give you advice about where to run EIGRP since we know so little about your environment, the topology of your network, or your requirements.

Your original post says that you would like to use EIGRP to eliminate redistribution of static routes. So I would start by assuming that you need EIGRP where there are static routes (and especially where there are static routes being redistributed - are there static routes that are not redistributed?). I might go further than that and assume that you also would want EIGRP running wherever inter-vlan routing is being done. This would allow EIGRP to know all the active VLANs and to assist in routing between them.

If you want us to tell you more than this, then you need to provide us some additional information about your situation and your topology.

HTH

Rick

Richard Burts Tue, 03/04/2008 - 10:24

Bart

I have looked through the configs that you posted. While there is still a bunch there I have not looked at carefully, I believe that I understand it well enough to make some recommendations. The router is already running EIGRP, and it is redistributing static routes. But the route map that controls redistribution does not permit the default route. I suggest that the router should redistribute the static default route. If the router redistributes the static default and the switches run EIGRP then the switches will learn the default route and therefore will no longer need static default routes.

I also suggest that you run EIGRP on both of the switches. On both switches you should run EIGRP 10 and it should include network statements for:

network 172.18.0.0

network 172.19.0.0

network 172.20.0.0

network 172.21.0.0

network 172.23.0.0

If you do this then both switches will not need any static routes and will learn the networks that they need to do effective inter-vlan routing. and they will learn a default route from the router and will forward all traffic for outside to the router.

This will mean that most of the inter-vlan route will now be on the switches which will relieve some of the work that the router has been doing and will reduce some of the traffic that the trunk to the router has been carrying.

HTH

Rick

lamav Tue, 03/04/2008 - 10:50

I agree with Rick.

And I will add that you can remove the "network 172.23.0.0" statement from eigrp 10 on the router. The router does not have any interfaces in that network and will therefore not be advertising it anyway.

Victor

Actions

This Discussion