CiscoWorks DCR database replication

Answered Question
Mar 4th, 2008

I am trying to enable the 'slave' server to replicate with the master however I get the following error message:

Error in configuring the slave because Domain IDs of this machine and Master are same.

I'm using CS 3.0.6 and RME 4.0.6.

I already have Single Server signon working across both servers.

I've been through the prereqs and imported the certs. All looks good but the final step won't work?

Anyone got any idea where to start to look?

I have this problem too.
0 votes
Correct Answer by Joe Clarke about 8 years 9 months ago

Sounds like you restored a backup from one server to the other. On the slave server, edit NMSROOT/lib/classpath/com/cisco/nm/dcr/dcr.ini, and make sure the DCR_ID and DCR_GROUP_ID are unique compared to the values on the master server. Typically, the DCR_ID should be the short hostname of the local server followed by "-DCR" followed by a random number.

After changing this file, restart dmgtd.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Joe Clarke Tue, 03/04/2008 - 21:00

Sounds like you restored a backup from one server to the other. On the slave server, edit NMSROOT/lib/classpath/com/cisco/nm/dcr/dcr.ini, and make sure the DCR_ID and DCR_GROUP_ID are unique compared to the values on the master server. Typically, the DCR_ID should be the short hostname of the local server followed by "-DCR" followed by a random number.

After changing this file, restart dmgtd.

a.goldsmith Tue, 03/04/2008 - 21:39

Brilliant! I've been working on this one for a few days now. The DCR Group ID was the same on both the master and slave. I just incremented the counter by 1 and re-added everything and it now works!

Thanks J.

Actions

This Discussion