FXO H323 incoming calls rings calling pstn phone 3x's before IP phone rings

Unanswered Question
Mar 4th, 2008
User Badges:

I have an issue where incoming calls from the pstn through a 2811 router ring 3 times before the internal called ip phone rings once. The FXO voice ports are set with command "Ring Number 1". Router is also performing intevlan routing between data and voice vlans for a layer 2 switch.


here is some configuration:

voice-port 0/0/0

trunk-group Analog-Lines 4

no vad

no comfort-noise

timing hookflash-out 50

connection plar 2240

station-id name External Call

caller-id enable


dial-peer voice 100 voip

destination-pattern 2240

session target ipv4:192.168.7.10

incoming called-number .

dtmf-relay h245-alphanumeric

codec g711ulaw

fax rate disable

no vad


interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

description Trunk to Default VLAN

encapsulation dot1Q 1 native

ip address 192.168.4.3 255.255.255.0

!

interface FastEthernet0/0.8

description Trunk to Sanford Voice Lan

encapsulation dot1Q 8

ip address 192.168.8.1 255.255.255.0

ip helper-address 192.168.1.17

h323-gateway voip interface

h323-gateway voip bind srcaddr 192.168.8.1

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
b_ferguson Fri, 03/14/2008 - 09:48
User Badges:

Did you get this resolved? I am having the same issue.


TODD BERGMAN Mon, 03/17/2008 - 07:03
User Badges:

Well, when you have caller-id enable on the voice-port I guess the call manager waits to collect the caller-id digits and this creates the delay. If you do not have caller-id on your pstn analog trunk then remove it. A new version of IOS introduced a connection plar opx immediate. This is suppose to setup the caller before recieving all caller-id information.

Actions

This Discussion