Equal cost Load balancing not happening in OSPF

Unanswered Question
Mar 4th, 2008
User Badges:

Hi ,

I am having two sites(A & B) each site is having 2 routers connected to each other via LAN.


The two routers are connected to there remote sites via wan link


On site B i am having FWSM firewall behind this firewall i am having a subnet- 202.137.234.0. This subnet is active on site B router1 & standby on FWSM router 2


I had put a static route on site b router 1 & 2 pointing towards the FWSM outside interface.


This static route is redistributed under my ospf of Type1


redistribute static metric-type 1 subnets


The problem.

I am not able to do loadbalancing from Site A router 2 to 202.137.234.0 subnet at Site B via Site A router 1 & Site B router2 2 . I am able to reach the subnet from Site A router 2 via Site B router 2 via metric 26 (OSPF-E1)& from Site A router 2 via Site A router 1 via metric 27 (OSPF-E1)


Pls let me know how could i perform equal loadbalancing .


Attach find the OSPF cost diagram


Regards

Hitesh




Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joseph W. Doherty Wed, 03/05/2008 - 04:58
User Badges:
  • Super Bronze, 10000 points or more

I'm gotten a little loss in what you're trying to accomplish. If you're trying to load balance starting at either SiteA router, you're not going to be able to do so using OSPF. To do that, you would need another router, or routers, in front of both SiteA routers.


Other options are: if available, use GLBP on each SiteA router. Or, make one of the two SiteA routers the primary gateway, and manually cost so that it will use both paths. (The other SiteA router would be the secondary gateway. Have the original SiteA router preempt the gateway address if it's up and both paths are valid.)

Actions

This Discussion