MMS:// port 554 with ACNS

Unanswered Question
Mar 5th, 2008

I have my CE setup and have the wccp setup on my router. I see that WMT is being redirected if I use http:// to access the video. If I try to go straight to the video using MMS:// (Windows Media Service) it plays from the original site not the CE. MMS:// uses port 554. Is there a way to redirect traffic based on this port number? How can I get the MMS:// request to redirect to the CE?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Diego Vargas Wed, 03/05/2008 - 08:59

Hi,

So you have the router and CE configured with WCCP service 80 and 83? (for WMS 9 which uses WMT RTSP)

And you already have the license for WMT?

It sounds to me that you have web-cache service configured but not WMT RTSP services.

Hope it helps!!

Diego M

rclemenger Wed, 03/05/2008 - 09:56

when I do a show wccp services I get

WAE-512#sh wccp services

Services configured on this Content Engine

Web Cache

RTSP

WMT

MMSU

I dont't have a WMT license but I do have WMT enabled and am using the evaluation. A little over 16 days left on the eval.

Diego Vargas Wed, 03/05/2008 - 10:13

Do you have all those services configured on the router?

Can you provide the CE and Router current configuration?

Diego Vargas Wed, 03/05/2008 - 10:48

Are you using WMS9? Starting with Windows Media Services 9 Microsoft decided to use RTSP-based streaming instead of the previously used MMS.

From the docs:

With WMS 9, Microsoft introduced a major change in the streaming protocol. Windows Media Services 9 Series by default uses a new RTSP-based protocol for streaming.

These are the streaming protocols currently used by Windows Media 9 players:

•Windows Media Services 9 Series RTSP/RTP-based protocol

•Windows Media Services 9 Series-over-HTTP

A Content Engine, which is running the ACNS 5.5.1 software, has full interoperability with the Windows Media 9 server and a Windows Media 9 player over all of these streaming protocols.

So if you want to configure WMT in ACNS 5.5 you need to enable service 80 and 83

Take a look at the procedure:

http://www.cisco.com/en/US/docs/app_ntwk_services/waas/acns/v55/configuration/local/guide/wmtstrm.html#wp1040956

Hope it helps!!

Diego Vargas Wed, 03/05/2008 - 10:49

BTW, you have service 80 and 81, so then again if you have WMT RTSP (used by WMS9) you need to have 80 and 83 configured.

Actions

This Discussion