Router password issue

Unanswered Question
Mar 5th, 2008

This is going to be probably very stupid question to you guys but I'm a new in the cisco routing. We got 2821 router and configured it. It was with default passwords 'cisco' , 'cisco'. I used #enable secret XXXXXX to change password and now when I try to telnet it's asking me for username and password. What suppose to be the username? Am I gonna be asked for username if I use console connection?

Thanks,

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
lamav Wed, 03/05/2008 - 10:55

Rashey, your question is not stupid at all.

If you have a router configured with a username and password and the login local command configured under line vty 0 4, you will be prompted for the username and password when you telnet to the router.

Example:

username MY ROUTER password MYPASSWORD

line vty 0 4

login local

You will also get prompted for a username and password if you're configured for TACACS, but that's another story. :-)

Try going in through the console.

HTH

If so, please rate this post.

Victor

Edison Ortiz Wed, 03/05/2008 - 11:03

Am I gonna be asked for username if I use console connection?

If you enable aaa new-model it will affect all incoming connections to the router and if you forgot to enter an username & password in the configuration, your only choice is rebooting the router.

Hopefully, you didn't save the config after making those changes, if you did, you will have to perform a password recovery.

Let's us know what kind of configuration was entered in addition to "enable secret". That command by itself won't cause the username prompt.

HTH,

__

Edison.

Actions

This Discussion