QoS on Fastethernet !!

Answered Question
Mar 6th, 2008

hi all, i have taken DSL connections from an ISP, consider 2 sites. Both are using ADSL connection terminated on their Fas 0/1 interfaces. The circuit taken is of 256 kpbs. now at each site we have a server that needs to be guaranteed 50% of bandwidth, now this is what i have done

configure interface bandwidth

int fas 0/1

bandwidth 256

service-policy output server

now here is the confusion, this qos will work only if there is congestion right ? so when there will be congestion of a 100mbps link ?? coz the circuit is 256 kpbs from DSL MODEM to ISP, the link from Fas 0/1 to MODEM is 100mbps, so router will send traffic at 100mbps to Modem right ? but when i issue the command

sh int fas 0/1

to see the load, it never exceeds 270-280 kpbs, so is the flow control between fas 0/1 and modem is limiting the traffic ?

To keep it simple, how shall i apply qos to Fas 0/1 in my case ?? CBWFQ will work when there is congestion its very difficult that 100mbps gets congested

i hope you understand what i am trying to ask,

kindly guide me through this

I have this problem too.
0 votes
Correct Answer by Joseph W. Doherty about 8 years 9 months ago

As both Paolo and Mohamed correctly note, the key is a CBWFQ parent shaper that will limit your outbound FastEthernet to 256 Kbps. Within the child policy, you'll provide a class that guarantees the minimal bandwidth for your server.

e.g. (syntax likely incorrect)

ip access-list extended special_server

permit ip host x.x.x.x any

class-map special_server

match access-list special_server

policy-map parent_shaper

class class-default

shape 256000

policy child_priority

policy-map child_priority

class special_server

bandwidth percentage 50

interface fastethernet 1

service-policy output parent_shaper

Correct Answer by Paolo Bevilacqua about 8 years 9 months ago

The problem with config example is that won't work, because as the original posted, the 100mb interface is never congested.

The solution is using so called hierarchical policy, shape to the uplink value as needed, then apply llq or whatelse is desired.

See for example

http://cisco.com/en/US/tech/tk543/tk545/technologies_tech_note09186a00800b2d29.shtml

Hope this helps, please rate post if it does!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
kris_duffy Thu, 03/06/2008 - 04:01

Hi Illusion,

I believe the following will provide you with your basic needs. It could do with a bit further tuning but at this stage it is the best I can come up with. Once you have applied this config you can confirm it with - show policy-map interface fastEthernet 0/1

access-list 100 permit ip host {your server ip here} any

class-map match-all server-access

match access-group 100

policy-map server

class server-access

bandwidth 128

class class-default

bandwidth 128

int fas 0/1

service-policy output server

Hope this helps,

Kris

Correct Answer
Paolo Bevilacqua Thu, 03/06/2008 - 05:58

The problem with config example is that won't work, because as the original posted, the 100mb interface is never congested.

The solution is using so called hierarchical policy, shape to the uplink value as needed, then apply llq or whatelse is desired.

See for example

http://cisco.com/en/US/tech/tk543/tk545/technologies_tech_note09186a00800b2d29.shtml

Hope this helps, please rate post if it does!

Mohamed Sobair Thu, 03/06/2008 - 06:39

Hi,

the bandwidth configured under the interface would not change the interface operating speed. The bandwidth is used for routing protocol & QoS calculation.

once you configured bandwidth, you could then apply you QoS based on it, or if you want to limit the speed, you could configure

shaping) and apply CB/WFQ using parent/child policy.

HTH

Mohamed

HTH

Mohamed

Correct Answer
Joseph W. Doherty Thu, 03/06/2008 - 07:06

As both Paolo and Mohamed correctly note, the key is a CBWFQ parent shaper that will limit your outbound FastEthernet to 256 Kbps. Within the child policy, you'll provide a class that guarantees the minimal bandwidth for your server.

e.g. (syntax likely incorrect)

ip access-list extended special_server

permit ip host x.x.x.x any

class-map special_server

match access-list special_server

policy-map parent_shaper

class class-default

shape 256000

policy child_priority

policy-map child_priority

class special_server

bandwidth percentage 50

interface fastethernet 1

service-policy output parent_shaper

david.lima Thu, 03/06/2008 - 09:33

I cannot applyt this on a 4506, can i use the police command instead of shape ?

Paolo Bevilacqua Thu, 03/06/2008 - 12:40

Not really, the police command will have adverse effects on tcp performance, remember that anything but a true router is not be suites to handle wan things and related qos.

At that point better to leave things as they are and if the voice cant go properly, get a router where you fit the adsl interface and you will have complete control over outgoing QoS.

Joseph W. Doherty Thu, 03/06/2008 - 13:57

From my reading of the 4500 series QoS documentation, 12.2(40)SG, depending on your sup, up to 4 queues are supported per interface. You have the option to shape a rate against each tx queue.

With such support, you could direct the special server traffic to one queue with a 128 Kbps shaper and all other traffic to another queue, also with a 128 Kbps shaper. This would meet your minimal requirements.

One issue is any excess bandwidth not used by one queue could not be used by the other queue.

david.lima Fri, 03/07/2008 - 05:39

Thank You, I also read this documentation but it seems that I cannot do shaping (I have SUP V card). My goal is to define a main class with the WAN bandwith that my provider gives to me and then declare subclasses with percent of the main class.My provider brings the WAN link with a copper to fiber transceiver directly connected to a Gigabit interface (@100 Mbs) of my 4500. If i declare percent of tx-queue without parent class it does not apply cause my interface is @100mbps

Joseph W. Doherty Fri, 03/07/2008 - 05:50

Perhaps the only way you're going to meet your goal is to place a full featured WAN router between the 4500 and your copper WAN link. It doesn't have to be a "monster" box, only one that can handle the bidirectional bandwidth. 256 Kbps is trivial, assuming the downlink speed is 8 Mbps or less, an 800 or 1800 series might do (I'm uncertain about the features of 800s).

Actions

This Discussion