ASA 5510 ssh

Unanswered Question
Mar 6th, 2008


i have router 2801 which is connected to ASA to Outside interface, and have problem with ssh ver 1.

sh ssh Inside Outside.

any suggestions?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
brettmilborrow Thu, 03/06/2008 - 08:06

have you generated your ssh keys on the ASA?

Try this command:

crypto key generate rsa modulus 1024

aadilovic Thu, 03/06/2008 - 08:33

yes i do...

and security-level on out interface is 50

from inside its work

brettmilborrow Thu, 03/06/2008 - 08:37

try running:

'debug ssh'

And then attempt to connect to the firewall using ssh. This may give a clue why the session is failing.

aadilovic Fri, 03/07/2008 - 06:23

when i try to connect i get this on router

2801#ssh -v 1 -l local

[Connection to aborted: error status 33]

brettmilborrow Fri, 03/07/2008 - 15:42

Could you run the 'debug ssh' command on the firewall whilst you try to connect.

dylan.webb Wed, 10/16/2013 - 19:34

I had a similar problem with an ASA5510 (


Switch#ssh -l admin

[Connection to aborted: error status 34]


after generating a new cert and changing ssh ver to 2 the problem disapeared.

Not sure if this is an option for you but I know there are some vulnerabilitys in ssh v1 as well.


Julio Carvajal Wed, 10/16/2013 - 21:49

Hello Dylan,

Remember that SSH version 1 uses 768 bits for the rsa key


ssh -v 1 -l username  IP address

Make sure you have configured the ASA to use Version 1

ASA(config)# ssh version 1



This Discussion