DMA upgrade 3.3.5 to 4.1.3 to 5.1.1 Validation error

Unanswered Question
Mar 6th, 2008
User Badges:

From reading this forum, I think that I may have either run into bug CSCsd03418, or I can just delete my user and re add him later. This forum is wonderful and I took the advice to build a lab server to 3.3.5sr2a, restore with BARS, upgrade to 4.1.3, backup with BARS, then install and run DMA.


I ran the DMA 5.1.1 tool on my 4.1.3 lab Publisher and only received 2 errors. Both Business Rule Validation errors.


Warning, Business Rule validation detected violations, see C:\CiscoWebs\DMA\bin\datavalidation.log for errors. Backup tar file can still be used.


From what I've read, I can still use this file, but it will bring over the 'faulty' data and I will have to correct after my upgrade. OR, I suppose that I can delete the user/phone that is giving the error and try again. Any suggestions?


Here are the actual error messages. I ran an export with BAT and this user showed up with a tab after the first name in the export. I went into the Corp Dir and removed the space that was appearing after the first name, re-ran DMA, but still received the same error.



Thanks!

Erin



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Rob Huffman Thu, 03/06/2008 - 10:46
User Badges:
  • Super Red, 40000 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Erin,


Yes, this is very clean looking. Either way you can proceed, but I think that I would try and fix this one error and you will really be good to go :)


Error message: DeviceNumPlanMap DisplayASCII has invalid format. It should contain letters, numbers and some special characters. Max length is 30. Regular expression used to validate: ^[a-zA-Z0-9 !#$'()*+,./:;=?@\\\\^_`}~-]{0,30}$


DisplayASCII Christoper Bressoud


Good luck with the rest of the project!

Rob

emikelso Thu, 03/06/2008 - 10:50
User Badges:

Thanks Rob,


My question is, how do I fix it? It doesn't have any special characters and it is less than 30 characters. Do I need to look at the SQL table to see the actual value?


Thanks,

Erin

Rob Huffman Thu, 03/06/2008 - 13:16
User Badges:
  • Super Red, 40000 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Erin,


Sorry, I thought maybe there was something I couldn't see (perhaps there is :)


Why don't you just remove the ASCII Alerting Name for now?


Rob

emikelso Thu, 03/06/2008 - 14:22
User Badges:

Success!


I just adjusted the name so there were no extra spaces.


Thanks!

Rob Huffman Thu, 03/06/2008 - 15:04
User Badges:
  • Super Red, 40000 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications


Nice thinking Erin :) 5 points for posting back with your resolution!


Take care and let us know how everything goes,

Rob

Actions

This Discussion