EtherChannel problem

Unanswered Question
Mar 6th, 2008

I'm trying to Etherchannel in two ports 2/1-2 in WS-C2948G with Cisco 6509 both running CatOS. Everytime I configure ports on 2948 to channe-mode desirable silent but it always show up as non-silent and therefore doesn't bind in the Etherchannel. Can someone point me what I could be doing wrong. here is the config on the ports

set port speed 2/1-2 100

set port duplex 2/1-2 full

set trunk 2/1 desirable dot1q 1-1005,1025-4094

set trunk 2/2 desirable dot1q 1-1005,1025-4094

set spantree portfast 2/1-2 disable

set spantree bpdu-guard 2/1-2 disable

set port channel 2/1-2 mode desirable non-silent

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
lamav Thu, 03/06/2008 - 12:15

Nawas:


From my understanding, a port that generates traffic, like STP BPDUs, is non-silent, not silent. That is why the switch keeps defaulting to non-silent.


You are running STP, right?


By the way, are all the swich ports configured with the same speed and duplex settings and allowing the same vlan ranges - on both switches?


HTH


Victor

glen.grant Thu, 03/06/2008 - 19:54

Usually in the logs when you negotiate the channels it will tell you why it did not bind them . Config looks correct just make sure the native vlan matches on both sides whether it is vlan 1 or whatever you decide you want it to be . Whats the 6509 side config look like ? What vlan do all the ports default to when not trunking (native vlan) , make sure they match on all ports in the channel .

Actions

This Discussion