LMS 3.0.1 Discovery Hangs

Unanswered Question
Mar 6th, 2008
User Badges:

I am having an issue in LMS 3.0.1 where the CS Device Discovery jobs hang and do not discover anything new. The discovery jobs show running in the job listing, but if I go to the Device Discovery Summary it says Recent discovery information not found. The discovery jobs never complete and show running for days until manually stopped. Devices already in CS stay there and in other apps, but new discoveries will not work. Has anyone else run into this? Best I can tell this started after we updated to 3.0.1 with the december 2007 update. Let me know if you have any ideas?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Joe Clarke Thu, 03/06/2008 - 10:25
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

There is one bug that could account for this. Do you have a lot of IP phones in your network?

Joe Clarke Thu, 03/06/2008 - 10:39
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

You sre seeing CSCsm13114. A patch is available from the TAC, and dropping your discovery SNMP timeouts and retries is a workaround to speed up the process. It would also be good to see your CSDiscovery.log to rule out any other obvious problem that could also be contributing to a long discovery.

NPT_2 Wed, 03/19/2008 - 15:37
User Badges:

Joe,

Can you please let me know what the patch file is that you are refering to. My TAC engineer first said there was no patch available, but now says there is one but it is untested, and he says the one time it was tried it did not work, but he will be posting it for me anyway to try.

Joe Clarke Wed, 03/19/2008 - 16:24
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

There is only one patch. It has been tested, and it does work for the phones that it supports. It is trivial to add new phones to the patched XML files, though. The official patch will come out with LMS 3.1, and it will scale to all Cisco IP phones.

NPT_2 Wed, 03/19/2008 - 16:34
User Badges:

Thanks Joe,

My TAC engineer just sent me the discovery.jar and CSDiscovery-config.xml files that I'll be loading shortly.

Joe Clarke Wed, 03/19/2008 - 16:50
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

You should have also received a system-config.xml. Without it, the patch will not work.

NPT_2 Wed, 03/19/2008 - 18:25
User Badges:

Thanks Joe, I'll let him know I am missing one file as he only sent me the discovery.jar and CSDiscovery-config.xml files.

NPT_2 Fri, 03/21/2008 - 09:05
User Badges:

Hi Joe,

Just to let you know, that patch did not change anything. I started a discovery yesterday morning after loading the patch and rebooting the server and the discovery has been running 24 hours now. If you have any other suggestions they would be much appreciated. I'm also contacting my TAC engineer to see what he thinks.


agivens02 Tue, 10/21/2008 - 11:24
User Badges:

Hello,


Were you able to resolve this issue? I have encountered a similar problem with discovery "hangs". Glad to see that I am not the only one encountering this error.

NPT_2 Tue, 10/21/2008 - 11:58
User Badges:

I ended up upgrading to 3.1 and it seemed to fix the problem. TAC was really not helpful on this issue, so I just switched to 3.1 and the problem went away.

agivens02 Tue, 10/21/2008 - 12:11
User Badges:

Ok. Thanks. I assume this upgrade from 3.0.1 to 3.1 was not a "free" upgrade. I did not see any patches that will update 3.0.1 to 3.1. Again I appreciate the information as TAC has been less than helpful with my issue also.

Martin Ermel Wed, 10/22/2008 - 00:40
User Badges:
  • Blue, 1500 points or more

to get the DVD media you need an active Service Contract number for LMS that you can enter at

www.cisco.com/upgrade

to place an order free of charge;

If you want to download the update go to

www.cisco.com/go/nmsevals


see some details in this thread:

http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Network%20Infrastructure&topic=Network%20Management&topicID=.ee71a02&fromOutline=&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.2cc21ab8

agivens02 Wed, 10/22/2008 - 05:28
User Badges:

Thanks for the info. I read the informational thread and it appears you can overlay 3.1 eval version (downloaded) over 3.0.1. However the actual online information states it can only be used for a clean install with no existing versions of LMS already installed. Have you actually overlayed the Windows eval version over 3.0.1? As stated I did read the thread but it never states whether or not the overlayed install was successful. Again thank you for your information! Greatly appreciated.

NPT_2 Wed, 10/22/2008 - 07:19
User Badges:

I actually tried to get TAC to post the upgrade files for 3.1 for me, they would not do so and told me that the eval version would not use my license file and I must use the upgrade tool.

Martin Ermel Wed, 10/22/2008 - 07:54
User Badges:
  • Blue, 1500 points or more

That is really intersting!!

I did it at least 6 times - on windows and solaris - without any problem. The only difference between the eval and the 'original' version is the kind of licensing.

The eval version is restricted to run 90 day with 100 devices- there is no restriction in functionality.

Installing the license file gives you the same functionality without time restriction but restriction to the number of devices for which you have purchase LMS (100, 300, 1.5k. 5k, 10k)

But I understand that you are distrusful...


http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Network%20Infrastructure&topic=Network%20Management&topicID=.ee71a02&fromOutline=&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.2cc16600


TAC won't post the upgrade because it is > 1GB;

and they won't support the *installation* of the eval version ...

as I said before, with a valid service contract you can order the DVD at

www.cisco.com/upgrade

agivens02 Wed, 10/22/2008 - 09:08
User Badges:

OK, thanks. I will just go ahead with the DVD upgrade. In the event I encounter problems I will have a leg to stand on with TAC. Your time and consideration is greatly appreciated.

agivens02 Wed, 10/22/2008 - 09:09
User Badges:

Thanks for your response! I will go ahead with the DVD upgrade.

Actions

This Discussion