Disable Speakerphone disables Softkeys

Unanswered Question
Mar 7th, 2008
User Badges:

When checking the box to disable the speaker phone function of our 7961G phones, the softkeys become dark grey and we get the error "That key is not active here" when pressing the key. Is this by design or a bug? I assume if this is by function it is because by pressing one of the softkeys, it would activate the speaker function . If this is by design, doesn't it limit the use of the HLOG softkey unless you pick up the phone to login/logout? Running CM4.2(3). Phones are SCCP41.8-2-2SR1S. I have tried upgrading to SCCP41.8-3-4SR1S, but have the same issue.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Rob Huffman Fri, 03/07/2008 - 06:10
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi David,


Good question! I just tried the same on my 7961G and it is the same. What you will find is that the Softkeys that are greyed out with the Handset "On Hook" become available with the Handset "Off Hook". These Softkeys all need a path (normally the Speakerphone) to complete their different functions, so when that path is disabled then the Handset must be used :)


Hope this helps!

Rob

d-roush Fri, 03/07/2008 - 06:53
User Badges:

Thanks for your reply. I figured that was the case and was just verify my thought. Any ideas on how to get the HLOG key to work on-hook? I tried playing w/ the softkeys, but no luck.

obi_wan_kenobi Thu, 03/27/2008 - 06:17
User Badges:

Is this Call Manager? Or Call Manager Express? I need to disable speakerphone in CME.

Rob Huffman Thu, 03/27/2008 - 06:32
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Jason,


This reference was to CCM but this can be done on CME as well :)


This can be done on CME on a phone by phone basis. Have a look;


service phone


To modify the vendorConfig parameters in the configuration file, use the service phone command in telephony-service or ephone-template configuration mode. To disable a setting, use the no form of this command.


service phone parameter-name parameter-value


no service phone parameter-name parameter-value





This command in telephony-service configuration mode modifies vendorConfig parameters in the configuration file for phones in a Cisco Unified CME system.


In Cisco Unified CME 4.0 and later versions, support for creating configuration files at a per-phone level was supported and this command in ephone-template configuration mode creates an ephone-template of vendorConfig parameters which can then be applied to an individual Cisco Unified IP phone in Cisco Unified CME.


disableSpeaker {true | false}


Enables and disables the speakerphone.


true Enabled (default).


false Disabled.



Router(config)# telephony-service


Router(config-telephony)# service phone disableSpeaker false


http://www.cisco.com/en/US/products/sw/voicesw/ps4625/products_command_reference_chapter09186a008061137f.html#wp1123331





The following example shows how to disable the Speakerphone on an individual IP phone (ephone 15) using an ephone template:


Router(config)# ephone-template 8


Router(config-ephone-template)# service phone disableSpeaker True (**this may be FALSE as there is some debate here)


Router(config-ephone-template)# exit


Router(config)# ephone 15


Router(config-ephone)# ephone-template 8


Router(config-ephone)# exit


Router(config)# telephony-service


Router(config-telephony)# create cnf-files


Router(config-telephony)# exit


Router(config)# ephone 15


Router(config-ephone)# reset


Hope this helps!

Rob

obi_wan_kenobi Mon, 03/31/2008 - 09:43
User Badges:

Thank you Rob...great post!


true = speakerphone is disabled


false = speakerphone is enabled




Now, is there a way to configure a time zone for individual phones? We have phones in another time zone running off of our CME.


Thanks again!

Jason

Rob Huffman Mon, 03/31/2008 - 10:59
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Jason,


You are most welcome :) I don't see that as possible unless all the remote phones were "Java Based" 3rd generation phones like the 7941 and all the local phones were 2nd generation like the 7940 as they use different methods to derive the time display.


This was really covered nicely by Paul in this thread :)


http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Unified%20Communications%20and%20Video&topic=General&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.2cbf1665/0


Hope this helps!

Rob


obi_wan_kenobi Mon, 03/31/2008 - 11:19
User Badges:

We have that config set. We're using 7941G-GE's. It would be nice to be able to adjust individual phones to match a remote time zone. Either by a time zone setting, or time offset.


Jason

obi_wan_kenobi Thu, 05/01/2008 - 05:33
User Badges:

CME 4.1 (XJ4) What we need to do is only have a few phones have speakerphone turned on. The 7940's I test with seem to work fine, but the 7941 - 7961's do not. We have globally shut off the speaker. We cannot override it with the ephone template to turn on the speaker on select phones. firmware 8.2


Any ideas?

Rob Huffman Thu, 05/01/2008 - 05:47
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Jason,


Can you try the opposite config? Globally Enable and then turn off specific phones. Just thinking out loud :)


Rob

Actions

This Discussion