3750 - vlan route-map's

Unanswered Question
Mar 7th, 2008

I have a switch stack of 3750's running IPServices 12.2(25)SEE4. I was wanting to implement a route-map to direct certain addresses with in a VLAN to be routed to another default route. Though when I apply the command on the vlan interface, it does not take. Any reason why? Am I missing? the following are the commands I am using

Thanks in advance

~Jeff

Config t

Access-list 20 permit 172.16.12.20

Route-map word permit 10

Match ip address 20

Set ip default next-hop 172.16.2.5

int vlan 12

ip policy route-map word

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (2 ratings)
Loading.
Jason Fraioli Fri, 03/07/2008 - 16:13

I assume you can ping 172.16.2.5 from a host in vlan 12? Do you have any vacls in place that might be blocking traffic from vlan 12 to 172.16.2.5?

Jeff Thompson Fri, 03/07/2008 - 16:18

thanks for your reply. No vacls any where else, and yes I can ping from the 12 to 172.16.12.5 It is weird, when I apply the policy to int vlan 12, and do a show run int vlan 12, the command does not appear.

I have looked over some unsupported commands for this version of IOS, and from I can see, only route-map commands that set to a prefix-list appear to be unsupported.

Any other thoughts?

Jeff Thompson Mon, 03/10/2008 - 06:25

Thanks Sundar - I went to apply this command to our switch stack this morning and the option for 'routing-pbr' was not listed. I could issue 'sdm prefer routing' Though I am looking for pbr functionality. Any thoughts as to why that command was not listed. Could it be a IOS version?

Thanks,

~Jeff

Jeff Thompson Mon, 03/10/2008 - 20:16

Thanks for the reply Edison. After looking at the link you posted it would appear that by running the command 'sdm prefer routing desktop' I would obtain 512k for pbr ace's.

this is what is currently configured:

Switch# show sdm prefer

The current template is "desktop default" template.

The selected template optimizes the resources in

the switch to support this level of features for

8 routed interfaces and 1024 VLANs.

number of unicast mac addresses: 6K

number of igmp groups + multicast routes: 1K

number of unicast routes: 8K

number of directly connected hosts: 6K

number of indirect routes: 2K

number of policy based routing aces: 0

number of qos aces: 512

number of security aces: 1K

and this is with the command stated above:

Switch# show sdm prefer routing

"desktop routing" template:

The selected template optimizes the resources in

the switch to support this level of features for

8 routed interfaces and 1024 VLANs.

number of unicast mac addresses: 3K

number of igmp groups + multicast routes: 1K

number of unicast routes: 11K

number of directly connected hosts: 3K

number of indirect routes: 8K

number of policy based routing aces: 512

number of qos aces: 512

number of security aces: 1K

Am I reading that correctly?

Edison Ortiz Tue, 03/11/2008 - 07:13

Just change the SDM from desktop default to routing and the router will have the PBR features you need. You must reboot for the changes to take effect.

Good luck

__

Edison.

Jeff Thompson Tue, 03/11/2008 - 07:53

Thanks - yes I made the change by applying 'sdm prefer routing desktop' and I now have pbr functionality.

Thanks to everyone for the help

gandrath.nithin Mon, 08/16/2010 - 01:07

i too face the same kind of issue , might be the IOS doesnt support .

Rgds,

Nithin Gandrath

Actions

This Discussion