cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1931
Views
0
Helpful
7
Replies

Reliable Static Routing Backup Using Object Tracking with DSL & DHCP

gcameron
Level 1
Level 1

Hi, I have two ISP's connected to a Cisco 1760 IOS ver 12.4-8 and one is providing PPPOE over a WIC 1adsl and the other cable modem through a WIC-4ESW by DHCP. The problem is I modified a Cisco example which works and I can get the PPPOE as the default route BUT I want the DHCP route (which is 8Mbps versus 2mbps for the adsl)as the default, try as I may I just cannot achieve same. Please see my running-config below (edited for salient lines only)

ip sla monitor 1

type echo protocol ipIcmpEcho 72.27.0.1 source-interface Dialer1

timeout 1000

threshold 40

frequency 3

ip sla monitor schedule 1 life forever start-time now

ip sla monitor 2

type echo protocol ipIcmpEcho 72.252.205.1 source-interface Vlan1

timeout 1000

threshold 40

frequency 3

ip sla monitor schedule 2 life forever start-time now

!

!

!

ip tcp synwait-time 10

track timer interface 5

!

track 123 rtr 1 reachability

delay down 15 up 10

!

track 345 rtr 2 reachability

delay down 15 up 10

!

!

bba-group pppoe global

!

!

interface Null0

no ip unreachables

!

interface FastEthernet0/0

description $FW_INSIDE$

ip address 10.0.0.138 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nbar protocol-discovery

ip flow ingress

ip nat inside

ip virtual-reassembly

ip route-cache flow

ip tcp adjust-mss 1452

speed auto

!

interface FastEthernet0/1

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface ATM1/0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

no atm ilmi-keepalive

bundle-enable

dsl operating-mode auto

hold-queue 224 in

!

interface ATM1/0.1 point-to-point

no ip redirects

no ip unreachables

no ip proxy-arp

no snmp trap link-status

pvc 8/35

pppoe-client dial-pool-number 1

!

!

interface Vlan1

description $FW_OUTSIDE$

ip dhcp client route track 345

ip address dhcp

no ip redirects

no ip unreachables

no ip proxy-arp

ip nbar protocol-discovery

ip flow ingress

ip nat outside

ip virtual-reassembly

ip route-cache flow

ip tcp adjust-mss 1452

!

interface Dialer1

description $FW_OUTSIDE$

ip address negotiated

no ip redirects

no ip unreachables

no ip proxy-arp

ip mtu 1492

ip flow ingress

ip nat outside

ip virtual-reassembly

encapsulation ppp

ip route-cache flow

dialer pool 1

ppp authentication pap callin

ppp pap sent-username user1 password 7 2

!

ip route 0.0.0.0 0.0.0.0 Dialer1 track 123

!

ip nat inside source route-map fixed-nat interface Dialer1 overload

ip nat inside source static tcp 10.0.0.13 8080 interface Dialer1 8080

ip nat inside source route-map dhcp-nat interface Vlan1 overload

!

!

access-list 110 permit ip 10.0.0.0 0.0.0.255 any

no cdp run

!

route-map fixed-nat permit 10

match ip address 110

match interface Dialer1

!

route-map dhcp-nat permit 10

match ip address 110

match interface Vlan1

!

END OF EDITED CONFIG

Show ip route:

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C 10.0.0.0/24 is directly connected, FastEthernet0/0

S 10.159.10.3/32 [254/0] via 72.252.205.1, Vlan1

72.0.0.0/8 is variably subnetted, 3 subnets, 2 masks

C 72.27.0.1/32 is directly connected, Dialer1

C 72.252.205.0/24 is directly connected, Vlan1

C 72.27.176.50/32 is directly connected, Dialer1

S* 0.0.0.0/0 is directly connected, Dialer1

NOTE: The DHCP route's admin. distance is defaulted to 254

Show Ip route track-table:

ip route 0.0.0.0 0.0.0.0 Dialer1 track 123 state is [up]

ip route 0.0.0.0 0.0.0.0 72.252.205.1 254 track 345 state is [up]

NOTE: Again the admin. distance of 254

Any Ideas on how I can set the default route to Vlan1 (DHCP) ?

I tried changing the vlan1 to track 123 and setting the static route to 72.252.205.1 but that doesn't work. Can you guys help.

1 Accepted Solution

Accepted Solutions

Gerald

I believe that what is important in what appears in the routing table - and that is a single route. I believe that the output of show ip route track-table is incorporating information from some working table and in that working table it should not be an issue if there are several appearances.

I also not that the alternate default route learned through VLAN 1 has admin distance of 254. So I would suggest making the floating static through the dialer have a weight lower than 254 (perhaps 250) so that it would clearly be the next route to insert into the routing table.

For rating posts there should be a small drop down box in the lower right corner of posts (other than your own) which you can access when you are logged in to the forum. There is also a small check box that can be used to indicate that your issue has been resolved.

HTH

Rick

HTH

Rick

View solution in original post

7 Replies 7

Richard Burts
Hall of Fame
Hall of Fame

Gerald

There are a couple of things in your post that puzzle me. The IP routing table has this static route:

S 10.159.10.3/32 [254/0] via 72.252.205.1, Vlan1

but I do not see this route in the config. I am also puzzled that the show ip route track-table sees 2 default routes where there is only 1 that shows up in your posted config. Do you have any insights about these?

I do have a suggestion to make:

- reconfigure the static default route through the dialer to make it a floating static default:

ip route 0.0.0.0 0.0.0.0 210 Dialer1 track 123

- try this for the primary default route:

ip route 0.0.0.0 0.0.0.0 dhcp

I do not have direct experience with this, but the documentation looks like it may do what you want.

Give it a try and let us know whether it works.

HTH

Rick

HTH

Rick

Rick,

That route was inserted by the DHCP mechanism and I am also puzzled by same. But I tried your suggestions and none seem to work. The ip route 0.0.0.0 0.0.0.0 dhcp doesn't allow the dhcp keyword and I used the ip route 0.0.0.0 0.0.0.0 Dialer1 210 track 123 (I noted you had the administrative distance 210 after the netmask but that gives an error, so I corrected as shown here and it didn't work either. Even when I use 'ip route 0.0.0.0 0.0.0.0 Vlan1 1 track 123 ' that didn't work as tried previously. Any other suggestions ?

Gerald

Gerald

The wrong order of the admin distance was a mistake on my part. Thanks for finding and fixing it.

I did some more checking on the ip route dhcp option and found this in the command reference:

The following example shows that using the dhcp keyword in a configuration of Ethernet interfaces 1 and 2 enables the interfaces to obtain the next-hop router IP addresses dynamically from a DHCP server:

ip route 10.165.200.225 255.255.255.255 ether1 dhcp

ip route 10.165.200.226 255.255.255.255 ether2 dhcp 20

So I wonder what happens if you try to configure:

ip route 0.0.0.0 0.0.0.0 vlan1 dhcp

If we can get the DHCP default route into the routing table without the distance 254 then it makes sense to try to assign an admin distance to the dialer default route. Until we get the DHCP route without distance 254 there is no point to trying to do anything different with the dialer route.

HTH

Rick

HTH

Rick

Thanks again Rick,

Ok, after entering this 'ip route 0.0.0.0 0.0.0.0 vlan1 dhcp 1' command. It wouldn't allow a track keyword.

I now have this (interesting or changed portions only shown):

Sh run:

!

interface Vlan1

description $FW_OUTSIDE$

ip dhcp client route track 123

ip address dhcp

no ip redirects

no ip unreachables

no ip proxy-arp

ip nbar protocol-discovery

ip flow ingress

ip nat outside

ip route-cache flow

ip tcp adjust-mss 1452

!

!

ip route 0.0.0.0 0.0.0.0 Dialer1 254

ip route 0.0.0.0 0.0.0.0 Vlan1 dhcp

!

(Note there is no track command attached to any route)

It seems to work but I get a double entry of the vlan1, as shown below:

Router#sh ip route track-table

ip route 0.0.0.0 0.0.0.0 72.252.205.1 254 track 123 state is [up]

ip route 0.0.0.0 0.0.0.0 Vlan1 72.252.205.1 track 123 state is [up]

See Track info:

Router#sh track

Track 123

Response Time Reporter 1 reachability

Reachability is Up

2 changes, last change 00:13:10

Delay up 10 secs, down 15 secs

Latest operation return code: OK

Latest RTT (millisecs) 8

Tracked by:

STATIC-IP-ROUTING 0

Track 345

Response Time Reporter 2 reachability

Reachability is Up

4 changes, last change 00:01:25

Delay up 10 secs, down 15 secs

Latest operation return code: OK

Latest RTT (millisecs) 11

See Routing table:

Router#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is 72.252.205.1 to network 0.0.0.0

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C 10.0.0.0/24 is directly connected, FastEthernet0/0

S 10.159.10.3/32 [254/0] via 72.252.205.1, Vlan1

72.0.0.0/8 is variably subnetted, 3 subnets, 2 masks

C 72.27.5.110/32 is directly connected, Dialer1

C 72.27.0.1/32 is directly connected, Dialer1

C 72.252.205.0/24 is directly connected, Vlan1

S* 0.0.0.0/0 [1/0] via 72.252.205.1, Vlan1

I am going to figure out how to end up with one route for vlan1 now (cosmetics really),by the way you notice how we still have vlan1 at [254/0],in the routing table. Anyway I think your contribution was ENORMOUS.

THANKS MUCH, AGAIN. RICK

(By the way, how do you rate posts?)

Gerald

Gerald

I believe that what is important in what appears in the routing table - and that is a single route. I believe that the output of show ip route track-table is incorporating information from some working table and in that working table it should not be an issue if there are several appearances.

I also not that the alternate default route learned through VLAN 1 has admin distance of 254. So I would suggest making the floating static through the dialer have a weight lower than 254 (perhaps 250) so that it would clearly be the next route to insert into the routing table.

For rating posts there should be a small drop down box in the lower right corner of posts (other than your own) which you can access when you are logged in to the forum. There is also a small check box that can be used to indicate that your issue has been resolved.

HTH

Rick

HTH

Rick

Thanks much, I'll definately change that admin distance to 250.

Gerald

Especially if you do change that admin distance then it looks to me like it ought to work the way that you want it to. I am glad that my responses were helpful to you. Thank you for using the rating system to indicate that your issue was resolved (and thanks for the rating). It makes the forum more useful when people can read about an issue and can know that they will read responses that did resolve the issue.

The forum is an excellent place to learn about Cisco networking. I encourage you to continue your participation in the forum.

HTH

Rick

HTH

Rick
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card