SIP Outbound CallerID Problem

Answered Question
Mar 9th, 2008
User Badges:

Greetings, would you be able to help with an issue im having with CallerID, Inbound calls to my voice gateway successfully display the correct CallerID information but when I try to make outbound calls the endpoint displays the CallerID information as “888888888888”


I have tried different methods of manipulating the Calling number on my CME Router to translates the outgoing number to my main CLI “0121345****” as well as trying my SIP account number “844*****” but neither have any affect.


Any help you would be much appreciated.


Regards

Mark Rigby

Correct Answer by Paolo Bevilacqua about 9 years 2 weeks ago

Hi,


If you verified the number to be right, complain to TSP and show trace as necessary. They may be the ones having the problem.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Paolo Bevilacqua Sun, 03/09/2008 - 12:00
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, the main test instrument is "debug ccsip message" with "term mon".

Then to understand why isn't working, you would need to mentioned first what do you want and how's configured now.

exonetinf1nity Sun, 03/09/2008 - 18:18
User Badges:

Indeed ive performed a debug when placing an outgoing call but cant find a reference to the "88888888888" translations.


CLI is 0121345**** (Partly edited)


The translation config is below


voice translation-rule 1

rule 1 /.*/ /0121345****/

!

voice translation-rule 2

rule 1 /^999$/ /999/

rule 2 /^9\(.*\)$/ /\1/

!

voice translation-rule 3

rule 1 /.........****/ /2001/

rule 2 /.........****/ /1005/

rule 3 /.........****/ /1006/

rule 4 /.........****/ /1007/

rule 5 /.........****/ /1008/

!

!

voice translation-profile SIP_Inbound

translate called 3

!

voice translation-profile SIP_Outbound

translate calling 1

translate called 2


and the dial peer in question is


dial-peer voice 1001 voip

description **Outbound call to SIP**

translation-profile outgoing SIP_Outbound

destination-pattern 9T

voice-class codec 1

voice-class sip dtmf-relay force rtp-nte

session protocol sipv2

session target sip-server

dtmf-relay rtp-nte

no vad


The call setup portion does show the calling number as being 0121345**** an intended.


The only other solution i can think of that there is another translation occurring with the registrar. Ive tested this on several different numbers.


Regards



Attachment: 
Correct Answer
Paolo Bevilacqua Mon, 03/10/2008 - 02:39
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi,


If you verified the number to be right, complain to TSP and show trace as necessary. They may be the ones having the problem.

exonetinf1nity Mon, 03/10/2008 - 09:14
User Badges:

Well after wrestling with the provider it was a fault at there end, i had expected this behaviour to enabled by default but you know what people say about assumptions!


Cheers for the reply anyhow.


Regards

Paolo Bevilacqua Mon, 03/10/2008 - 09:18
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Exactly. First answer from SPs should be discarded by default.

Hope it helped, thanks for the nice rating and good luck!



Actions

This Discussion