Trying to complete a BGP config

Unanswered Question
Mar 10th, 2008

Trying to work out configs for the following…(Big Iron and Cisco 3725).

Have a customer with a new Metro-E feed from us and a T1 from Sprint that wants to use BGP for failover. He has a class C from Sprint and wants that to be the advertised IP space. But, since ours has more bandwidth, he wants us to be the primary route - don't think that affects MY config, just putting it out there since his class C is a Sprint subnet.

This is my 2nd Metro-E and will terminate in a Big Iron switch in the same port as the first Metro-E (NOT tagged by AT&T). The 1st (and only at the moment) is configured with a /30 - 1 IP in Big Iron (untagged VLAN) and 1 in customer Pix (no VLAN).

The Big Iron connects to my Cisco 3725 Edge router on a private 10. network. Big Iron has default route of 3725 for all traffic.

The new Metro-E will obviously have to be tagged. I'll need to create a new VLAN on the Big Iron using the same port as the existing untagged VLAN. Will need help with that. Will probably want to go ahead and tag the 1st one as well to be consistent. Can address the Pix later.

The bigger issue is that this subnet is NOT on the edge 3725 router so how will BGP know about it? Would using a /29 and adding a VLAN on the Cisco work?

Recap

Customer AS 11111 has T1 from Sprint - IP's 2.2.2.0/24.

Will get Metro-E from me (AS 22222) - IP 3.3.3.66/29 (or 3.3.3.67/30 if it helps).

Metro-E terminates in my Layer 3 switch.

Switch connects to edge via private network.

Current Big Iron related parts….

vlan 22 name Metro_E by port

untagged ethe 8/1

router-interface ve 2

interface ve 2

ip address 3.3.3.33/30 (existing Metro-E)

ip route 0.0.0.0 0.0.0.0 10.0.0.1

Cisco related parts….

interface Hssi1/0 (outside)

bandwidth 45000

no ip address

encapsulation frame-relay IETF

serial restart_delay 0

frame-relay lmi-type ansi

interface FastEthernet0/0 (inside)

ip address 10.0.0.1 255.255.255.0

ip access-group 197 in

ip access-group 197 out

no ip unreachables

ip policy route-map proxy-redirect

duplex auto

speed auto

router bgp 22222 (I currently BGP with AT&T)

no synchronization

bgp log-neighbor-changes

network 3.3.3.0 mask 255.255.255.0

network 4.4.4.0 mask 255.255.255.0 (My other IP's)

network 5.5.5.0 mask 255.255.255.0

neighbor 1.1.1.29 remote-as 1234 (AT&T)

neighbor 1.1.1.29 version 4

neighbor 1.1.1.29 route-map bellout out

no auto-summary

ip as-path access-list 1 permit ^$ (Left over from a previous attempt)

ip as-path access-list 2 permit 11111 (Customer AS)

access-list 1 permit 3.3.3.0 0.0.0.255 (Mine)

access-list 1 permit 4.4.4.0 0.0.0.255 (Mine)

access-list 1 permit 5.5.5.0 0.0.0.255 (Mine)

access-list 1 permit 2.2.2.0 0.0.0.255 (Customer subnet)

access-list 2 permit 2.2.2.0 0.0.0.255

route-map bellout permit 10

match ip address 1

route-map bellout permit 20

match as-path 1

route-map customerin permit 10

match as-path 2

Thanks 

Ed

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Rick Morris Tue, 03/11/2008 - 08:37

wow there is a lot here.

I need to break it down a little...I think of the Movie What about Bob...baby steps!

Customer is AS 11111

/24 from Sprint

So they will run BGP with Both you and Sprint?

If that is the case then they will need their own AS. They may not need their own IP Space since it sounds like you will advertise their space, but that may cause issues if Sprint see's the Advertisement from another source and not from their own network, so your customer may need to get their own IP space, which is the correct way in the first place. They can however have two different peering sessions and have two different subnets, but that is a discussion for another time.

I need to address the first BGP section first and then move on...

cuchara61 Wed, 03/12/2008 - 15:59

Sorry if not clear...

Customer does have their own AS (11111 in my example, not using "real" numbers). They also have their own IP space which happens to be provided by Sprint 2.2.2/24 (also not using "real" numbers). They will peer with Sprint and me - I want to advertise that I will accept his 2.2.2.0 network on my 3.3.3 IP address.

Thanks

Rick Morris Thu, 03/13/2008 - 06:32

Since you are a peering point you will need to make sure you advertise the route to your upstream.

The customer who wished to direct traffic must do so from their end.

One of the easiest ways to do this is to build a route-map and prepend the AS on the Sprint announcement. This way the BGP table will be populated and the your route will be more preferred based on BGP metrics, since the Sprint link will have more AS hops than yours.

Actions

This Discussion