128M compact flash card for router 2811

Unanswered Question
Mar 10th, 2008

Hi, I use a compact flash reader to copy ios image and cme files from PC to the flash card, and insert it to the router. While booting, it reports

% Crashinfo may not be recovered at flash:crashinfo

% This file system device reports an error

On CLI,

Router#show flash:

%Error show flash: (No such device)

The ios image was actually booted. The file format I used for the card is FAT.

How this happened,and how to resolve it?

Thanks,

Jon

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Rick Morris Thu, 03/13/2008 - 11:16

format the card

insert into router

format the flash in the router

Copy the IOS from a TFTP server to your flash.

copy tftp flash:

You will need basic network connection from your router, download a free tftp software pack from the internet. Set up your workstation as a TFTP server and make sure the IOS is in the right directory specified by the TFTP software during set-up.

With no IOS on the router it may boot up in rommon so you might need to do this via rommon commands:

http://www.cisco.com/en/US/products/hw/routers/ps214/products_tech_note09186a0080110ed1.shtml

xiaoliangyue Thu, 03/13/2008 - 11:22

thx for reply. I tried all of these. the key is format doesn't pass thru:

Router#format flash:

Format operation may take a while. Continue? [confirm]

Format operation will destroy all data in "flash:". Continue? [confirm]

%Error formatting flash: (No such device)

I tried Xmodem on ROMMon mode, failed, too.

Actions

This Discussion