OSPF stuck in init state over IP Interworking pseudo wire

Unanswered Question
Mar 11th, 2008
User Badges:

Layer 2 VPN is provided to one of my client who has Serial interface on one end and Ethernet on the other side.

Using IP Interworking L2 circuit is provided.

Unicast ping is working fine but unable to bring OSPF across this L2 circuit.

OSPF remains in INIT state only.

Tried “ip ospf network point-to-point” on Ethernet interface still no luck..

Any clue whether multicast is supported across IP Interworking kind of circuits ?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mheusing Tue, 03/11/2008 - 05:02
User Badges:
  • Cisco Employee,

Hi,


Are you seeing hellos across the link (debug ip ospf hello)? If so, please check the MTU settings on both interfaces and set the OSPF link type (point-to-point).

If there are no OSPF hellos received you have to ask your provider to troubleshoot the problem with you. In principle it should work.


Hope this helps!


Regards, Martin


ric_asomgdata Tue, 03/11/2008 - 23:15
User Badges:

Thanx for responding..

after issuing debug ip ospf hello i observed that site A is receiving hellos sent by site B but Site B is not receiving hellos sent by site A.

MTU used for establishing Pseudo-wire is 4474 and that of ospf interfaces (i.e. CPE interfaces) is set to 1500.


mheusing Wed, 03/12/2008 - 05:28
User Badges:
  • Cisco Employee,

Hi,


The MTU is compared in database description packets an they will come at a later stage. You can confirm, that A is sending hellos? Then you need to contact the provider to troubleshoot inside the MPLS cloud, namely why the VC does not forward the hellos.


Regards, Martin

ric_asomgdata Thu, 03/13/2008 - 00:17
User Badges:

Thanx Martin

Got the same setup tested in lab and found to be working.


Actions

This Discussion