DST work around for Unity 4.0(5)

Unanswered Question
Mar 11th, 2008

Very strange behaviour after the work around was applied to Unity in a UM configuration.

From Outlook, users receive the correct time for VM's (patched exchange) but when they access the same VM from the phone it's 1 hr behind.

Both Unity & CCM are in synch (time in the system tray) and VM ports register without issue although the timestamp is still behind. Time on the phones is correct.

Any idea how this can be resolved? A reboot didn't produce a positive change.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
nbassel Tue, 03/11/2008 - 08:38

Hi Adam,

The server was never patched for DST and according to the work around method JRE patching was not part of the process, only changing the system time. The current issue was not produced when the work around was applied previous times.

Do you know how to correct the VM timestamps on the phones?

Tommer Catlin Tue, 03/11/2008 - 09:40

I think you are talking about two different things.

on the IP phones, the time comes from CallManager server.

When you hear "Message, from xxx.xxx.xxx at 4:15pm) This is from Exchange time stamping the voicemail message.

If the TUI is playing the time wrong, this is from Unity.

You will need have your Unity servers in the "Daylight" setting in Time zones. If you do not see "Daylight" in your time zone, then you do not have the Microsoft patch.

http://www.ciscotaccc.com/kaidara-advisor/voice/showcase?case=K90543054

Basically, run the Windows patch for the KB mentioned. If you have Windows 2000, you can get the KB from the Cisco Unity DST patch. It's in the folder when you unzip the file after download. Run this first, verify your time settings.

Now run the Cisco Unity DST update. Reboot the server. Should be good to go.

I ran into this past weekend.

nbassel Tue, 03/11/2008 - 09:56

Hi Adam,

If the user checks the VM in Exhange the timestamp is correct but when they retrieve the same VM from the phone it's behind by 1 hr so this is from Unity and not exchange.

"If the TUI is playing the time wrong, this is from Unity".

Patching has not been applied at all since the beginning of the DST changes imposed by the US.

Patching at this time is not an option but I still need to rectify the VM timestamp issue from Unity to the phone.

Any advice in resolving this other than patching the system for DST?

metuzuner Tue, 03/11/2008 - 12:30

I am having the same issue; time on exchange and unity servers are correct, but message timestamps when played thru the phone are one hour behind.

Tommer Catlin Tue, 03/11/2008 - 12:31

Check your time/clock on the Unity server. It still says "standard" for example Eastern Standard time, then you need the windows patch installed. It will change it to Eastern Daylight then.

metuzuner Tue, 03/11/2008 - 13:02

I'm looking at my Date/time settings on unity boxes and it says Eastern Time, not standard or daylight.

Adam Thompson Tue, 03/11/2008 - 13:03

One thing I would like you to test if you could.

Set the time on your server to 1 hour ahead (if current time is 1:00p set to 2:00p). Check a voicemail message using a phone. Does the voicemail timestamp give the current time (not the time you set your server to)?

Please respond with what happens and we can take it from there.

Thanks,

-Adam

nbassel Tue, 03/11/2008 - 13:12

Unity, CCM & Exchange are all in synch in the system tray on each server all showing the same time.

The issue is the TUI interface and the timestamp which is 1 hr behind.

nbassel Tue, 03/11/2008 - 13:09

Hi Adam,

If the server times are different (Unity & CCM)the VM ports on CCM will not register for Unity instead an already registered port will unregister. I have seen this before during previous DST failed work arounds. This is a production system and I cannot justify this testing with the customer.

Adam Thompson Tue, 03/11/2008 - 13:36

Ok then, lets try something that should not be customer impacting (although it may be).

Have you tried going into Date/Time properties for Windows and manually unchecking the 'automatically adjust clock for daylight savings'?

If you are not in a timezone that adjusts for DST, change your timezone to one that is (ex. Pacific Time US&Canada) and uncheck the box and apply the changes. Then change it back to your correct timezone.

nbassel Tue, 03/11/2008 - 13:51

The date\time properties window shows that the "'automatically adjust clock for daylight savings" is unchecked currently.

The time zone is Eastern Standard Time.

Tommer Catlin Tue, 03/11/2008 - 14:06

Right so you need to LOAD THE PATCH. It will not reboot the server, you can do this during business hours. It's a Microsoft patch for windows 2000 server that addresses this fix.

nbassel Tue, 03/11/2008 - 14:44

Can you provide a link to the related patch?

I've read that the patches are bundled together into 1 .exe that will address DST although at this time all that is needed is the reccomended patch to address the TUI timestamp issue and not patch the server fully in regards to DST.

metuzuner Tue, 03/11/2008 - 14:02

Here's how I fixed my system.

Unchecked "automatically adjust clock for daylight saving changes" from date and time properties on all servers (exchange, unity) and set the times to correct time.

Timestamps seem to indicate correct time now.

Hope this helps others.

Regards,

metuzuner

Actions

This Discussion