LMS 3.0 Inventory collection issue

Unanswered Question
Mar 11th, 2008
User Badges:

Using LMS 3.0.1 and some devices have never had inventory collected. If inventory collection is attempted it fails with a message "Device sensed but collection failed". The credentials have been checked for these devices and are ok. the devices in question are varying models connecting to either 3750s or 6509 switches. Any ideas about where I should be looking. This is a problem affecting only 10 out of 500 devices

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Tue, 03/11/2008 - 17:02
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

I recently filed a new bug tracking a certain class of inventory collection problems, but there appears to be still one outstanding. Check your IC_Server.log. If you see errors saying an index for a table is not unique, then you are hitting at least one of these bugs, and you should open a TAC service request to get a patch, and to collect more debugging info.

mburrell5 Tue, 03/11/2008 - 19:04
User Badges:

The error occuring throughout the log file is: ASA Error -193: Primary key for table 'PhysicalPort' is not unique. Is this what you were referring to?

Joe Clarke Tue, 03/11/2008 - 19:08
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Yes. This problem will most likely be fixed by the patch I already have created (available through TAC for bug CSCsm97530).

suelange Tue, 03/18/2008 - 08:18
User Badges:
  • Bronze, 100 points or more

I am getting the same error "device sensed but collection failed" on inventory. I can import the config and access the device and it passes the credentials tests. BUT I am not seeing the error about unique index in my ic_server.log file. Instead, I have the following in my log file:


[ Mon Mar 17 11:09:44 CST 2008 ],ERROR,[Thread-14],com.cisco.nm.rmeng.inventory.ics.core.CollectionController,667, Collection failed but sensed the device : 256

com.cisco.nm.xms.xdi.ags.system.CollectionFailedDeviceSensed: com.cisco.nm.xms.xdi.ags.system.CollectionFailedDeviceSensed: java.lang.NullPointerException

at com.cisco.nm.xms.xdi.pkgs.SharedInventoryStack.ContainmentAGI_ENTITY_Mib.populatingTheStack(ContainmentAGI_ENTITY_Mib.java:241)

at com.cisco.nm.xms.xdi.pkgs.SharedInventoryStack.ContainmentAGI_ENTITY_Mib.g$eval(ContainmentAGI_ENTITY_Mib.java:110)

at com.cisco.nm.xms.xdi.ags.ContainmentAGI.g$eval(ContainmentAGI.java:21)

at com.cisco.nm.xms.xdi.SdiEngine.initAndEvalAGIs(SdiEngine.java:301)

at com.cisco.nm.xms.xdi.SdiEngine.request(SdiEngine.java:226)

at com.cisco.nm.xms.xdi.SdiEngine.getDevRepr(SdiEngine.java:219)

at com.cisco.nm.rmeng.inventory.ics.core.CollectionController.run(CollectionController.java:467)

at java.lang.Thread.run(Thread.java:534)


Would that patch help me at all or am I fighting something else?


Joe Clarke Tue, 03/18/2008 - 09:10
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

What type of device is this? what version of code is it running? What version of RME?

suelange Tue, 03/18/2008 - 11:48
User Badges:
  • Bronze, 100 points or more

rme is 4.0.6


both are 3750's


both run ver C3750-ADVIPSERVICESK 12.2.40 se


I have lots of other 3750's same code level no problem.

Joe Clarke Tue, 03/18/2008 - 11:50
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Do you have any pre-provisioned cluster switches configured on this 3750? That is, have you configured any cluster switches which don't yet exist? If so, remove them from the config, then try and collect inventory from this switch.

suelange Wed, 03/19/2008 - 07:01
User Badges:
  • Bronze, 100 points or more

no, no clustering. These two switches do have cross-stack etherchannel back to the core switch, but so do other 3750's that don't have this problem....


Thank you in advance,

Joe Clarke Wed, 03/19/2008 - 09:09
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

There appears to be an issue with the ENTITY-MIB on this switch. Please post the show run and show ver.

suelange Thu, 03/20/2008 - 06:38
User Badges:
  • Bronze, 100 points or more

okay i've attached the shows per request.


I think I might see something here. Both systems in question seem to list 4 switches in the master election but both stacks only have 3 swtiches in play. It's been that way since before I started working here but I don't know what causes that. I suspected my predecessor took one out of the stack to deploy elsewhere but have no history to confirm this. I do know that I tried to force the stack to renumber so that it would be top to bottom 1, 2, and 3. All that did was jumble up the port configurations. If fixed it and, if you press the mode button, the stack is numbered 1, 2, and 3, in the order they are placed in the rack but...maybe the problem lies with the fact that it thinks somehow there are 4 switches in there?



Attachment: 
Joe Clarke Thu, 03/20/2008 - 06:43
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Yes, this is what I said previously. You need to remove the switch which doesn't exist from the config. In this case:


no switch 4 provision ws-c3750g-48ts

alanjbrown Fri, 03/28/2008 - 07:03
User Badges:

Joe,

Could you tell me what the patch name/ID is to fix the bug?


Alan

Actions

This Discussion