lms 2.6 - cannot get snmp walk v3 to return context mib data

Unanswered Question
Mar 11th, 2008
User Badges:

I am trying to get Campus Manager to use snmp v3 on 3750 but it appears that CM is not able to query snmp v3 contexted mib data (dot1dBridge). I have read all related posts that I could find but I'm obviously missing something somewhere.


3750 is running 12.2(35)SE2

snmpv3 config:

snmp-server engineID local xxxxxxxxx

snmp-server group v3group v3 auth access 2

snmp-server user v3user v3group auth sha yyyyyy

snmp-server group v3group auth context vlan-154

snmp-server group v3group v3 auth write v1default


snmp v3 non-context queries using SNMP WALK work fine and when I configure snmp v2 community I can also use v2 indexed walks successfully. However when I do a v3 context walk I get this error:


The following is a SNMP walk of device 10.3.154.4 starting from dot1dBridge.dot1dStp.dot1dStpPortTable


SNMP Walk Output

--------------------------------------------------------------------------------

dot1dBridge.dot1dStp.dot1dStpPortTable


BRIDGE-MIB::dot1dStpPortTable = No Such Object available on this agent at this OID


If anyone has some insight it would be greatly appreciated.


Thank you....William

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Tue, 03/11/2008 - 17:10
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

The context config looks wrong, but that may be a typo. It should be:


snmp-server group v3group v3 auth context vlan-154


The object you want to walk in this context is dot1dTpFdbTable (or .1.3.6.1.2.1.17.4.3).

William Stridsland Wed, 03/12/2008 - 10:42
User Badges:

Thank you for responding, Joe.

Sorry, the context config was a typo.

I've now verified the snmp v3 context functionality on the 3750 with a third-party mib browser so I'm left with something not working/configured right in LMS. My next step is to compare network traces from LMS' SNMP WALK tool and the third party browser.


Thx...William

Joe Clarke Wed, 03/12/2008 - 10:49
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

I tested the SNMP Walk tool using Common Services 3.0.6, and it worked for me. If you have CS 3.0.6, enable debugging, then post the specified debug log.

William Stridsland Wed, 03/12/2008 - 12:40
User Badges:

Here's the debug log. I'm noticing that the context isn't included in the arguments list and I've tried to issue the command from the command line but all I get back is a repeat of the OID, like this:


D:\program files\CSCOpx\objects\jt\bin>snmpwalk -v3 -l authNoPriv -n vlan-154 -a SHA -A xxxxxxx -e xxxxxxx -u CiscoWorks -Iu -r 5 -t 10 -d -m ALL

-M ..\jt\mibs nlwes2 dot1dTpFdbTable

dot1dTpFdbTable: (dot1dTpFdbTable)


Thx....William



Joe Clarke Wed, 03/12/2008 - 12:55
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

I found a bug. I'm working on a patch now.

Joe Clarke Wed, 03/12/2008 - 13:18
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Okay, I have a working patch. You need to open a TAC service request to get it. Reference this Netpro thread, and have your engineer contact me directly to get the patch.

William Stridsland Tue, 03/18/2008 - 08:11
User Badges:

Thank you, Joe - SNMP WALK now works correctly for v3 context mib data. I will move on with my original problem of getting Campus Manager to discover correctly.

....William

Actions

This Discussion