is this a switch issue?

Unanswered Question
Mar 11th, 2008

I have 3 routers connected to a switch, see diagram attached.

R1 is set as the default gateway for R2 and R3, R2 and R3 has the same static routing configuration “ip route 0.0.0.0 0.0.0.0 next hop on R1”. R3 can now ping R1 interface connected to the switch, but R2 can't ping R1.

R2 can ping the switch, vice versa. And the switch can ping R1, vice versa. I was wondering if there's problem with the switch, as I can't find any problems. These are very simple configurations which I have done a few times successfully in the past. Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
lamav Tue, 03/11/2008 - 18:19

If R3 can PING R1, that means they both have routes to each other. Good.

If R3 cannot PING R2, and R2 has the static route configured (the same that R1 has), then I would first have to ask if R1 has a route to R2. Does it?

But we really do need more information to give you the right answer.

Why dont you post the configs of each switch's IP interfaces and routing tables so we can see whats going on?

HTH

Victor

wayne_fan Wed, 03/12/2008 - 20:25

Thanks Victor. here're more details, see a detailed diagram attached

Switch:

interface FastEthernet0/2

description To R2

duplex half

speed 10

switchport access vlan 13

!

interface FastEthernet0/3

description To R3

duplex half

speed 10

switchport access vlan 13

interface FastEthernet0/1

description To R1

duplex half

speed 10

switchport access vlan 13

!

Show cdp neighbour

R2 Fas 0/2 128 AS2511-RJ Fas 0/0

R3 Fas 0/3 149 AS2511-RJ Eth 0

R1 Fas 0/1 156 AS2511-RJ Eth 0

R2:

interface FastEthernet0/0

description To switch

ip address 172.26.65.2 255.255.255.192

no ip route-cache

no ip mroute-cache

speed 10

half-duplex

!

ip default-gateway 172.26.65.62

ip classless

no ip routing

R2#sh ip route

Default gateway is 172.26.65.62

Host Gateway Last Use Total Uses Interface

ICMP redirect cache is empty

R3:

R3 has exactly the same configuration as R2, except the E0 interface has different ip address as 172.26.65.3 255.255.255.192

R3 can ping R1 , but R2 can't ping R1. Why?

wayne_fan Wed, 03/12/2008 - 20:26

is it possible that the cable between R2 and switch is having problem? I'm using a straight through cable here.

Actions

This Discussion