Cannot See Cluster ID?

Unanswered Question
Mar 11th, 2008

Hi,

I'm using this topology in my lab for clustering.

as2r4 ---- as2r1

=======================

as2r4#sh run | s router bgp

router bgp 65002

no synchronization

bgp cluster-id 65222

bgp log-neighbor-changes

bgp confederation identifier 2

bgp confederation peers 65001

network 2.2.2.0 mask 255.255.255.0

neighbor 2.2.2.1 remote-as 65002

neighbor 2.2.2.1 update-source Loopback0

neighbor 2.2.2.1 route-reflector-client

neighbor 2.2.2.1 next-hop-self

neighbor 2.2.2.9 remote-as 65001

neighbor 2.2.2.9 next-hop-self

neighbor 2.2.2.34 remote-as 4

no auto-summary

as2r4#sh ip bgp

Network Next Hop Metric LocPrf Weight Path

*> 2.2.2.0/24 0.0.0.0 0 32768 i

as2r4#sh ip bgp sum

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

2.2.2.1 4 65002 41 51 14 0 0 00:38:53 0

2.2.2.9 4 65001 46 50 14 0 0 00:39:22 5

2.2.2.34 4 4 53 46 14 0 0 00:38:47 3

=======================

as2r1#sh run | s router bgp

router bgp 65002

no synchronization

bgp log-neighbor-changes

bgp confederation identifier 2

neighbor 2.2.2.4 remote-as 65002

neighbor 2.2.2.4 update-source Loopback0

no auto-summary

as2r1#sh ip bgp

Network Next Hop Metric LocPrf Weight Path

*>i2.2.2.0/24 2.2.2.4 0 100 0 i

as2r1#sh ip bgp sum

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

2.2.2.4 4 65002 52 42 14 0 0 00:39:26 9

=======================

Router as2r4 is acting as an RR to advertise network 2.2.2.0.

When I do "as2r4#sh ip bgp nei 2.2.2.1 | i Route-reflector Client" on as2r4 it does not show anything. I thought I would get a sign that neighbor 2.2.2.1 is aa RR client.

On the RR client, as2r1,

as2r1#sh ip bgp 2.2.2.0

BGP routing table entry for 2.2.2.0/24, version 7

Paths: (1 available, best #1, table Default-IP-Routing-Table)

Not advertised to any peer

Local

2.2.2.4 (metric 2) from 2.2.2.4 (2.2.2.4)

Origin IGP, metric 0, localpref 100, valid, confed-internal, best

I also can't see that netwok 2.2.2.0 is originated from 2.2.2.4 from cluster 65222.

I'm using "Cisco IOS Software, 3600 Software (C3640-JS-M), Version 12.4(18), RELEASE SOFTWARE (fc1)"

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mheusing Wed, 03/12/2008 - 08:05

Hi,

The cluster ID is only attached to reflected routes, so any route originated by the route reflector will not have the cluster ID.

The next hop 0.0.0.0 indicates as2r4 as the originator for 2.2.2.0/24

as2r4#sh ip bgp

Network Next Hop Metric LocPrf Weight Path

*> 2.2.2.0/24 0.0.0.0 0 32768 i

Second, the "| include" is an exact text search, thus uppercase/lowercase matters.

Try "show ip bgp neighbors | include BGP neighbor|Route-Reflector Client", it should give you the desired output.

Hope this helps! Please use the rating system.

Regards, Martin

davidsudjiman Wed, 03/12/2008 - 15:58

Hi mheusing,

Thanks for your reply. Apparently I do can see the RR client info.

Could you please elaborate "The cluster ID is only attached to reflected routes, so any route originated by the route reflector will not have the cluster ID. "

From your info, I can understand that I won't see cluster ID for 2.2.2.0. Is there anyway I can see my cluster ID?

I tried to check other networks but none show the cluster ID.

This topology actually has several EBGP networks attached to this AS 2.

mheusing Fri, 03/14/2008 - 03:23

Hi,

The cluster ID and Originator ID are used to prevent routing loops in a RR environment. If a RR sees his cluster ID in a received route, it will ignore the route, as it was already reflected by this cluster. If any BGP speaker receives it's own BGP router ID as Originator ID in a reflected route, it is ignored, as the route came from this client.

As long as a route is not reflected by a RR there is no reason to attach cluster ID and Originator ID. In case a RR inserts a route into the BGP table (network command or redistribution) it does not behave as a RR, but as a normal iBGP speaker, thus does not attach cluster ID to the newly created route. This behaviour was observed in your test lab: the cluster ID was not seen for 2.2.2.0/24 inserted into BGP by the RR.

The cluster ID is attached to reflected routes:

Client1 - RR - Client2

If a route is sent by client1 to the RR and then reflected to Client2, you can see the Cluster ID and Originator ID in Client2 for that route.

So you need at least two clients and a RR to see the cluster ID, and one client router needs to advertise a route - internal or external does not make a difference.

Try to start with a simple setup

C1 - RR - C2

and simple BGP configs like:

C1:

interface loopback0

ip address 1.1.1.1 255.255.255.255

router bgp 65000

network 1.1.1.1 mask 255.255.255.255

neighbor 3.3.3.3 remote-as 65000

neighbor 3.3.3.3 update-source loopback0

C2:

interface loopback0

ip address 2.2.2.2 255.255.255.255

router bgp 65000

network 2.2.2.2 mask 255.255.255.255

neighbor 3.3.3.3 remote-as 65000

neighbor 3.3.3.3 update-source loopback0

RR:

interface loopback0

ip address 3.3.3.3 255.255.255.255

router bgp 65000

network 3.3.3.3 mask 255.255.255.255

neighbor 1.1.1.1 remote-as 65000

neighbor 1.1.1.1 update-source loopback0

neighbor 1.1.1.1 route-reflector-client

neighbor 2.2.2.2 remote-as 65000

neighbor 2.2.2.2 update-source loopback0

neighbor 2.2.2.2 route-reflector-client

Then investigate the BGP table and the different routes. In the above example on C1 the C2 route will be a reflected route and only this one will have a cluster ID. Neither the C1 (1.1.1.1/32) route nor the RR route (3.3.3.3/32) will have a cluster ID attached in the BGP table of C1, as they are nor reflected.

Hope this helps! Please use the rating system.

Regards, Martin

Actions

This Discussion