RME shows no device and saying I/O error:file exists

Answered Question
Mar 12th, 2008

hi all,

i am facing a problem that i cannot see any devices on the left panel of RME windows, when i want to generate the syslog report, hardware report and other RME jobs.

then i found that the RMEDbEngine service is not started and if i try to start is manually by using windows services or using CLI command (pdexec), there are errors and the service cannot be started.

in the windows event log, there is an error reported by RMEDbEngine saying that "I/O error:file exits" or "unknown device". any advices?

I have this problem too.
0 votes
Correct Answer by Joe Clarke about 8 years 9 months ago

It sounds like you've take the backup directory (e.g. 0), and replace the CMF, ANI, and DFM components with a more recent copy while keeping RME from last month. That will not work. It sounds like your only recourse at this point is to reinitialize the RME database.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Wed, 03/12/2008 - 10:08

Your database might be corrupt. What files do you have under NMSROOT\databases\rmeng?

thetnaing00 Wed, 03/12/2008 - 18:15

hi Joe,

there are syslog.db files, rmeng.db and rmeng.log files under rmeng folder.

i rename the rmeng.log to another name and try to restart the service using windows services but nothing different as they still show the same error.

Joe Clarke Wed, 03/12/2008 - 18:18

You can't do this. Delete the rmeng.log, then run NMSROOT\objects\db\win32\dbsrv9 -f NMSROOT\databases\rmeng\rmeng.db. Then restart dmgtd.

thetnaing00 Wed, 03/12/2008 - 18:49

hi,

i am using this on windows machine. so do i need to set the environmental variable like on UNIX. i don't know how to set those. if require, could you also show me how to set these in windows. thanks.

regarsd,

Thomas

thetnaing00 Wed, 03/12/2008 - 23:18

hi

now i am on site but i still have the same problem as i run the command you posted last two messges. i deleted the log file, give the permission to the user to full control the rmeng.db file and run the command. the command return the error "error read file (38)" "unknown device error: transaction roll back" and the database process didn't start at all. any more suggestion. thanks.

Joe Clarke Thu, 03/13/2008 - 05:58

Your database is corrupt, then. The only recourse is to reinitialize it. The command is:

NMSROOT\bin\perl NMSROOT\bin\dbRestoreOrig.pl dsn=rmeng dmprefix=RME

thetnaing00 Thu, 03/13/2008 - 06:06

yes joe,

after re-initialization, i think all the data will be lost. do i need to do database backup to get the database? or i don't need to do this at all and it will synchronize with common service database automatically?

i have database backup for RME but it is one version earlier than others such as CMF, and so on. if i need to restore the database, i think that the backup version of all should be the same. is it correct? any suggestion on this. thanks for your help

Joe Clarke Thu, 03/13/2008 - 06:11

Restoring a known good backup is another route you can take. If you restore that backup, you restore EVERYTHING from all apps. This will overwrite your Common Services, Campus Manager, and DFM databases as well as RME. If that is a viable solution, then you can try the restorebackup.pl command. But if you do go the reinitialization route, you will lose all RME data.

thetnaing00 Thu, 03/13/2008 - 06:22

hi,

yes, if i do reinitialization, i will lose all data inside. but can i just use restorebackup.pl command to retrieve the database from database backup which i do regular backup.

Joe Clarke Thu, 03/13/2008 - 06:26

The restorebackup.pl command will restore everything, bot just RME. But as I said, this is an alternative to reinitializing the database.

thetnaing00 Thu, 03/13/2008 - 06:32

ok,joe

then reinitialization is the last resort. if i don't want to lose the data, i must go for restore. am i right?

in this case, what about the version of backup? as i said in my earlier post, the other database backup (CMF,ANI,DFM) are on last week and RME database is on last month. so, is there any issue for that? i once saw the post that there will be database instability if i restore these on different version of backup. please suggest on this as well. if there is no problem, i will go for restoration.thanks for your help

Joe Clarke Thu, 03/13/2008 - 06:37

The backup is all or nothing, so I do not know how you can have a backup of RME that is older than that of CS, ANI, and DFM. If you are referring to an external backup (e.g. Veritas, Legato, etc.) then restoring that will not be possible (i.e. you would not be able to get a working LMS afterward). You would need a CiscoWorks backup taken with the backup.pl command or scheduled through the GUI. Only with that could you ensure that the databases would be consistent with the file system and with each other.

thetnaing00 Thu, 03/13/2008 - 06:41

hi joe,

the situation is we didn't keep version of backup. we just keep only one version of backup. we schedule it though gui and save it on the local machine which run LMS.

last month, everything was fine and the backup was successful. but this month, RME went down before the backup and all other database backup are successful and only RME is not available and backup.log says that it cannot contact RME. that's why i have only RME is not up to date as others.

so,in this case, shall i go for restore everything or if it may lead to database instability, shall i go for reinitialization?

Joe Clarke Thu, 03/13/2008 - 06:45

You will have to restore last month's backup alone. This will revert all changes that were made over the previous month.

thetnaing00 Thu, 03/13/2008 - 06:50

hi joe,

sorry for my question. but now the situation is that the versions are mix and match. i don't have last month backup for other database apart from RME. only RME is last month and all others are this month. if i restore like this, any problem? this is my concern.

if it is, i won't go for restore. i simply go for reinitialization.

Correct Answer
Joe Clarke Thu, 03/13/2008 - 06:52

It sounds like you've take the backup directory (e.g. 0), and replace the CMF, ANI, and DFM components with a more recent copy while keeping RME from last month. That will not work. It sounds like your only recourse at this point is to reinitialize the RME database.

thetnaing00 Thu, 03/13/2008 - 06:55

i really appreciate your help. thanks alot. this clarify my thoughts.

Actions

This Discussion