Dynamic Route Failover

Unanswered Question
Mar 12th, 2008
User Badges:

Hello,


I am trying to get our network traffic to dynamically pick the best route out/in in case of a link failure. I have attached a diagram showing our current router links. The majority of the links are connected to the end-point routers using wireless backhaul bridges. We have two connections forming a ring back to our central noc. (DS3, and PTP fiber connections). Can any one help with this?



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
fahad.sheikh Wed, 03/12/2008 - 08:57
User Badges:

Can you be specific where u want to acheive this.


My suggetion would be you can use HSRP with interface tracking...

Jesse Hottle Wed, 03/12/2008 - 09:11
User Badges:

Hello,


Any of the router links that go dead, is where I need fail over to take place and re-route customer traffic. Example, router E has three Fe100 interfaces. 1 is directly attached to backhaul bridge, 2 is connected to another backhaul bridge going opposite direction, and 3 would be connected a switch, which feeds various access points which are serving customers for internet access. If INT 1 goes down, I need traffic to route out of INT 2, etc.. Same for all the other connected routers and layer 3 3550.


I do not think all my routers support HSRP, and I am not in a position to upgrade IOS at this time. We have a mixture of static routes, and EIGRP as our routing protocol. All connections eventually terminate at our core 7507 (one is a FE100 interface, the other a serial DS3 connection). We are trying to build a ring to ensure as close to 99% uptime as possible. Also, this got thrown in my lap, so I am a little lost on what to do.


Thanks again for the replies...



Jesse Hottle Thu, 03/13/2008 - 07:22
User Badges:

Can anyone assist in the HSRP configuration? My routers all support this, but I am not sure the best why to setup the virtual routers, or more importantly on which ones.


In some examle I have read, the Active and Standby virtual routers are residing on the same physical subnet. Do I have to set the routers in this way?


Any help would be appriciated.


Thanks

Istvan_Rabai Sun, 03/16/2008 - 00:09
User Badges:
  • Gold, 750 points or more

Hi Jesse,


Here's a sample configuration of an HSRP pair:

Both Fa0/1 interfaces are in subnet 192.168.1.0/24 (the LAN of hosts), through which hosts reach remote subnets.

Router 1 and Router 2 are the default gateways for these hosts in a redundant pair.


Router 1:


conf t

interface Fa0/1

ip address 192.168.1.1 255.255.255.0

no shutdown

standby 1 ip 192.168.1.10

standby 1 priority 200

standby 1 preempt

standby 1 track serial0/1 50


Router 2:


conf t

interface Fa0/1

ip address 192.168.1.2 255.255.255.0

no shutdown

standby 1 ip 192.168.1.10

standby 1 priority 180

standby 1 preempt

standby 1 track serial0/1 50


This is probably one of the simplest configurations for interface tracking, that track the state of interfaces serial0/1. You can track multiple interfaces the same way.

Note that ip addresses, interface numbers and standby group number are just examples. You should use your own values.


This will provide you a redundant configuration, but only one HSRP router will be active at a time. So one router will always be idle.


However, you can configure load balancing as well with a symmetrical configuration for standby group 2.


The configuration I provided you makes Router 1 as active and Router 2 as standby.


This is done by setting the priority of Router 1 to 200, which is higher than the priority value of Router 2 of 180.


When interface s0/1 goes down on the active router, interface tracking will lower the priority of the router by 50 (the configured value in the standby track command), so its priority will be 150.


At this time, the priority of the standby router becomes higher (180 configured) and will take over the active role from router 1. This is configured by the standby preempt command.


If interface s0/1 comes up again, router 1 will take over the active role again.


Here's the load balancing symmetrical config:


Router 1:


conf t

interface Fa0/1

standby 2 ip 192.168.1.20

standby 2 priority 180

standby 2 preempt

standby 2 track serial0/1 50


Router 2:


conf t

interface Fa0/1

standby 2 ip 192.168.1.20

standby 2 priority 200

standby 2 preempt

standby 2 track serial0/1 50


In this config router 2 will be active and router 1 will be standby. The takever mechanism is the same: router 1 will take ober from router 2 if interface s0/1 goes down, and take over back if it goes up again.


You need to configure one half of the host PCs with default gateway address 192.168.1.10, the other half with default gateway address 192.168.1.20.


Cheers:

Istvan

Jesse Hottle Mon, 03/17/2008 - 10:08
User Badges:

Hello Istvan,


I thought I might need to clarify my needs, so I have attached a simpler network diagram. On the attached drawing, I basically need a setup that will allow my network nodes to still route traffic back to our core 7507 router and onto the internet in the event that any of the interface links on routers A, B, or C happen to go down or fail in any way. I am in the process of completing the configuration of EIGRP as our primary routing protocol for route distribution. Behind each router(A,B,or C), I have multiple secondary IP subnets setup serving hundreds of customers.


So if s0/0 fails on Router A, I would need inbound/outbound traffic to route out the interface f0/1 to the next attached router B and so on..


I am not really concerned with load balancing at this time. But redundancy in the event of a link failure is key.


Thanks for any help.


j



Istvan_Rabai Tue, 03/18/2008 - 14:31
User Badges:
  • Gold, 750 points or more

Hi Jesse,


Sorry for the late response. Today I could free an hour to sit behind the NetPro forum.


The config you provided will give you that failover redundancy you need without HSRP.


If s0/1 goes down on router A EIGRP will automatically use the alternate route through fa0/1 if it is available. And every other router will do the same.


HSRP is needed primarily for default gateway redundancy, though it has a failover feature through interface tracking.

For HSRP you need at least 2 routers for the LAN segment or the VLAN where you want to provide gateway redundancy.


This means you would need 2xRouterA, 2xRouteB, 2xRouterC, just to be simple.


Cheers:

Istvan

Jesse Hottle Thu, 03/27/2008 - 07:08
User Badges:

Hello,


Would it be possible to get some config assistance for using OSPF on this network diagram. I believe this is what we are moving over to, and I got no experience with this routing protocol. Plus, we are going to be integrating other "non-cisco" devices.


What is confusing me is the multiple areas and stub networks. Or do I even need multiple areas?


anything would be great.

Istvan_Rabai Thu, 03/27/2008 - 11:03
User Badges:
  • Gold, 750 points or more

Hi Jesse,


Moving to OSPF is a good idea in case you integrate non-cisco devices.


The topology you provided in the Redundant_Project_Simple file, is not so big to be worth bothering with multiple areas at the moment.


Configure all interfaces of all routers for area 0.


Later, if the network grows, then you can use this area 0 as your backbone and expand your network in the locations where your 2950 switches are located now.


Or the number of locations may grow as well, then you can revise the configuration depending on the topology changes.


What is exciting: what is in the NET cloud and how will the OSPF connect to this cloud?

Could you provide info on this?


If you need help in the specific OSPF configurations, please tell me and I will try to post some configs here.


Cheers:

Istvan

Jesse Hottle Thu, 03/27/2008 - 11:43
User Badges:

HI, and thanks for the response. The idea behind OSPF is that we are in the process of integrating with another ISP, and they use limited Cisco gear and all OSPF for their routing protocol. I want both network to be consistant. Our core routing will be all Cisco and I hope to integrate EIGRP, OSPF, and BGP (other OSPF network is on a different carrier).


As for the NET cloud, that basically represents the Internet via our upstream provider. Right now we just get our Internet hand off on a 100mb ethernet connection, directly connected to our Core Router (A) on a /30 subnet. We use a default route at the core (i.e. 0.0.0.0 0.0.0.0 x.x.x.x.)


I could use any config help possible. I am very new to OSPF. Keeping everything on Area 0, helps clarify things for me. I was concerned with virtual-links, etc.. and I have not got my lab fully setup, plus I am lacking some test equipment at this time.


Any help would be great, and I can answer all questions as best as possible.


Thank again,


j

Istvan_Rabai Sat, 03/29/2008 - 12:54
User Badges:
  • Gold, 750 points or more

Hi Jesse,


Sorry for the late response, I do not log in to the NetPro forum every day.


Some simple OSPF config would be for Core router A in the Redundant_Project file for example:


[Router A config, sample values]


interface serial 1/0

description DS3 to Router B 7206

ip address 192.168.1.1 255.255.255.252


interface fastethernet 1/0

description 100Mbps fiber to Router F 7206

ip address 192.168.1.5 255.255.255.252

ip ospf network point-to-point


interface fastethernet 1/1

description 100Mbps to ISP

ip address x.x.x.1 x.x.x.x

no cdp enable [this may be needed for security purposes, the router will not send CDP packets to the ISP]


router ospf 1

log-adjacency-changes

network 192.168.1.1 0.0.0.0 area 0 [this places interface serial 1/0 into area 0]

network 192.168.1.5 0.0.0.0 area 0 [this places interface fastethernet 1/0 into area 0]

default-information originate [this command causes ospf to send a default route to the internal ospf network, so internal routers know how to reach the outside world]


ip route 0.0.0.0 0.0.0.0 x.x.x.2 [default route to the ISP]


Notice, that I do not start the ospf process on interface fastethernet1/1, because there is no need to exchange updates with the ISP router. You will use a default route to reach the Internet. You need to check with the the ISP that they have a route to your edge router (or to your network) so the reverse traffic to your company can be routed.




[Router F config, sample values]


interface fastethernet 1/0

description 100Mbps fiber to router A 7507

ip address 192.168.1.6 255.255.255.252

ip ospf network point-to-point


interface fastethernet 1/1

description 100Mbps to router E 7206

ip address 192.168.2.1 255.255.255.0 [this is a /24 subnet, as there are switches and hosts on this subnet, but its size may be different depending on the number of hosts residing in the subnet]


router ospf 1

log-adjacency-changes

network 192.168.1.6 0.0.0.0 area 0

network 192.168.2.0 0.0.0.255 area 0



The config for the rest of the routers is similar. You just need to adjust the correct ip addresses and masks on every config line.


I hope this will help you with the start.


Please write if you need help with the configuration of the other routers or switches.


Cheers:

Istvan

Jesse Hottle Tue, 04/01/2008 - 07:36
User Badges:

Hello,


Thanks for the response and info. I am going to setup a test lab and play around with this setup. Are there any issues with OSPF and secondary IP addresses on router interfaces?


Thanks again for the tips and info.


j

Istvan_Rabai Tue, 04/01/2008 - 12:39
User Badges:
  • Gold, 750 points or more

Hi Jesse,


As far as I know there are no issues with the secondary IP addresses.


You only need to be aware that OSPF builds up neighbor relationships and sends routing updates using the primary ip address as the source address.


So don't use the secondary ip addresses to build ospf neighbor relationships.


But you can use the secondary ip address as the default gateway address for hosts on the ip subnet of the secondary ip address.


Cheers:

Istvan

Jesse Hottle Fri, 04/04/2008 - 10:30
User Badges:

Hello Istvan,


On the routers running ospf do I still need to add a default route on each router?

Istvan_Rabai Fri, 04/04/2008 - 11:01
User Badges:
  • Gold, 750 points or more

Hi Jesse,


By the suggested config Router A should inject a default route into the internal ospf domain.


This is why I put the "default-information originate" command into the ospf config of router A.


So no other default route config is necessary.


Cheers:

Istvan

Jesse Hottle Fri, 04/04/2008 - 11:08
User Badges:

Thanks for the response..


Also, on all the router interfaces that are directly connected to other routers, should I always use the ip ospf network point-to-point command on that specifc interfaces?


Also, on the ospf network configs you have an inteface assigned as 192.168.1.1 and 192.168.1.5, but within the global ospf config you list the adversitzed networks as 192.168.1.1 0.0.0.0 and 192.168.1.5 0.0.0.0 (why are these not 192.168.1.0 0.0.0.3)..


And on the interface that is connection to a switch for end-users you have 192.168.2.1 255.255.255.0, but on the ospf global you have 192.168.2.0 0.0.0.255)?


Just trying to clarify this up some for my own knowledge.


Thanks again,


J

Istvan_Rabai Fri, 04/04/2008 - 20:02
User Badges:
  • Gold, 750 points or more

Hi Jesse,


Your 1st question:

I used to specifiy "ip ospf network point-to-point" on links that are point-to-point.

The link between Router A and Router F is a fiber optic circuit and it is point-to-point (only these 2 routers are on this link).


If you specify the network type for ospf "ip ospf network point-to-point", the 2 routers form a neighbor relationship automatically but without the use of a designated router (DR)and backup designated router (BDR).


DR and BDR are necessary only when you have more than 2 routers on a broadcast link, or a full mesh of connections on a non-broadcast multiaccess link (e.g. frame relay).


Not using a DR and BDR saves memory and processor cycles for the routers.




Your 2nd question:

0.0.0.0 wildcard mask specifies that all bits of the given address need to be compared with the interface addresses.

The implication of this is that only one interface will be included in the ospf process: the one that has the exact 192.168.1.1 address.


192.168.1.0 0.0.0.3 will achieve the same result in this specific configuration, so you can use it as well.




Your 3rd question:

192.168.2.1 255.255.255.0 specifies the ip address of an interface and its subnet mask.


192.168.2.0 0.0.0.255 uses a wildcard mask instead of a subnet mask.


This wildcard mask means this: 00000000.00000000.00000000.11111111


The bits of the address 192.168.2.0 must be compared with the addresses of the interfaces on the router, where 0s are specified in the wildcard mask.

Where 1s are specified, these are "don't care" bits, there is no need for comparison.


The above wildcard means then: only the leftmost 3 octets must be compared. If these bits match, then the interface is selected under the ospf process.


This is not the same as the subnet mask, where the 1s and 0s must be contiguous.


For a wildcard mask there is not a requirement for 0s and 1s to be contiguous You can have a wildcard mask like this:


00000000.00000000.11111101.11111111

(0.0.253.255)

In this case bit 2 of the 3rd octet is 0, all other bits are 1.

This requires the respective bit of that octet to be compared with the interface addresses. All bits with value 1 don't have to be compared. Bit 1s are called "don't care" bits.


Cheers:

Istvan

Istvan_Rabai Sun, 04/06/2008 - 03:49
User Badges:
  • Gold, 750 points or more

Hi Jesse,


Although you didn't mention if you will use a private address space within your internal ospf domain, my supposition is that you will use a private address space.


If this is true, then let me make an addition to the configurations I posted for you beforehand:


If you use private addresses in your internal ospf domain, you will need to do NAT address translation. It is configured on Router A the following way ( I post the modified config for Router A here):



[Router A config, sample values]


interface serial 1/0

description DS3 to Router B 7206

ip address 192.168.1.1 255.255.255.252

ip nat inside [part of the NAT config]


interface fastethernet 1/0

description 100Mbps fiber to Router F 7206

ip address 192.168.1.5 255.255.255.252

ip ospf network point-to-point

ip nat inside [part of the NAT config]


interface fastethernet 1/1

description 100Mbps to ISP

ip address x.x.x.1 x.x.x.x

ip nat outside [part of the NAT config]

no cdp enable [this may be needed for security purposes, the router will not send CDP packets to the ISP]


router ospf 1

log-adjacency-changes

network 192.168.1.1 0.0.0.0 area 0 [this places interface serial 1/0 into area 0]

network 192.168.1.5 0.0.0.0 area 0 [this places interface fastethernet 1/0 into area 0]

default-information originate [this command causes ospf to send a default route to the internal ospf network, so internal routers know how to reach the outside world]


ip route 0.0.0.0 0.0.0.0 x.x.x.2 [default route to the ISP]


ip nat inside source list 1 interface fastethernet1/1 overload [part of the NAT config]


access-list 1 permit 192.168.0.0 0.0.255.255 [part of the NAT config]



I hope this will give you an additional help in your configuration work.


Cheers:

Istvan

Jesse Hottle Sun, 04/06/2008 - 17:55
User Badges:

Hello,


I had not planned on using NAT, as I am afraid this will causes issues when we begin using BGP along with OSPF for other networks we are going to be routing through our network backhauls. Woudl this cause a problem? Why would you recommend NAT?


Thanks again for the responses.


J

Istvan_Rabai Sun, 04/06/2008 - 20:47
User Badges:
  • Gold, 750 points or more

Hi Jesse,


NAT is only needed when you use a private address range within your internal ospf domain. Private addresses are not routable on the Internet.


If you have enough public ip addresses for use within your network, then it is not necessary to use NAT.


Cheers:

Istvan

Jesse Hottle Mon, 04/07/2008 - 09:00
User Badges:

Hello again,


I got a question on Secondary router interfaces. Do I need to use any ip ospf commands on these secondary interfaces (i.e f0/0.1 and f0/0.2)? Or can I just enable OSPF on the primary interface of f0/0?


Thanks,


Jesse

Istvan_Rabai Mon, 04/07/2008 - 09:18
User Badges:
  • Gold, 750 points or more

Hi Jesse,


What what would be the purpose of using subinterfaces?


Generally speaking, there is no problem of using them, but why isn't the main interface enough?


Cheers:

Istvan

Jesse Hottle Mon, 04/07/2008 - 09:29
User Badges:

Hello,


On one of the router interfaces for client nodes, switches, etc.. I have the interface connected to a switch trunk port. One the switch have I have other devices on seperate vlans. I need each vlan to be on its own subnet, hence the sub-interfaces on the router side interface.


J

Istvan_Rabai Mon, 04/07/2008 - 21:07
User Badges:
  • Gold, 750 points or more

I undestand.

This is a an intervlan routing configuration then.

Its popular name is router on a stick.


If you need help in this config, please tell me.


How is the ospf configuration proceeding. Is it working well?


Cheers:

Istvan

Jesse Hottle Tue, 04/08/2008 - 05:14
User Badges:

Hello,


I got the router on a stick config covered, just wondering how this would work with OSPF. I will be integrating this setup into our network this evening and will let you know how things go.


thanks again.


j

Jesse Hottle Thu, 04/17/2008 - 23:10
User Badges:

Hello,


I got all the routers installed and running OSPF. Dynamic fallover is working well, however there is an issue with the paths traffic is following. Traffic seems to be unbalanced between different outbound routes. Is there a way for specify a prefered route for each interface or subnet?


Thanks again,


j

Jesse Hottle Thu, 04/17/2008 - 23:16
User Badges:

Also, I got one L3 3550 running three ospf interfaces. Two of the interfaces are connected to seperate links on the ring, but the third is attached to a single router. I am not sure if I have configured this router correctly.


thanks,


j

Istvan_Rabai Fri, 04/18/2008 - 08:15
User Badges:
  • Gold, 750 points or more

For the L3 3550 you can post interface and ospf configs here and I will check.


Cheers:

Istvan

Istvan_Rabai Fri, 04/18/2008 - 09:09
User Badges:
  • Gold, 750 points or more

Hi Jesse,


This config seems to me OK, with one reservation:


Why do you configure the secondary ip addresses on Fa0/1, Fa0/2 and Fa0/3?


As far as I understand, they are point-to-point interfaces to another layer3 switch or router.


So there is no reason to define an additional subnet on that link. Or is there?


Can there be hosts on the secondary subnet?


Thanks:

Istvan



Jesse Hottle Fri, 04/18/2008 - 09:18
User Badges:

There are backhaul units that I need management IP addresses on. I didnt want them to be on the same address space as the routable inteface IP's.


How can I change the default costs for routes. I want some traffic to route out different paths as a priority.


J

Istvan_Rabai Fri, 04/18/2008 - 20:58
User Badges:
  • Gold, 750 points or more

Hi Jesse,


If you want to change the default cost of the default route you need to apply this command:


default-information originate metric xxx metric-type [1|2]


If you want to change the default cost of other routes you can do it by several ways:


1. On interface level change the bandwidth parameter of the interface, like this:

interface fastethernet 1/1

bandwidth 100000 (kbits per second)


2. On interface level you can use the "ip ospf cost x" command


3. Under the routing process you can change the auto-cost reference-bandwidth:


router ospf 1

auto-cost reference-bandwidth 1000


Default is 100, which means the ospf process will calculate the interface cost according to this:


cost= 100*1000,000 / bandwidth (Mbps)


This is why the default cost of a fastethernet link is 1.


If you increase the auto-cost reference-bandwidth to 1000 (for example) then the ospf costs of ALL interfaces on that router will be multiplied by 10. This gives you more granularity in applying ospf cost to interfaces.


It is recommended to use this command on all routers within the network, and then use the bandwidth and/or ip ospf cost commands to set the desired link costs.


Cheers:

Istvan





Jesse Hottle Sat, 04/19/2008 - 06:24
User Badges:

If all the interfaces are fastethernet then why wouldn't I want to assign a cost reference of 1000 to each? Also, I got a big problem with traffic not routing anything out at all over one of the ospf links on the 3550. Traffic seems to only be going one way, when a shorter path is available.

Istvan_Rabai Sat, 04/19/2008 - 09:09
User Badges:
  • Gold, 750 points or more

Hi Jesse,


This is the normal behavior of routing protocols: they install the least cost routes in the routing table.


This implies that the router will route traffic through the least cost route (shorter path).


So this should not be a problem.


Anyway, if you want to route traffic through another interface, then you can play around with the link costs.


If you want to route a specific well-defined traffic through another interface, then you can use policy based routing.


Cheers:

Istvan

Jesse Hottle Sat, 04/19/2008 - 13:24
User Badges:

Hello again,


Is there a reason on my serial ds3 connection to router A, that I am not using an ip ospf network type command on each interface? Just trying to understand why that is.


Thanks,


j

Jesse Hottle Sat, 04/19/2008 - 13:34
User Badges:

Hello,


I tried changing the interface costs on the 3550. I set on to a cost of 20 the other to a cost of 10. I want all traffic to route out the interface with a cost of 10, but still there is zero traffic passing this interface. The only traffic that passes is if I login to the switch on the IP assigned to that int.


This has me stumped. Everything else appears to be ok.

Istvan_Rabai Sat, 04/19/2008 - 23:10
User Badges:
  • Gold, 750 points or more

Hi Jesse,


You should have a look at the cost of a whole path in the routing table of the 3550. (show ip route)


The cost of a path is the summarized cost of all links that lies between the source and destination.


This summarized path cost should be the least cost path for it to be elected into the routing table.


So if you change the ip ospf cost of one interface only in the path, that may not be enough.


Probably the cost of the DS3 line contributes the most to the path cost.


You should then change the cost of this interface on router B (in the Redundant Project.bmp file).


BUT: you should be aware that if you change the cost of the DS3 interface this will change the costs of routes in all ospf routers, and thereby rearranging the routing tables in some routers.


One way is to play around with the cost of this interface.

Another way may be to install a static route into your 3550 for some destinations via the DS3 link.

A third way may be, as I mentioned earlier to use policy based routing for some well defined traffic types to override the contents of the routing table.



Concerning your previous question on the DS3 line: The reason you may have this line is for redundancy at least. So if one of your routers or links goes down to router A, then you will have an instantaneous failover to the other route towards router A.


Otherwise, I'm glad everything else works fine.


Cheers:

Istvan

Jesse Hottle Sun, 04/20/2008 - 07:07
User Badges:

I think my routing tables are creating a loop to one of the networks behind one of the 3550's. Running the trace command from any routers other that the CORE Router A, takes forever to complete, if it even does. Traces from Router A fly right out. However, I have no issue pinging any network I have being advertised.


Also, the link in question does failover if I disable the other connected path, traffic flows just fine. Do you recommend any thing for maybe load balancing on just this router? Also, it seems my routing tables are way, way to big.



Istvan_Rabai Sun, 04/20/2008 - 07:39
User Badges:
  • Gold, 750 points or more

Hi Jesse,


Based on the drawings I had no idea that your network will grow up so big :)


If you consider your routing tables are too big, then you can make the networks behind your 3550s and 7206s different OSPF areas and then summarize those routes into the backbone with the "area x range" command.


By backbone I mean the ring formed by the 7507, 3550s and 7206s on the Redundant_Project.bmp file.


So the interfaces in this backbone should remain in area 0, and interfaces going away from this ring can be different areas, like 1, 2, 3, 4.


I don't see in your drawing how many subnets are behind the different routers. If there are more than 1, then it may be worth to create an area out of them and then summarize the routes within each area into the backbone as one summarized route.


For this, the addressing scheme needs to be hierarchical.


This means that if there are 4 subnets behind a 3550, then they should be easily summarizable, like the following:


1. 10.1.0.0/24

2. 10.1.1.0/24

3. 10.1.2.0/24

4. 10.1.3.0/24


These 4 subnets then can be summarized into 10.1.0.0/22


If these subnets would be in area 1 on a 3550 then the summarization would look like this:


router ospf 1

area 1 range 10.1.0.0 255.255.252.0


And this would reduce the size of the routing tables in your backbone (area 0) by advertising only 10.1.0.0/22 into the backbone.


For area 2 you could use the 10.2.0.0 range and the summarized route would began with the 10.2. prefix.


This way it would be easily seen in each backbone router which area the given summarized route belongs to (this is just for the readability of your routing tables).


Of couse, these are just general hints, you should consider your specific adressing scheme and adapt all this to it, if you think these are adaptable.


Cheers:

Istvan

Jesse Hottle Sun, 04/20/2008 - 15:57
User Badges:

What about IP subnets that are spread out across multiple routers?


Example:


Router B - 192.168.2.0/24

192.168.3.0/24


Router C - 192.168.4.0/24

192.168.5.0/24


Router D - 192.168.6.0/24

192.168.7.0/24


Also, I only have 2 routers that are not directly attached to the backbone. And I think putting those within there own area is a good idea. I have many subnet spread throughout this network, up to 30 full class "C"'s subnetted all over the place.


Istvan_Rabai Sun, 04/20/2008 - 16:15
User Badges:
  • Gold, 750 points or more

Hi Jesse,


Yes, it's a good idea to put those routers with up to 30 subnets within their own area.

Don't forget to summarize the address range on the area border router (the router connecting the backbone area 0 and this area) with the "area x range" command as I mentioned earlier.


If that area is not connected anywhere else just to the backbone, then you can also configure them as stub areas.


The good thing with stub areas is that the area border router (the router connecting the backbone area 0 with the stub area) injects a default route into the stub area.


So the routing tables within the stub area will be smaller.


This is just an idea from my side.


Your consideration is needed.


Cheers:

Istvan


Jesse Hottle Sun, 04/20/2008 - 16:26
User Badges:

I didnt want to configure them as stub areas because soon we will have redundant paths to these locations as well, and I would just have to change it. Thanks for explaining the summarization, I a little iffy in it, but worth a test. If I sent you a config of one of my two connected routers, could you check it out?


thanks again,


j

Jesse Hottle Mon, 04/21/2008 - 04:46
User Badges:

I am going to put together a new diagram, showing the non-backbone attached routers as well as configs for some of the routers. I also think the way we have some of our private IP ranges defined, is causing some issues and preventing me from making some of the changes needed.


I'll post ASAP.


Thanks,,


j

Jesse Hottle Mon, 04/21/2008 - 08:07
User Badges:

Hello,


I have attached a full network diagram. This is accurate. I have also attached dumps for some of the connected routers. The interface labels on the diagram to no match the dumps, not to confuse you.



On the diagram router M is the single network we discussed adding to its own area, which I want to do. Little confused on the setup, but I dont think it will be an issue. Our biggest problem is that we sigle class "C" subnets spilt up across multiple routers. I dont know how that would be summarized. Each router has multiple hosts and devices attached. I did not put that in the diagram.


j



Istvan_Rabai Mon, 04/21/2008 - 09:48
User Badges:
  • Gold, 750 points or more

Hi Jesse,


I have just downloaded the files. I will look over the configs and return to you.


This may take some of out of work time, so it can happen that I will return to you tomorrow or after tomorrow.


Cheers:

Istvan

Jesse Hottle Mon, 04/21/2008 - 10:02
User Badges:

Cool and thanks. I am going to start resubnetting parts of the network off the 192.168.x.x subnets and take your advice on using a 10.x.x.x approach. Think this will greatly clean up the routing tables and be better organized.


thanks again,.

Actions

This Discussion