BGP next hop ??

Answered Question
Mar 12th, 2008

Scenario :-

R1--IBGP--R2--EBGP--R3

R2 applies community AS:NN to inbound updates of R3

route-map test permit 10

set weight 0

set origin igp

set community AS:NN

then while sending the updates to R1 and applies the following route map

route-map set-next-hop permit 5

match community comm

set ip next-hop loopback0

loopback0 is the R2 loopback IP address.

ip community-list standard comm permit AS:NN

While I do (on R2) "show ip bgp neigbors <R1-router id> advertised-routes", I can see that next hop of R3 prefixs is not changed.

but at R1, its getting R3 prefix with next hop as R2 loopback0.

anyone who can help here ???

Correct Answer by Harold Ritter about 8 years 11 months ago

Rajat,

This is also normal behavior. These counters displayed in the output of the "show route-map" are only incremented if the route-map is used for the purpose of Policy based routing (PBR).

Regards,

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
devang_etcom Wed, 03/12/2008 - 10:19

peform soft reset...

clear ip bgp {* | address | peer-group-name} soft in

regards

Devang

rajatsetia Thu, 03/13/2008 - 07:18

Hi Devang,

sorry for the delay in reply ...kinda busy in some other issue but I tried soft reset but no luck...

I got one reply from Harrold, and I kinda agree with him...

Thanks for your reply mate

rgds

Harold Ritter Thu, 03/13/2008 - 06:06

Rajat,

This is normal behavior as the output of this command shows only the routes that made it through the outbound policy but it doesn't reflect the attribute alterations applied by this same outbound policy. In other words it shows these routes with the same attributes they have in the bgp loc-rib.

Hope this helps,

rajatsetia Thu, 03/13/2008 - 07:15

Hi Harold,

Thanks mate, you explanation makes sense..

ok then if there is a case that I donnt have access to R1 and I have to make sure that outbound policies have been applied at R2.

how can I check at R2 and the weird part is that I am not able to see any matches when do "show route-map " ..

rgds

Harold Ritter Thu, 03/13/2008 - 09:46

Rajat,

One way I know if you have absolutely no access to R1, is to use "deb ip bgp upd ". The ACL could be limited to one prefix send to that specific neighbor (R1). This will give you the attribute as updated by the outbound policy.

Regards,

rajatsetia Thu, 03/13/2008 - 12:14

Harrold,

so we are left with last resort i.e. debug ...

If I think abt the order of operation of changing the attribute, kinda agree with you that only debug will give the correct picture ...

have you thought about the other aspect of why there are no matches shown for "show route-map " command ..

Regards

Correct Answer
Harold Ritter Thu, 03/13/2008 - 14:24

Rajat,

This is also normal behavior. These counters displayed in the output of the "show route-map" are only incremented if the route-map is used for the purpose of Policy based routing (PBR).

Regards,

rajatsetia Fri, 03/14/2008 - 05:03

Hi Harrold

hmmm now I know where the problem, its in my head :)

configuration is correct , everything is working fine and all the operations are normal and still i got ?? in my head ...

but this discussion does cleared lot of things, it was kind of reminder for me to stick to the basics while solving any problem..

yeah, you are correct again, when we do show route-map, its output says "policy routing matches " ...

Thanks a lot mate ..

regards

Actions

This Discussion