Dial Peer Help

Unanswered Question
Mar 12th, 2008

I have central call processing, 2 offices, each with their own GWs.

I am having trouble with international calls from one of the offices (Office A). My international Route Pattern (INT_RP)in CM is simply a 9.@ for Office A. For Office B (INT_RPB)it is 9011!

Both Offices only have 9. pots dial peers in GWs.

Is the problem that I need a dial-peer of 9011T in the GW of Office B??

Will rate Posts.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Rajesh Revuru Wed, 03/12/2008 - 11:33

Yes you would need a dial Peer 9011T on the gateway even if you have it on the CM. Just copy the existing dial-peer(do not forgot to change voice port info) from the working gateway to not-working gateway.


mparella Wed, 03/12/2008 - 12:03

No luck. Still getting busy tone. I can post my dial peers if that helps?

mparella Wed, 03/12/2008 - 13:40

I believe I captured enough from the call. Let me know if you need more. The called party was 011442077971076.

Thanks again!

Rajesh Revuru Wed, 03/12/2008 - 13:50


It says invalid number format as the error, can you post the dial-peer now from working and non-working gateway.

Cause i = 0x809C - Invalid number format (incomplete number)

mparella Wed, 03/12/2008 - 13:55

Interesting. Here is the dial peer I added to the GW that does not work. It is exactly the same as the other.

dial-peer voice 89 pots

destination-pattern 9011T

progress_ind setup enable 3

progress_ind alert enable 8

progress_ind progress enable 1

progress_ind connect enable 1


port 0/0/0:23

prefix 011


dial-peer voice 88 pots

preference 1

destination-pattern 9011T

progress_ind setup enable 3

progress_ind alert enable 8

progress_ind progress enable 1

progress_ind connect enable 1


port 0/1/0:23

prefix 011

Rajesh Revuru Wed, 03/12/2008 - 14:07

Can you compare under the call manager administration page H323 Configurations for both working and non-working gateway setting for

1.Called Numbering plan

2.Calling Numbering Plan

Both of them should be Cisco Call Manger

Let me know

mparella Thu, 03/13/2008 - 05:10

Sorry, I am back. I attached a screenshot of the fields from the gateway configs in CM that I believe you were asking about. The page in the left is the one that does NOT work. There are some values that are different, could this be a problem? Are you thinking that those values be the same?

Thanks again for all of your help. I'll be esure to rate your assistance.

Rajesh Revuru Thu, 03/13/2008 - 09:54

Mostly probably yes, can you adjusting the values for the not working one according to the working one.

Let me know

mparella Thu, 03/13/2008 - 10:58

Yes, i am goign to make the changes. I can't do it right now because I will more than likely have to reset the gateway which will drop calls.

Standby, I will le tyou know how we make out.

Thanks again, I really appreciate you helping me out.

mparella Fri, 03/14/2008 - 04:31

Still no change, cannot place the international calls and the Gateway settings are matching. I double checked with my provider and we do in fact have international service.

I'm out of ideas. Any other thoughts?

Thanks again!

mattcalderon Fri, 03/14/2008 - 05:56

Have you tried a csim start and ran a debug on the ISDN and pots dial-peer? If the call is successful then you can rule out possibly any gateway config and look more at the configs on the ccm.

mparella Fri, 03/14/2008 - 07:39


Not sure how to do that. If it's noty too detailed for you to do, can you send me a quick instruction on that.

Will rate post.

Steven Landon Sun, 03/16/2008 - 08:03

are you discarding the 9 at the call manager? if not....do so.

remove the 9 on the dial peer

get rid of the prefix under the dial peer and add "discard-digits none"


mparella Sun, 03/16/2008 - 11:19


Appreciate your input.

On the CM Route Pattern configuration I have discard digits as "Pre-dot" now, originally I had "none". I removed the 9 from the dial-peer and the prefix from the dial-peer.

Now at least I am getting a message fro the provider saying "call cannot be completed as dialed". Is there something else I need to present to them.

Will rate, thanks!

Paolo Bevilacqua Tue, 03/25/2008 - 05:25

Hi, the problem is that the setup is sent as "international" type AND the prefix 011 is present, that is an invalid configuration.

The way it works, normally internatiol calls are "unknown" type and the 011 prefix.

OR, you set international type call, and the number begins with the country code and no prefix. But, I've never seen anybody doing that and I would no recommended that.

So you need to go into whatever CM or router config where you specified "international" and take it away.

mparella Tue, 03/25/2008 - 05:35

Understood. Do you hapeen to know where this specific setting might be located? I attached a screenshot of my GW setup for outbound. I am running H.323 and my route pattern is just a 9.@ for international. I also noticed the "Route Filter" which I am not familiar with.



This Discussion