Can't get interfaces up together

Unanswered Question

I have a 2620 and a 2610 router. Hardware is not the issue because when I did a hardware reset indivuidually the interfaces came up fine. However, once I used a crossover cable, I can't get them to be up together. I am so mad because the process is so simple and it's kicking my behind. Any suggestion will be appreciated, family

-JMF

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Richard Burts Thu, 03/13/2008 - 08:17

JMF

Is there possibly any problem with the cross over cable? Is there possibly a speed mismatch between the interfaces?

It would be helpful if you would post the configuration of both interfaces and post the output of show interface for each interface.

HTH

Rick

Thank you for getting back to me so quick. Ihave tons of Crossover cable - I changed them over and Over - didn't set the speed.

Here is a copy of both configs:

Building configuration...

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Router

!

!

ip subnet-zero

no ip domain-lookup

!

!

!

!

!

interface FastEthernet0/0

ip address 10.5.5.1 255.255.255.252

no ip directed-broadcast

!

interface Serial0/0

ip address 192.168.65.1 255.255.255.252

no ip directed-broadcast

no ip mroute-cache

no fair-queue

service-module t1 clock source internal

!

ip classless

no ip http server

!

!

!

line con 0

transport input none

line aux 0

line vty 0 4

login

!

end

Router#

NJ#sh run

Building configuration...

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname NJ

!

no logging buffered

no logging console

no logging monitor

enable secret xxx

enable password xxx

!

ip subnet-zero

no ip domain-lookup

!

!

!

interface Ethernet0/0

no ip address

no ip directed-broadcast

shutdown

!

interface Ethernet0/0.1

no ip directed-broadcast

!

interface Serial0/0

ip address 192.168.65.2 255.255.255.252

ip directed-broadcast

!

router rip

network 10.0.0.0

network 172.20.0.0

!

ip classless

!

!

line con 0

transport input none

line aux 0

line vty 0 4

password xxx

no login

!

no scheduler allocate

end

NJ#

Rick Morris Thu, 03/13/2008 - 10:48

from a config level it looks ok. Going Serial to Serial with a crossover. Something you maybe already have done.

sh ip int bri

Just want to know what each router says here?

Also you may want to specify clock source external on the other router.

Try a shut no shut on the serial interfaces.

Amit Singh Thu, 03/13/2008 - 10:52

Hi,

Here Are couple of things that I have noticed:

1. Your interface on the NJ router is in " Shutdown" state. Did you try enabling it by using " no shut " under the interface config mode.

2. Your NJ router has an ethernet port and the other router has a Fastethernet port. Typically the auto-negotiation should work and both the sides will fall back on 10 MB/half-duplex. If its a problem with auto-negoatiation then sometimes the link desnot comeup fine. I would suggest you to try hard-coding the speed and duplex on both the sides.

Let us know your findings on this.

-amit singh

Amit Singh Thu, 03/13/2008 - 10:55

Guys, I have assumed that the original poster is trying to connect it via the ethernet ports on both the routers.

Please clarify this that whether the routers are connected using the serial or ethernet links.

-amit singh

Rick Morris Thu, 03/13/2008 - 10:59

I believe it is serial based on the /30 applied. But you are right we need to know for sure.

Rick Morris Thu, 03/13/2008 - 11:05

what do you see in your sho ip int bri

also do a sho interface

post both so we can get an understanding of what is being shown.

Alright guys;

Here it is

Here I just show you the hardware loopback test. The result tells me that the hardware is fine.

Router#sh ip int brief

Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 10.5.5.1 YES NVRAM up down

Serial0/0 192.168.65.1 YES NVRAM up up

NJ#sh ip int brief

Interface IP-Address OK? Method Status Protocol

Ethernet0/0 unassigned YES unset administratively down down

Ethernet0/0.1 unassigned YES unset administratively down down

Serial0/0 192.168.65.2 YES NVRAM up up

NJ#

One of you guys request a "sh Int" for both routers. Here they are

NJ#sh int s0/0

Serial0/0 is up, line protocol is up (looped)

Hardware is PQUICC with Fractional T1 CSU/DSU

Internet address is 192.168.65.2/30

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/255

Encapsulation HDLC, loopback not set, keepalive set (10 sec)

Last input 00:00:01, output 00:00:01, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0 (size/max/drops); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/1/256 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

14 packets input, 1621 bytes, 0 no buffer

Received 14 broadcasts, 0 runts, 0 giants, 0 throttles

1678 input errors, 722 CRC, 932 frame, 0 overrun, 0 ignored, 24 abort

15 packets output, 1645 bytes, 0 underruns

0 output errors, 0 collisions, 9 interface resets

0 output buffer failures, 0 output buffers swapped out

3 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

NJ#

Router#sh int s0/0

Serial0/0 is down, line protocol is down

Hardware is PQUICC with Fractional T1 CSU/DSU

Internet address is 192.168.65.1/30

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliablility 255/255, txload 1/255, rxload 1/255

Encapsulation HDLC, loopback not set, keepalive set (10 sec)

Last input 00:02:38, output 00:02:38, output hang never

Last clearing of "show interface" counters never

Queueing strategy: fifo

Output queue 0/40, 0 drops; input queue 0/75, 0 drops

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

2 packets input, 363 bytes, 0 no buffer

Received 2 broadcasts, 0 runts, 1 giants, 0 throttles

1713 input errors, 466 CRC, 1195 frame, 0 overrun, 0 ignored, 51 abort

2 packets output, 363 bytes, 0 underruns

0 output errors, 0 collisions, 27 interface resets

0 output buffer failures, 0 output buffers swapped out

2 carrier transitions

DCD=down DSR=up DTR=up RTS=up CTS=down

Router#

I made couples modification but NO luck!!

NJ#sh run int s0/0

Building configuration...

Current configuration:

!

interface Serial0/0

ip address 192.168.65.2 255.255.255.252

ip directed-broadcast

service-module t1 clock source internal

end

NJ#

Router#sh run int s0/0

Building configuration...

Current configuration:

!

interface Serial0/0

ip address 192.168.65.1 255.255.255.252

no ip directed-broadcast

no ip mroute-cache

no fair-queue

service-module t1 clock source internal

end

Thank you guys...You are awesome!

-JMF

Router#

marikakis Thu, 03/13/2008 - 11:51

Hello,

I see that you have under both interfaces the command "service-module t1 clock source internal". For back-to-back configurations one of the interfaces must have "service-module t1 clock source line".

Kind Regards,

M.

Richard Burts Thu, 03/13/2008 - 11:40

JMF

It is significant that you are attempting to connect serial to serial. That leads me back to questions about the crossover cable. Would I be correct in assuming that you are using a normal Ethernet crossover cable? If so that is the problem. A crossover cable for serial is significantly different from a crossover for Ethernet. Is this a serial crossover or an Ethernet crossover?

HTH

Rick

Rick Morris Thu, 03/13/2008 - 11:42

Ah...good call Rick

Yes a serial to serial is pins

1 - 3

2 - 5

3 - 1

5 - 2

This is the pinout

Rick Morris Thu, 03/13/2008 - 11:44

either cut one end and crimp a new end on or find someone who can either make a T-1 cable or buy one.

Thanks again Rick for pointing that out.

Richard Burts Thu, 03/13/2008 - 13:03

JMF

I am glad that we were able to shine some light on your issue. Keep reading and keep participating in the forum.

HTH

Rick

Actions

This Discussion