Malformed "from:" header in SIP trunk (CCM 4.1)

Unanswered Question
Mar 13th, 2008

I am having a problem making calls through a SIP TRUNK.


I have the following setup


ALCATEL --- E1 (MGCP) ---> CALLMANAGER --- SIP TRUNK ----> ASTERISK

PBX


When I call from Asterisk to Alcatel or Callmanager, it works fine.

When I call from an IP Phone in Callmanager to a DN in Asterisk it works fine.

But When i make a call from Alcatel to Asterisk, the call fails.


I ran a sniffer on Asterisk to see the traffic flow between the Callmanager and Asterisk, and I found that the "from:" field of the message header on the INVITE packet is showing the extension number I am calling as the originating number.


Ie.:


When I am calling to extension 8050 in Asterisk (always from the Alcatel PBX) , I see the following message:


Via: SIP/2.0/UDP [Callmanager's IP Address]:5060;branch=z9hG4bK151f2a3e

From: "User" <sip:8050@[Callmanager's IP Address]>;tag=16778787

To: <sip:8050@[Asterisk's IP Address]>

Date: Fri, 07 Mar 2008 19:20:49 GMT

Call-ID: 96cf0400-1de10a7e-4a2-500880a@[Callmanager's IP Address]

Supported: timer

Min-SE: 1800

User-Agent: Cisco-CCM4.1

Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK

CSeq: 101 INVITE

Max-Forwards: 70

Remote-Party-ID: "User" <sip:8050@[Callmanager's IP Address]>;party=calling;screen=no;privacy=off

Contact: <sip:8050@[Callmanager's IP Address]:5060>

Expires: 180

Allow-Events: telephone-event

Content-Type: application/sdp

Content-Length: 223


The sniffing shows that when Asterisk receives the INVITE with that DN, it then asks for Proxy Authentication, and Callmanager does nothing.


When I make a direct call from Callmanager to Asterisk, the INVITE packet shows the correct information in the header, and the call proceeds without issues.


It's obvious to say that Extension 8050 does not exist in Callmanager nor in Asterisk.

Has anybody seen something like this?


I have Callmanager 4.1(3)SR3. I have been browsing the bug toolkit but couldn't find any clue or reference to a similar problem. I am NOT free to apply the latest service Release if I cannot guarantee that it's the solution to the problem, that's why I am asking for your assistance.


Can anybody help me out?


Best regards to all the NetPro community!


Ariel


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
smalkeric Wed, 03/19/2008 - 14:08

Do you have any type of authentication mechanism activated as part of security design guidelines in callmanager?

arielroza Wed, 03/19/2008 - 14:20

Not to my knowledge. Although the system belongs to a customer, so my knowledge of their config may be partial.

What do you have in mind?

arielroza Mon, 05/19/2008 - 07:41

Fixed,

The issue was that my customer was using the same extension numbers in the PBX and in Asterisk, so Asterisk thought the call was being made by its own phones

Actions

This Discussion