I need help please !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Unanswered Question
Mar 13th, 2008

Using netsim version 4 to configure VLAN.

Below are my config...

routerA sub-int ==

switchA ip default gateway==

VLAN 1==

switch B ip default-gateway===

VLAN 1==

While i try to ping

I get incomplet command as response

Pls can someone help out.

It seems i have done everything right.I hope nothing is wrong with my simulation.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Istvan_Rabai Thu, 03/13/2008 - 13:49

Hi Femi,

I think the problem is in your simulator. The command parser is not prepared for such complicated tasks you are trying to accomplish.

This is a general problem with simulators.

They are not real routers.



rgfrergfre Fri, 03/14/2008 - 06:59

Posting the configs would help us take a closer look.

I have Netsim, and could test to see if you are having a problem with the sim itself.

femiayegbusi Sat, 03/15/2008 - 07:12

I really appreciate everyone`s contribution to my post.I am to configure a VLAN using Router as an Inter-Vlan communication device with 2 switches.

As earlier posted I use NETSIM v4 but it doesn`t accept some of the VLAN commands.

Another option is to recommend a more better simulator that can give optimum efficiency.

Check attachment please !!!!

Thanks in anticipation.....


Hi There

I see a few things which to me are not quite right with the configuration posted. Can I ask which study guide this configuration came from? Given that you are using passwords of "todd" on the equipment, it makes me think that you are using the CCNA study guide from Todd Lammle. Is this correct? If so which edition do you have?

Now to my observations.

1. You run ping tests in the configurations but you do not post whether these were successful or not. It would help to know what connectivity you have at each step.

2. You have configured the F0/0 interface on the 2600 router with an IP address which is supposed to be the default gateway for each subnet, but a physical interface can not be enabled as a trunk link. Only a sub interface can be enabled as a trunk. This is done with the command "encapsulation dot1q/isl ". As the 2950 switches only support dot1q trunking, you would use dot1q on the routers sub interface.

3. It is Cisco's recommendation and also real world best practice that each VLAN is a separate subnet. You have obeyed this rule with VLAN1, which would act as a management VLAN. But then you have given all your hosts, which are in VLAN's 2, 3 & 4 IP addresses in the same range. So you now have 4 VLAN's sharing the same subnet range. VLAN's 2, 3 & 4 should each be a different subnet range.

4. Even if you moved the IP address from the physical interface on the router to a sub-interface, each sub-interface can only be encapsulated for a single VLAN and you cannot assign any IP address from the same range ( to a second sub-interface as the router will not permit it. So you could not assign to 4 different sub interfaces.

I have attached a diagram of an inter VLAN routing setup. This diagram is only showing 1 switch, but would work the same if you had 3 switches trunked together. Only one of the switches needs to be connected (trunk link) to the router. But the router requires sub interfaces configured, each sub interface having the default gateway IP address of a particular subnet and encapsulation configured for that particular subnets VLAN id (1, 2, 3, or 4).

I put this diagram together to explain the concept to a colleague in work who is studying for the CCNA. Hopefully it will help you also. If anything is unclear or if you have more questions, just post.

Also please use the rating system for posts that you find helpful.

Best Regards,


rgfrergfre Mon, 03/17/2008 - 07:59

You are correct. The link worked. Thanks! What's weird is that I logged into the CCNP Prep Center, then went to the forum. This method didn't have the attachment links, or the rating dropdown box. Basically, I accessed The CCNP forums by clicking on links provided by the web site after logging in. Very strange, but thanks again!


This Discussion