Help configuring EtherChannel from Catalyst 4506 to Nortel Switch in IBM BC

Unanswered Question
Mar 13th, 2008

I need to configure 4 ports out of my 4506 to form and EtherChannel so I can create a communication path between this 4506 and an IBM Blade Center.

The IBM Blade Center has a Nortel switch with 6 physical ports. The IBM BladeCenter has 14 blade server and few of those servers will belong to a certain VLAN, and others to another VLAN.

I've read I that I have to create the etherchannel as trunk but I have never done this.

thanks in advance

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.8 (6 ratings)
Loading.
Istvan_Rabai Thu, 03/13/2008 - 22:38

Hi Angel,

I can only suggest you from the Cisco switch side.

I suppose the Nortel switch supports LACP as it is a standards based protocol.

If yes, then you should use LACP as an Etherchanneling protocol to build up the Etherchannel between them.

On this link you have more info on LACP.

http://www.cisco.com/en/US/docs/switches/lan/catalyst4000/7.1/configuration/guide/channel.html

If you don't want to read this link, give me the specifics of the switch ports and I will give you an example of configuring the LACP Etherchannel.

Cheers:

Istvan

insccisco Thu, 03/13/2008 - 23:46

Hi Istvan,

Ports Gigabit2/11, Gigabit2/12, Gigabit2/13 and Gigabit2/14 will be the ones being used for this etherchannel.

If LACP is the best language they can talk, then LACP it is.

Basically I need any VLAN to traverse this link, so I assume the link has to be a trunk.

I've read that each individual port should be setup as 1000 Mbps-full duplex.

What will be the correct setup for the etherchannel so that any VLANs can go thru it because there will be lots of blade servers that will be isolated on their own VLANs.

thanks in advance

Istvan_Rabai Fri, 03/14/2008 - 10:33

Hi Angel,

As I mentioned, I can make the config for you for the Cisco switch:

conf t

port-channel load-balance {load-balance method}

lacp system-priority 100

interface range gig2/11 - 14

speed nonegotiate

switchport

switchport mode trunk

switchport trunk encapsulation dot1q

switchport trunk allowed vlan all

switchport trunk native vlan 1

channel-protocol lacp

channel-group 1 mode active

The load-balance method depends on your traffic. Please read more about it on the link here:

http://www.cisco.com/en/US/docs/switches/lan/catalyst4500/12.1/8aew/configuration/guide/channel.html

Click on the "Configuring EtherChannel Load Balancing" link.

Load balancing can be based on the mac-addresses, ip addresses (on 6500 and 4500 switches on port numbers as well).

Cheers:

Istvan

insccisco Fri, 03/14/2008 - 11:06

Istvan, great stuff. I will go ahead and get this configure at the 4506.

I am still digging for configuration help for the Nortel switch

I will post back.. but if anyone has some help with regards to configuring the nortel switch to talk to the 4506, that will be great

thanks in advance

insccisco Sun, 03/16/2008 - 11:27

Hi Istvan,

the statement "speed nonegotiate" didn't work.

What was this statement intended for?

I read a cisco document and it mentions something like "switchport nonegotiate". Is this the same thing?

Istvan_Rabai Sun, 03/16/2008 - 11:38

Hi Angel,

This command may not work for some IOS releases.

It is intended to set the values to the default speed of 1000 Mbps and full duplex.

Use the "speed 1000" command instead, if your interfaces aren't set to that speed.

Gig interfaces should be full-duplex.

You can check it with the "show interface gig2/11" etc. command.

The "switchport nonegotiate" may also be useful. It disables DTP trunking negotiation. The Nortel switch doesn't support DTP, I suppose.

Cheers:

Istvan

insccisco Sun, 03/16/2008 - 13:01

Yes, just finished reading that the nortel switch doesnt support DTP.

I have set the load-balance method to "port-channel load-balance src-dst-ip" although I havent found any info on that in the nortel documentation, so hopefully this is supported.

The channel-protocol I will set to LACP as I've read nortel does support this. So basically I am done in the cisco 4506 and I am now setting up the nortel switch. Im close to do the first test.

Another big question.... currently, the 4 physical cables connecting the Nortel 6-port switch to the Cisco switch are straigh-thru cable. I've read that it is best to use cross-overs.... will this be a problem?

thanks for all the help Istvan

insccisco Sun, 03/16/2008 - 21:46

Hi Istvan,

I got my 4-port etherchannel working! It is communicating with the nortel switch and and my PCs behind the 4506 are happily talking to the servers behind the Nortel switch (the blades inside the IBM BladeCenter)

What I need to do now is check if all the 4 gigabit ports in the channel are indeed being used. How do I check this?

Here is my etherchannel config:

!

interface Port-channel1

description BLADECENTER_01

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,50,99,150

switchport mode trunk

switchport nonegotiate

!

!

interface GigabitEthernet2/11

description BLADECENTER_01 --- Ethernet Switch Module 1 (Bay 1)

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,50,99,150

switchport mode trunk

switchport nonegotiate

speed 1000

duplex full

channel-group 1 mode on

!

interface GigabitEthernet2/12

description BLADECENTER_01 --- Ethernet Switch Module 1 (Bay 1)

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,50,99,150

switchport mode trunk

switchport nonegotiate

speed 1000

duplex full

channel-group 1 mode on

!

interface GigabitEthernet2/13

description BLADECENTER_01 --- Ethernet Switch Module 1 (Bay 1)

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,50,99,150

switchport mode trunk

switchport nonegotiate

speed 1000

duplex full

channel-group 1 mode on

!

interface GigabitEthernet2/14

description BLADECENTER_01 --- Ethernet Switch Module 1 (Bay 1)

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,50,99,150

switchport mode trunk

switchport nonegotiate

speed 1000

duplex full

channel-group 1 mode on

!

Also let me know if this looks pretty to you and if there is anything that needs work.

thanks in advance

Istvan_Rabai Sun, 03/16/2008 - 22:57

Hi Angel,

I'm really happy your etherchannel is working.

You can check the traffic on all 4 Gig ports by issuing the "show interface Gig2/x" command.

In the output you will see the input and output traffic among other data, for the particular interface.

Please note, that the src-dst-ip etherchannel load balancing on 4 links works the following way:

It calculates the link to be used for the traffic by calcuating a XOR value of the last 2 bits of the source and destination ip addresses.

example:

source ip 192.168.1.1 (last 2 bits of the address: 01)

destination ip: 10.1.1.2 (last 2 bits of the address: 10)

link to be used within the channel: 01 XOR 10 = 11, that is 3.

This means that traffic between the same 2 nodes will always go through the same link within the channel in one direction.

If you have several sources and/or destinations with different ip addresses, then you will have traffics distributed among the links.

By checking the traffic within the link as above stated, you can play around with the load balancing method to achieve a more or less even distribution among the links.

Note also, that you have to set the load balancing method on both switches, because load balancing will affect the transmitted traffic only.

This way you may get different distribution of traffic in one direction and different traffic distribution in the other direction.

Cheers:

Istvan

Istvan_Rabai Mon, 03/17/2008 - 12:09

Hi Angel,

In the morning rush I forgot to mention a very simple way to check load balanced traffic on the etherchannel.

Use the "show etherchannel port" command.

Among other data, it will show the "Load" of all participating ports in hexadecimal format, like Load: 0x00 or Load 0x0A or similarly.

This will give you a fairly good picture of traffic distribution across the 4 links.

How is you setup is working?

Are you OK with it?

Cheers:

Istvan

insccisco Mon, 03/17/2008 - 15:04

I forgot to point out that I never specified the "port-channel load-balance {load-balance method}". My etherchannel is working with just all the settings I sent you before.

So, if the load-balance method is not specified, does the Layer3 4506 switch use a default one?

I guess a really good test will be shutting down one of the 4 interfaces to see if the channel still up. I have to play with these settings in order to be 100% sure that all interfaces in the etherchannel are working

The part that got me was "channel-group 1 mode active". According to the readings, this "active" word turns on LACP. So it wasnt working. I looked at the nortel switch config and no help as I have zero clue about it. But doing a search on nortel config examples, the word LACP was specified, and in my nortel switch was not, so I assumed LACP wasn;t on so I made all those nortel interfaces static trunks, placed them into trunk group 1 and then it worked.

Baby steps but we're getting it done

insccisco Mon, 03/17/2008 - 15:09

I just entered the command and it reports Load = 0x00 on all. I will be doing more "sh int giga2/11" comands to see the activity there.

On the nortel side, the status of the trunk comes back as "forwarding" on all 4 ports. So I assume this is good

moabdallah Sun, 01/11/2009 - 02:01

Hi,

i am trying to configure the same setup beween IBM bladeCenter ( Nortel ) and Cisco 4500 Switch

Can u help me in this configuration Specially from the Nortel side ?

Regards

Mohamed

insccisco Tue, 01/13/2009 - 07:42

Hi Mohamed,

I remember this project which turned out to be no fun. I basically got this working by reading all the Nortel and IBM Blade Center manuals... lots of print-outs.

You'd need to understand the architecture of these systems first. I highly recommend this. I am by no means a nortel guy, but once I read thousands of manuals, articles, examples, etc., I was able to configure those nortel switches.

what exactly are you having problems with?

moabdallah Tue, 01/13/2009 - 07:56

I have read the IBM BladeCenter guide which contain the Nortel configuration

I would to ask about the nortel configuration specially the link aggregation ( EtherChannel from Cisco side ) ?

Regards

Mohamed

insccisco Wed, 01/14/2009 - 10:17

I found my answers on the Nortel manuals. I can't remember the stuff now as I don't work with Nortel stuff at all.

I will try to get you the Nortel manuals. I'll send you the links if I can.

Amit Singh Thu, 03/13/2008 - 22:44

Yes, we have to use LACP between the 4506 and the Nortel switch. Also, you have to tag all the Vlans manually for the trunk port configuration on the Nortel switch. You will obviously be using the Dot1q as the trunking encapsulation. Once this is done on Cisco switch after configuring the trunk port you have to manually the native vlan on the trunk port to some bogus vlan number (Vlan thatis not used on 4506) or you have to tag all the vlans by using global config command " dot1q vlan tag all ". Nortel doesnot support the native vlan concept.

HTH,

-amit singh

insccisco Fri, 03/14/2008 - 00:17

What do you mean by "you have to tag all the Vlans manually for the trunk port configuration on the Nortel switch"?

sateeshk10 Fri, 10/31/2008 - 14:58

Hi Guys,

If i am runing spannning tree on my core switch..How we are going to configure the nortel switch. like i am going run rapid Spanning tree ..So how can i integrate with my nortel switch.

Regards

sateesh

sateeshk10 Mon, 11/03/2008 - 14:23

Hi guys..

Can anybody answer to my question as it is very urgent for me.

Regards

sateesh

insccisco Mon, 11/03/2008 - 14:51

Hi,

I'd try to get more info on the Nortel switches.

I went thru so many problems with Nortel that I had to download all their manuals and read them all. Their support is pretty expensive I believe, this is why I had no other choice.

But once again, what is your exact problem? perhaps I can dig my old notes

sateeshk10 Mon, 11/03/2008 - 15:09

Hi..

Thanks for your help..

I am going to enable RPVST in my core switches..

I am going connect the blade servers(with nortel) to my core1 and core2 as portchannel

If I din`t enable STP in nortel switches both the ports are in fwd state.I want one port shld be fwd and another port shld blocking ..

What type of STP need to enable..

Regards

sateesh

Actions

This Discussion