Problem with NAT in Cisco 2811

Unanswered Question
Mar 14th, 2008
User Badges:

Hi,


I have a cisco 2811 with two HWIC-1ADSL cards. I have configured Static Nat / Port Forwarding on my Router. The port is forwarded to the Local Webserver. The problem is that the Mapping works fine until the my Webserver redirects the traffic to another Port. Once my Internal Webserver redirects the traffic to some other port the mapping stops working. Here is the running configuration of my router.


interface FastEthernet0/0

ip address 192.168.0.200 255.255.255.0

ip nat inside

ip virtual-reassembly

ip route-cache flow

ip tcp adjust-mss 1452

ip policy route-map CYBER-ROUTE

duplex auto

speed auto

!

interface ATM0/1/0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

pvc 0/35

encapsulation aal5snap

pppoe-client dial-pool-number 2

!

!

interface Dialer2

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

shutdown

dialer pool 2

ppp pap sent-username habib1 password 0 habib1

!

ip route 0.0.0.0 0.0.0.0 Dialer2

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat inside source list 1 interface Dialer2 overload

ip nat inside source static tcp 192.168.0.2 8888 202.38.58.54 8888 extendable

ip nat inside source static tcp 192.168.0.2 9080 202.38.58.54 9080 extendable

!

access-list 1 permit 192.168.0.0 0.0.0.255


Thanks.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Edison Ortiz Sat, 03/15/2008 - 09:13
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

The problem is that the Mapping works fine until the my Webserver redirects the traffic to another Port. Once my Internal Webserver redirects the traffic to some other port the mapping stops working


Well ......


ip nat inside source static tcp 192.168.0.2 8888 202.38.58.54 8888 extendable

ip nat inside source static tcp 192.168.0.2 9080 202.38.58.54 9080 extendable



You are only covering 2 TCP ports for the webserver. If those ports change, the webserver will use dynamic NAT. It's working as you've configured.


HTH,


__


Edison.


haris_shuja Sun, 03/16/2008 - 23:07
User Badges:

Well, the thing is that the WebServer is redirection the request to a JReport Server which is listening on Port 8888 and those reports are not opening.


Thanks.

Edison Ortiz Mon, 03/17/2008 - 06:49
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

They are not opening from the webserver? If so, does the connection from the webserver to the JReport Server involves NAT?


At the moment, you only have a static NAT for 192.168.0.2, is this the webserver?

If the JReport server holds another IP address, that address isn't included in the NAT.


__


Edison.

Actions

This Discussion