HSRP with Interface sla tracking

Unanswered Question
Mar 14th, 2008


We are using HSRP for High availability option with two 3845 .

Two routers are having WAN links terminated in HWIC cards and we need to track these ports which are on ethernet.

As WAN is on ethernet , it do not go down and we can not be used by standby track interface command for HSRP priorty changeing.

So we are using interface track command , with ip sla and icmp echo configuration.

So we are monitoring next hop of the WAN link (ISP side ip address ) as target and our HWIC port as source IP address for ICMP-ECHO configuration in ip sla configuration.

But it is not working any experience please share.

Even if we could do static routing with distance that can be changed with inteface track commend it will solve our problem.

We will route the traffic to second router if first tracking result is down.

any link on cisco.com is highly appreciable.



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Edison Ortiz Fri, 03/14/2008 - 13:41

You are saying the track goes down but the HSRP does not decrement ?

Can you post the config?



wasiimcisco Sat, 03/15/2008 - 08:45

I have confiugred the MHSRP successfully. I am able to provide the redundency and load balancing. But problem is that I am not able to track the Interface connected with WAN.

It is ethernet interface and I mentioned it in HSRP configration, but when it goes down, it is not detected by HSRP.

Below mention is the configuration of HSRP

interface GigabitEthernet0/1

ip address

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

standby 1 ip

standby 1 priority 150

standby 1 preempt

standby 1 track GigabitEthernet0/0

standby 2 ip

standby 2 preempt

standby 2 track GigabitEthernet0/0

Kindly help me out, how to solove this problem. Anyway to configure tracking any other method, if yes then how to configure that method. Why not it is working with HSRP.

Edison Ortiz Sat, 03/15/2008 - 08:52

Configure SLA with ICMP Echo to the next-hop by following this document:


Once the SLA is configured, verify the track goes down when the link fails.

Attach the track to the MHSRP configuration along with a decrement value. Currently, I don't see any decrement on the standby 1 track GigabitEthernet0/0 command.

Here is a good example of using track along with HSRP






This Discussion