Windows Vista and Catalyst 2950

Unanswered Question
Mar 14th, 2008

We have the Catalyst 2950 device (C2950-I6Q4L2-M) Version 12.1 and our Windows XP clients can join our Active Directory domain but our Windows Vista clients cannot connect/ping/remote the domain controller and thus can not join the domain. Any ideas? Do we need a firmware upgrade? Unfortunately we are not Cisco savy so any feedback or help would be greatly appreciated.

Thank you

Todd N. Rustad

[email protected]

http://www.toddnrustad.com

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Danilo Dy Fri, 03/14/2008 - 21:23

Hi,

I don't think its something to do with the switch. It's more on the Vista.

Thus the Vista able to ping other PC in the same network?

- If not and using DHCP ip address assignment, your Vista may not be able to get IP Address from DHCP server. There is a MS KB about this issue.

- If not and using STATIC ip address, check the IP Address, Subnet Mask, Gateway, WINS, DNS if correct. Else, it has something to do with Vista security.

If IP Address and local network connectivity is okay but still not able to connect to AD.

- Check the MS KB regarding Vista problem connecting to AD.

Can you post your network topology?

- Showing connections of XP, Vista, AD including the network devices in between

Regards,

Dandy

glen.grant Sat, 03/15/2008 - 04:52

Check to see if you are even getting an ip address on those clients , if it has a 169.x.x.x address then it is not pulling an address . If possible post the 2950 config.

toddnrustad Sat, 03/15/2008 - 12:33

We are getting an IP and can connect out to the internet and our other servers, just not the domain controller. We removed the catayst and we able to connect and put it back in and then can't connect. XP is fine. It seems to be something with the Catayst.

glen.grant Sat, 03/15/2008 - 17:08

When you you remove it how are the devices connected in then . Can you elaborate more how things are setup ?? If XP works then the only thing I can think of is maybe XP has certain services turned on that Vista does not .

Danilo Dy Sat, 03/15/2008 - 20:21

Hi,

Is the Catalyst 2950 new switch or old switch and what is the configuration of the switch?

I mean, thus all the ports in this switch in a single vlan and what about the VTP mode is it transparent, server, or client?

Regards,

Dandy

toddnrustad Sat, 03/15/2008 - 21:12

Very good questions, thank you so much! I am going to have to go back into the office and see if I can download the config information and post it. If I telnet into the catayst, what do I type to print out the config information?

Actions

This Discussion