IMlA Interface problem

Unanswered Question

Hi,


I have a problem with my ATM/IMA subinterfaces in that I can't even ping my local interface from the router despite it showing UP UP.


I am connecting to 3 times E1's using VWIC2 mutliflex cards on a 3825.

I have an ATM aim model and all of the above seem to be up OK.

I am working with my telco to connect remote frame-relay sites in to my core site.

The remote sites stay as frame-relay and my core site has 3 times E1's connected to my telco's ATM switch (a Nortel) as a single 6 meg ATM bundle.

We are trying to migrate my core site from frame-relay to ATM over E1 using the configuration below.

My IMA is UP, and my sub-interfaces are UP UP, but I can't ping my local sub-interface IP address, let alone the remote site IP.



network-clock-participate wic 0

network-clock-participate wic 1

network-clock-participate wic 2

network-clock-participate aim 0

network-clock-select 1 E1 0/0/0



controller E1 0/0/0

mode atm aim 0

framing NO-CRC4

!

controller E1 0/0/1

mode atm aim 0

framing NO-CRC4

!

controller E1 0/1/0

mode atm aim 0

framing NO-CRC4



interface ATM0/0/0

bandwidth 2048

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

scrambling-payload

ima-group 1

no atm ilmi-keepalive

!

interface ATM0/0/1

bandwidth 2048

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip mroute-cache

no snmp trap link-status

scrambling-payload

ima-group 1

no atm ilmi-keepalive

!

interface ATM0/1/0

bandwidth 2048

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

scrambling-payload

ima-group 1

no atm ilmi-keepalive

!

interface ATM0/IMA1

bandwidth 6144

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

no atm ilmi-keepalive


!

interface ATM0/IMA1.2 point-to-point

description ATM Connection to Desforge Branch

bandwidth 512

ip address xx.xx.xx.xx xx.xx.xx.xx

no ip redirects

no ip unreachables

no ip proxy-arp

no snmp trap link-status

no routing dynamic

pvc 4/101

oam-pvc manage

encapsulation aal5snap

!

interface ATM0/IMA1.10 point-to-point

description test link to QB DR

bandwidth 64

ip address xx.xx.xx.xx xx.xx.xx.xx

no ip redirects

no ip unreachables

no ip proxy-arp

no snmp trap link-status

pvc 3/120

no oam-pvc manage

encapsulation aal5snap

!

!

interface ATM0/IMA1.13 point-to-point

description PVC to Chemin Grenier Branch

bandwidth 128

ip address xx.xx.xx.xx xx.xx.xx.xx

no ip redirects

no ip unreachables

no ip proxy-arp

ip mroute-cache

no snmp trap link-status

pvc 4/126

encapsulation aal5snap

!

Am I missing some command to map my layer 3 to the layer 2 protocol?


Any other ideas?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
paolo bevilacqua Sat, 03/15/2008 - 09:42
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi,


check if the cell counters are increasing with: show atm pvc x/y. On the remote do the same, but is show frame-relay instead. Check the remote likely must use encapsulation frame-relay ietf for this to work.

If the counters are not increasing, telco has not provisioned the IWF correctly.


Note unrelate to the issue, the following commands:


bandwidth xxx

no ip redirects

no ip proxy-arp


are not doing anything and can be removed.




Hi,


strangely, the test link we configured last night suddenly started working, however telco insists he did nothing!!

But today we tried to configure another site and now, although we can ping the local IP;s on the ima subinterfaces, we can't ping the remotes an the pvc that was working or on the new one!

Have triede router reloads and modem resets etc, all to no avail.

The counters are increasing on both ends as per the sho outputs below:


rwmabellv0102#sho atm pvc 3/120

Description: N/A

ATM0/IMA1.11: VCD: 6, VPI: 3, VCI: 120

UBR, PeakRate: 5760 (13585 cps)

AAL5-LLC/SNAP, etype:0x0, Flags: 0xC20, VCmode: 0x0, Encapsize: 12

OAM frequency: 0 second(s), OAM retry frequency: 1 second(s)

OAM up retry count: 3, OAM down retry count: 5

OAM Loopback status: OAM Disabled

OAM VC Status: Not Managed

ILMI VC status: Not Managed

InARP frequency: 15 minutes(s)

Transmit priority 4

InPkts: 49, OutPkts: 38, InBytes: 5364, OutBytes: 3672

InPRoc: 23, OutPRoc: 20, Broadcasts: 18

InFast: 26, OutFast: 0, InAS: 0, OutAS: 0

InPktDrops: 0, OutPktDrops: 0/0/0 (holdq/outputq/total)

CrcErrors: 0, SarTimeOuts: 0, OverSizedSDUs: 0, LengthViolation: 0, CPIErrors: 0

Out CLP=1 Pkts: 0

OAM cells received: 0

F5 InEndloop: 0, F5 InSegloop: 0, F5 InAIS: 0, F5 InRDI: 0

F4 InEndloop: 0, F4 InSegloop: 0, F4 InAIS: 0, F4 InRDI: 0

OAM cells sent: 0

F5 OutEndloop: 0, F5 OutSegloop: 0, F5 OutRDI: 0

F4 OutEndloop: 0, F4 OutSegloop: 0, F4 OutRDI: 0

OAM cell drops: 0

Status: UP


VC 3/120 doesn't exist on 3 of 4 ATM interface(s)


QBornes_DR_Site_RTR01#sho frame-relay pvc 100


PVC Statistics for interface Serial0 (Frame Relay DTE)


DLCI = 100, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0.101


input pkts 83 output pkts 165 in bytes 7552

out bytes 17918 dropped pkts 0 in pkts dropped 0

out pkts dropped 0 out bytes dropped 0

in FECN pkts 0 in BECN pkts 0 out FECN pkts 0

out BECN pkts 0 in DE pkts 0 out DE pkts 0

out bcast pkts 12 out bcast bytes 4344

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

pvc create time 00:08:22, last time pvc status changed 00:07:23


We did have to change the IOS on our local router as we had to install an additional FastEthernet NM module and the IOS would not recognise it, could this be related?


Old and new IOS versions shown below:


original ver: c3825-advipservicesk9-mz.124-11.T4.old


current ver: c3825-advipservicesk9-mz.124-9.T4.bin

paolo bevilacqua Sun, 03/16/2008 - 05:56
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi can you ask telco if they're are doing transparent or translated iwf ?

Can you send interface config the the FR side?


For the NM, send output of show diag.

paolo bevilacqua Sun, 03/16/2008 - 07:56
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Ok. The NM-1E hat you're trying is not supported in the ISR router, get HWIC-1FE or 2FE.

OK, but we did try a HWIC-1FE first with the same result.

Also, forgot to add the remote router frame-relay i/f config, so here it is:

Note s0.1 and s0.2 are on existing frame-relay network and work OK (have been in use for a number of years)

s0.101 is on the new dlci that connects into the telco's frame to ATM network



interface Serial0

no ip address

encapsulation frame-relay IETF

frame-relay lmi-type q933a

!

interface Serial0.1 point-to-point

description Live Link to Quatre Bornes

bandwidth 32

ip address xx.xx.xx.xx 255.255.255.252

ip access-group 151 in

ip ospf network non-broadcast

frame-relay interface-dlci 17

crypto map qb_dr_live

!

interface Serial0.2 point-to-point

description backup Link to Bell Village

bandwidth 16

ip address xx.xx.xx.xx 255.255.255.252

ip access-group 151 in

ip ospf network non-broadcast

frame-relay interface-dlci 16

crypto map qb_dr_back

!

interface Serial0.101 point-to-point

description test link to QB DR

ip address xx.xx.xx.xx 255.255.255.252

ip ospf network non-broadcast

frame-relay interface-dlci 100



Actions

This Discussion