LMS 2.6 backups fails with bizarre error message

Answered Question
Mar 17th, 2008

The backups on one of my LMS servers fails with a message that does not make sense to me:

/cygdrive/d/CSCOpx/bin/tar: /CSCOpx/campus/etc/cwsi/DeviceDiscovery.properties : Cannot stat: No such file or directory

/cygdrive/d/CSCOpx/bin/tar: /CSCOpx/campus/etc/cwsi/ANIServer.properties : Cannot stat: No such file or directory

/cygdrive/d/CSCOpx/bin/tar: /CSCOpx/campus/etc/cwsi/discoverysnmp.conf : Cannot stat: No such file or directory

/cygdrive/d/CSCOpx/bin/tar: /CSCOpx/campus/etc/cwsi/datacollectionsnmp.conf : Cannot stat: No such file or directory

/cygdrive/d/CSCOpx/bin/tar: /CSCOpx/campus/etc/cwsi/Snmpv3EngineParam.txt : Cannot stat: No such file or directory

/cygdrive/d/CSCOpx/bin/tar: /CSCOpx/campus/etc/cwsi/UTSnmpv3EngineParam.txt : Cannot stat: No such file or directory

/cygdrive/d/CSCOpx/bin/tar: /CSCOpx/campus/etc/cwsi/users: Cannot stat: No such file or directory

/cygdrive/d/CSCOpx/bin/tar: /CSCOpx/campus/etc/cwsi/archives: Cannot stat: No such file or directory

/cygdrive/d/CSCOpx/bin/tar: /CSCOpx/campus/etc/users: Cannot stat: No such file or directory

/cygdrive/d/CSCOpx/bin/tar: /CSCOpx/campus/etc/cwsi/ReportArchives: Cannot stat: No such file or directory

/cygdrive/d/CSCOpx/bin/tar: /CSCOpx/htdocs/campus/maps: Cannot stat: No such file or directory

/cygdrive/d/CSCOpx/bin/tar: Error exit delayed from previous errors

ERROR(686): Cannot create or back up tar file. Backup cancelled. Verify that you have write-access to this directory.

Backup failed: 2008/03/17 04:40:50

Does this mean that tar has problems reading the files and dirs (they are all there) or does it actually imply that the permissions on d:\backupdir has become messed up?

BR,

Olof

Correct Answer by Joe Clarke about 8 years 11 months ago

This means you have another Cygwin application installed on this machine, and it is interfering with the backup. You will need to remove apps like OpenSSH from the server, and make sure the following registry key is empty:

HKLM/Software/Cygnus Solutions/Cygwin/mounts v2

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Loading.
Correct Answer
Joe Clarke Mon, 03/17/2008 - 10:49

This means you have another Cygwin application installed on this machine, and it is interfering with the backup. You will need to remove apps like OpenSSH from the server, and make sure the following registry key is empty:

HKLM/Software/Cygnus Solutions/Cygwin/mounts v2

OLOF SAMUELSSON Fri, 03/28/2008 - 07:56

I'm impressed! I tried to install Cygwin on this server a few years back (it didn't work,. since CW uses an arcane version of the DLL, but never mind) but did not clean up the registry afterwards.

The backups have worked in the meantime and seems to have stopped working after our latest CiscoWorks patching (updating CS, DFM and CM to the latest SPs), so I guess this may be related.

Never midn, I guess this will solve my issue.

Thanks!

Actions

This Discussion