general voip vlan config

Answered Question
Mar 17th, 2008
User Badges:

We have a flat network of 6 3750g poe switches in a stack. default vlan1 for data.......we are getting ready to go to voip and am need some general guidance in setting up voice vlan. It seems some say the ports should be in trunk mode, others say no. Just looking for simple config examples for the setup. thank you

Correct Answer by Rob Huffman about 9 years 1 week ago

Hi Mark,


I'm sorry, I didn't realise you were running Shoretel IP Phones. You will want the Switchport set in Trunk mode. Here is a really good description of the config;


http://ciscoconfigs.net/index.php?option=com_content&task=view&id=13&Itemid=26


Hope this helps!

Rob

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Paolo Bevilacqua Mon, 03/17/2008 - 12:52
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

interface range fa x/y - z/k

switchport mode access

switchport access vlan

switchport voice vlan


That's it.


gmtimmons Mon, 03/17/2008 - 13:46
User Badges:

so they dont have to be in trunk mode? Why do I see some configs where they are putting the ports in trunk mode? and some with access mode and trunk mode again,pc and phone to same port on switch

thanks for you help

Jaime Valencia Mon, 03/17/2008 - 14:00
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

You can find some more info here


How to configure a Catalyst switch port to connect to a Cisco IP phone

http://www.ciscotaccc.com/kaidara-advisor/lanswitching/showcase?case=K33524366


The 7935 IP Conference Phone is not registering, which causes problems with the voice VLAN

http://www.ciscotaccc.com/kaidara-advisor/voice/showcase?case=K18816621


HTH


javalenc


if this helps, please rate

gmtimmons Mon, 03/17/2008 - 17:21
User Badges:

Im still confused on to or not to use trunk mode... from your first link....

With third party IP phones:


Console>(enable) set vlan[vlan id] [mod/port]

!--- This line is for the data VLAN, Native VLAN.

Console>(enable) set trunk[mod/port] on dot1q

Console>(enable) Set trunk [mod/port] [data vlan id, voice vlan id]

Console>(enable) set spantree portfast [mod/port] enable trunk

For Cisco IOS:


Switch(config-if)#switchport modeaccess Switch(config-if)#switchport access vlan vlan id Switch(config-if)#switchport voice vlan Vlan id Switch(config-if)#no shutdown

Alternatively, this configuration can be used:


Switch(config-if)#switchport trunk encapsulation dot1q

Switch(config-if)#switchport trunk native vlan id

!--- This is the VLAN with untagged frames used by the PC.

Switch(config-if)#switchport mode trunk

!--- This enables trunking on the port for two VLANs, data and voice.

Switch(config-if)#switchport voice vlan id

Switch(config-if)#spanning-tree portfast trunk


so is trunk mode necessary?

Paolo Bevilacqua Mon, 03/17/2008 - 17:45
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, with cisco phones, no trunk mode is necessary, except on certain ESW modules for routers. The config you referenced is about third-party phones.


Technically, the access+voice mode is a subset trunk mode with tagging frames limited to 1 vlan.

Hope all that doesn't confuse you further :)

Rob Huffman Mon, 03/17/2008 - 18:21
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Mark,


Welcome to the world of VoIP. This is a great question!My background is primarily voice so it is hard for me to describe why this is a Cisco "best practice". I do know that it is unnecessary to configure the switchport in Trunk mode because when you use the Voice VLAN (with a native vlan) command a "special" dot1q trunk is automatically setup. The reasons I have seen to support this setup are many and vary from minimizing Trunking overhead to ease of configuration and everything in between :) On the older 3500XL Switches the Trunk method was the only way to go, but on all newer versions the need for Sitchport mode Trunk is not necessary. Here is one of the better threads I have ever read on this issue (with some Tac links as well). There are some great answers from Mahesh,Paolo Sankar and others here.



http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Unified%20Communications%20and%20Video&topic=IP%20Telephony&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40%5E1%40%40.1ddd5905/14#selected_message


Hope this helps!

Rob


gmtimmons Tue, 03/18/2008 - 12:34
User Badges:

Ok, so even if we are using third party shortel phone system, it is not necessary to trunk each port? On the thread you list, it states that trunking the ports is only necessary if you are not using cisco phones, which we wont be using. to trunk or not to trunk, that is the question aaha thank you all very much for your help

Correct Answer
Rob Huffman Tue, 03/18/2008 - 16:39
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Mark,


I'm sorry, I didn't realise you were running Shoretel IP Phones. You will want the Switchport set in Trunk mode. Here is a really good description of the config;


http://ciscoconfigs.net/index.php?option=com_content&task=view&id=13&Itemid=26


Hope this helps!

Rob

gmtimmons Wed, 03/19/2008 - 07:56
User Badges:

EXACTLY WHAT I WAS LOOKING FOR!! Thank you for clearing things up for me and to everyone that helped.

Rob Huffman Wed, 03/19/2008 - 16:54
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Mark,


Good stuff :) Best of luck with your new deployment.


Take care,

Rob

Actions

This Discussion