Router stuck in ROMMON mode

Unanswered Question
Mar 17th, 2008


we have AS5400, which is not responding on console. If we do a hard reload its getting hung. If we do hard reload with Break sequence its entering ROMMON mode.

In ROMMON mode,

a) able to see the devices (flash)

b) confreg is set to boot the image from flash

c)able to execute the command to boot from the flash

but after boot in the ROMMON mode also the router is hanging... To bring it back to ROMMON we need to again hard reload the router....

we tried to delete the existnig IOS in flash (though IOS would have got corrupted) and uploaded the IOS via TFTP.. but the problem still exists...

Any advice on this...

thanks in advance

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
vincent-n Mon, 03/17/2008 - 23:00

I could be wrong but I think that you're having problems with IOS. Can you revert back to older version of IOS that you KNOW had worked in the past and work your way through. Be aware that sometimes newer version of IOS would require upgrade of firmware. I've not come across one but I'm not surprise if there's such requirement.

mazhar mahadik Tue, 03/18/2008 - 05:46


i m not sure but u can try to hard reset the DRAM.

u hv to just remove DRAM and load it again.

this helped me once.


Mazhar Mahadik.


This Discussion