EtherChannel not coming up

Unanswered Question
Mar 18th, 2008
User Badges:

Guys, Im having a problem with a port-channel in a 4506.

I created 2 4-port etherchannels (int port-channel1 and int port-channel2) and all is well. Each of these 2 channels go to 2 Nortel Switches.

When I try to create a third 4-port etherchannel to a third Nortel switch, in theory I was expecting this to be smooth because they all the same, however this 3rd channel will not come up.

I checked the logs in the nortel switch and all clear. However, the logs in the 4506 have these messages:

EC-5-CANNOT_BUNDLE2: Gi4/14 is not compatible with Po3 and will be suspended (trunk mode of Gi4/14 is dynamic, Po3 is trunk)

I've changed ports in the 4506 (from 3/21-24 to 4/11-14) and the exact problems.

Can you guys please help?

thanks in advance

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Jon Marshall Tue, 03/18/2008 - 14:55
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Can you check the interface capabilities and ensure that gi4/14 has exactly the same settings as gi4/11 - 13.

switch(config)# int gi4/14

switch(config-if)# sh interface capabilities


sundar.palaniappan Tue, 03/18/2008 - 16:09
User Badges:
  • Green, 3000 points or more

Are your symptoms similar to this bug CSCsd11234. If it's try the workaround.

If a physical interface is configured in shutdown mode, then configured with the same configuration including "switchport nonegotiate," when it is later enabled by the no shutdown command, it can not join the bundle and the following error message displays:

%EC-5-CANNOT_BUNDLE2: Gi3/16 is not compatible with Po1and will be suspended (trunk

mode of Gi3/16 is dynamic, Po1 is trunk)

The following configuration sequence will prevent interface g3/16 from joining the bundle:

int g3/16


switchport mode trunk

switchport nonegotiate

channel-group 1 mode on

int po1

switchport trunk enacp dot1q

switchport mode trunk

switchport nonegotiate

int g3/16

no shut

Workaround: Do NOT configure the channel-port with the same configuration while all physical ports are still in shutdown mode. Instead, issue the unshutdown command on the physical ports to carry over the first unshutdown to the channel port. (CSCsd11234)




This Discussion