Attach two switches

Unanswered Question
Mar 18th, 2008

Hi, I have two 3560 switches. I need to combine both switch together.I have created vlan8 on both switches with selected ports for my servers.

Q1. Do I need to configure any trunking protocol on both side ports to connect both switch ? since I am not interested to share multiple vlan traffic. only vlan8 traffic to be shared from both switches.

2.I need to have a cross cable to connect both switches.

idea pla..

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
mahmoodmkl Tue, 03/18/2008 - 23:07


from combine u mean as stack if so then 3650 doesnt support stacking.

1.No u need not configure both the side to be trunk,just define the ports which u r using to connect the switches in the vlan u want.

2.If u r using RJ-45 ports then u can use cross cable.



ilnaiduccna Wed, 03/19/2008 - 00:00

HI Mohamood,

You connect both switches with cross cable and you should do configure trunk on both side switch ports.

Since not interested to share all vlans and share only vlan8 through trunk ports you can define ACL's to allow / restrict communication between vlan's

Hope it will help's you,


Naidu :-)

blue4ciscome Wed, 03/19/2008 - 02:33

this is my first switch config:

interface GigabitEthernet0/2

switchport trunk encapsulation dot1q

switchport trunk native vlan 8

switchport mode trunk

macro description cisco-switch

auto qos voip trust

spanning-tree link-type point-to-point

this one on second switch:

interface GigabitEthernet0/18

description Conn new switch

switchport access vlan 8

switchport trunk encapsulation dot1q

switchport mode trunk

duplex full

speed 1000

but I am unable to ping each other switch.

mahmoodmkl Wed, 03/19/2008 - 03:17


U mean to say u r not able to ping the management IPs for these switches..?

can u paste sh run of these switches.



blue4ciscome Wed, 03/19/2008 - 03:45

Hi Both I hv trunk port on first switch port 18 n port 2 on other switch, beside above both switch are connected via WAN link also.

ilnaiduccna Wed, 03/19/2008 - 03:32


Make sure physical connectivity between switches, is you tried internal ping?

And make sure speed, duplex same / not.



vaisharm Wed, 03/19/2008 - 03:37

Is the link up/up (you have manually configured the speed and duplex on one of the switches). The command 'switchport trunk native vlan 8' should be there on both the switches. Also, gig0/18 should not have the statement 'switchport access vlan 8'.



shrikar.dange Wed, 03/19/2008 - 03:58


As per your configuration you have enabled the auto QoS for VOIP on one of the switches with trust boundary make sure its working fine.

And as vaibhav said above you have not configured native vlan on one of the switch.The switchport access valn 8 will work fine no need to remove that.If your trunking is not working then this way you can have fall back method with this config.

You are pinging to which Ip from where?

To your 1st question in 1st post:

On trunk interfaces (@ both sides) issue following command to allow onlyy vlan 8 traffic:

switchport trunk allowed valn 8

no need to configure anything else.



shri :)

Joseph W. Doherty Wed, 03/19/2008 - 04:40

You should be able to daisy chain your two switches without a trunk port by connecting two access ports that have the same vlan. You'll likely need a cross over cable.


This Discussion