Connecting servers directly to L3 switch

Unanswered Question
Mar 19th, 2008

Hi,

How can i directly connect my servers to L3 switch by not having a seperate l2 switch, So can i configure l2 vlans also on the l3 switch .

Basically i want my seevers connected to L3 switch ----then it goes to a Wan router.

Please let me know what steps i need to take care for this activity.

Rgds,

Akber.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Loading.
Jon Marshall Wed, 03/19/2008 - 05:54

Akber

A L3 switch still has L2 vlans on it. So you create the vlans as you would on a L2 switch, allocate ports into those vlans and connect your servers up.

If you then need those servers to be able to reach remote networks then you simply create L3 SVI's for the vlans ie.

interface vlan 10

ip address 192.168.5.1 255.255.255.0

HTH

Jon

mirzaakberali Wed, 03/19/2008 - 07:15

Jon

I have 10 severs , which i would direcly connecting to L3 switch ( Avoiding L2 switch expenses) . So the basic idea would be to create a l2 vlan and assign all the server ports under that vlan on a L3 switch . From now how this l2 vlan pass trafiice to the next device ( which is a Wan Router) . Does it require any configs more on the L3 switch .

Appreciate your valuable response!

Rgds,

Akber.

Jon Marshall Wed, 03/19/2008 - 08:04

Akber

Letes say you use vlan 10. You create the L2 vlan 10 and assign ports into that vlan.

Then on the L3 switch

switch(config)# int vlan 10

switch(config-if)# ip address 192.168.5.1 255.255.255.0

Assign your server addresses out of the 192.168.5.x subnet and set the default-gateway to 192.168.5.1.

Do you have connectivity already between the L3 switch and the router ?

Jon

meballard Wed, 03/19/2008 - 09:33

One thing to make clear if you didn't realize this, a Layer 3 switch is a Layer 2 switch with added capabilities. A layer 3 switch can be run as a layer 2 switch, or a combination thereof.

You just configure the layer 2 ports exactly the same as you would on any layer 2 switch. Once you have the layer 2 ports configured, you can then add an IP address to the vlan interface so that it can then also act as the gateway to the devices on that VLAN.

mirzaakberali Wed, 03/19/2008 - 10:24

Hi,

Suppose i want to connect my 10 servers to two L3 switches for Redundancy purpose. Can i use HSRP/etherchanneling,then how do i proceed with the configuration.

Rgds,

Akber.

Jon Marshall Wed, 03/19/2008 - 13:54

Akber

Yes you can do this. If you want redundancy on your servers you can run NIC teaming which means one of the NIC's is active and forwarding data and the other NIC is in standby.

You connect one NIC to a port on Switch1 (sw1) and the other NIC to a port on Switch2 (sw2).

Then using the same example as before

sw1

int vlan 10

ip address 192.168.5.2 255.255.255.0

standby 10 ip 192.168.5.1

standby 10 auth cisco

standby 10 preempt

standby 10 priority 110

sw2

int vlan 10

ip address 192.168.5.3 255.255.255.0

standby 10 ip 192.168.5.1

standby 10 auth cisco

standby 10 priority 100

Then you connect the 2 switches together with a fibre/UTP cable and on the port on each switch that this cable connects to

int fa0/24

switchport trunk encapsulation dot1q

switchport mode trunk

As before you give the servers IP addresses from the 192.168.5.x subnet and the default-gateway is 192.168.5.1

HTH

Jon

Actions

This Discussion