LMS 2.6 & 3.0 Topology Services - Java plugin?

Unanswered Question
Mar 19th, 2008

I have an older LMS 2.6 server and a newer (evaluation) LMS 3.0 server, both have the latest patches installed (available on CCO). When I use an XP client with IE 7 and the latest Java 6 plugin installed I can sucessfully access Topology services on the LMS 2.6 server. If I use the same client to access Topology services on the LMS 3.0 server I get directed to download an older Java plugin from the server.

Now I am sure if I uninstall the Java 6 plugin from the PC and install the one LMS 3.0 is telling me to it will work, however the client needs Java 6 for other stuff.

Why am I seeing this behaviour difference between LMS 2.6 and 3.0? I assumed there would be no client compatibility issues between the 2 servers?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Joe Clarke Wed, 03/19/2008 - 12:30

This is a common problem we face with client-sided Java. LMS 2.6 and 3.0 require different VM versions, and neither support Java 6. An LMS 2.6 client needs Java Plug-in 1.4.2_15. An LMS 3.0 client needs Java Web Start 1.5.0_13. The LMS 3.0 server is more flexible. If you have Java 6 on the client, you still need to install the 1.5.0_13 VM, but you can keep 6 as well. In order to avoid JVM compatibility issues, you may have to disable the Java 6 VM in the Java control panel when using LMS.

andrew.butterworth Wed, 03/19/2008 - 12:34

Thanks, but why does LMS 2.6 work fine then? The client has only one Java VM installed (1.6.0_05) I have just checked. I can't actually ever remember the LMS 2.6 server complaining about the Java VM version?


Joe Clarke Wed, 03/19/2008 - 12:36

Java 6 may work, but it was never test, and not officially supported. We are stringent when we specify the required JVM version. Newer versions of the plug-in/web start allow for more flexibility, but we require that customers run the supported versions when calling the TAC.

Joe Clarke Wed, 03/19/2008 - 16:27

Since we never officially tested either version with Java 6, there can be no further explanation. The only obvious difference I can think of is that since LMS 3.0 uses Web Start and not the plug-in, there are additional compatibility checks that are required. That said, if you load 1.5.0_13 along side 1.6, you should be able to use everything. You will just need to disable the 1.6 VM when launching Topology Services from LMS 3.0. Of course, if you call in for TAC support for 2.6, you will be told to load the 1.4.2_15 plug-in.

andrew.butterworth Sat, 03/29/2008 - 09:45

OK, I was a bit annoyed that Java 6 wouldn't work with Topology Services in LMS 3.0 so I installed the Java plugin 1.5.0_13 and lo and behold - it didn't work....

I just keep getting prompted to install the plugin, even though it is now installed. I unistalled it and tried again, same problem. As a test I then uninstalled both Java versions. Rebooted, re-installed the 1.5.0_13 plugin when prompted and still it doesn't work....

I must admit I am using the same PC (running Windows 2003 Server), however this is the same machine that worked OK with Topology Services from LMS 2.6. I'll load up a VM machine with a clean Windows 2003 image and see how this gets on.

Java? isn't the latest version supposed to be backwardly compatible with older versions?


Joe Clarke Sat, 03/29/2008 - 09:52

Installing the JRE from the server on a machine without any other JRE installed should work. The installer we use is special in that it also includes some CORBA classes needed for Campus, so it's vital you use our installer. It sounds like you did do this.

However, you might try uninstalling Java again, then login as a local Administrator, and manually copy NMSROOT\htdocs\plugin\jre-1_5_0_13-windows-i586-p_withvbj.exe to your client, and install it. This will absolutely guarantee all of the files are properly installed.

andrew.butterworth Wed, 04/02/2008 - 04:04

I think this is the 4th time I have tried this now and it still won't work....

I have removed all Java instances on the PC, rebooted and then re-installed the Java plugin when prompted, then rebooted and still I just get pushed to the 'install java plugin' page.

I can only assume there is an issue with the PC. I'll try another workstation and see if that works.



This Discussion