Urgent help. Etherchannel

Unanswered Question
Mar 20th, 2008

I have created a port channel between 2 switches

int fa0/1 and fa0/2

as the following

int range fa0/1-2

switch mode access

switch acce van 10

channel-gr 10 mode on

Switch A

Created vlan 10

ip addres

Switch B

Created vlan 10

ip addres

but as soon as I connect the cables into the Fa0/1 and Fa0/2 on both switch it comes up and then goes down and stops working so I cannot ping or

What am I doing wrong?

These are Cat 2960.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
melwongpl Thu, 03/20/2008 - 03:17

Etherchannel cannot be created across different switches unless you use Catalyst 3750 X-stack. Across different ports on the same stack of switches.

qwertys21 Thu, 03/20/2008 - 03:21


These are Cat2960s and not different switches. Ok, maybe I have to use a cross over cable as they are switch to switch

melwongpl Thu, 03/20/2008 - 03:24

What i meant different switches are different physical switches irregardless of models.

Yes you can use cross cable to create VLAN trunk or L3 links.

But if you want to use etherchannel across different physical switch, it cannot be done unless you use Catalyst 3750 X-stack.

glen.grant Thu, 03/20/2008 - 05:12

If you are using straight thru cables and letting mdix correct the pinouts then you "cannot" hardcode the speed and duplex on the ports , they must be left as auto for this to work.

joeevans Thu, 03/20/2008 - 06:40

YOu will need to use cross over cables unless you can alter the MDI-MDIX settings. You should also fix the speed/duplex to 100/full on all ports.

Istvan_Rabai Thu, 03/20/2008 - 13:50

Hi Ade,

1. The best is to use crossover cables.

2. Please look at the speed and duplex settings of the ports in question with the "show interface fa0/1" and "show interface fa0/2" commands on both switches.

If they are not the same, then issue the "speed 100" and "duplex full" commands in interface config mode on both ports on both switches.

3. Did you configure the port-channel on both switches with the same commands?




This Discussion