Router subinterface question

Answered Question
Mar 20th, 2008

HI, I have set up a simple lab to study inter Vlan routing. I have set up two Vlans on my 2950 switch and created a trunk between a switchport and a fastethernet port on a 2600 router. When I try to configure the router port with subinterfaces I get this message 'Configuring IP routing on a LAN subinterface is only allowed if that

subinterface is already configured as part of an IEEE 802.10, IEEE 802.1Q,

or ISL vLAN'. Seems like the Router port needs to be configured with some Vlan information, but I dont know the commands - any ideas ??

The router config is as follows:

(For Vlan 1:)

int fa0/0

ip address 192.168.120.3 255.255.255.224

(For Vlan 2:)

int fa 0/0.2

ip address 192.168.120.3 255.255.255.224

Then I get the message stated above.

The CLI doesnt give me a chance to use the encapsulation dot1q 2 command.....

I am running IOS 12.3 on a 2621 router. Perhaps this version doesnt support subinterfaces ??

I have this problem too.
0 votes
Correct Answer by Jon Marshall about 8 years 8 months ago

Benjamin

You have the IP/FW/IDS feature set and this does not support 802.1q trunking.

The equivalent IP Plus version c2600-is4-mz.123-3.bin needs 64k RAM so you couldn't use that on your 2600. You could go for a lower IOS version ie. 12.2 or 12.1 with IP Plus feature set.

Cisco have something called the Feature Navigator which allows you find software images with the right features.

http://tools.cisco.com/ITDIT/CFN/jsp/index.jsp

You need a Cisco login to use this.

Jon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Jon Marshall Thu, 03/20/2008 - 07:13

Benjamin

What is the IOS feature set that you have. If you want to 802.1q trunking on the 2621 you need a minimum feature set of IP Plus.

Jon

benjaminfoster Thu, 03/20/2008 - 07:32

I have looked in the show version but cant see any reference to the feature set. What command can I use to find it ?? Here is the sh ver:

Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600-IO3-M), Version 12.3(3), RELEASE SOFTWARE (fc2)

Copyright (c) 1986-2003 by cisco Systems, Inc.

Compiled Tue 19-Aug-03 16:32 by dchih

Image text-base: 0x80008098, data-base: 0x80D11A24

ROM: System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1)

R1 uptime is 15 minutes

System returned to ROM by power-on

System image file is "flash:c2600-io3-mz.123-3.bin"

cisco 2621 (MPC860) processor (revision 0x600) with 44032K/5120K bytes of memory

.

Processor board ID JAD06020JD1 (3490212388)

M860 processor: part number 0, mask 49

Bridging software.

X.25 software, Version 3.0.0.

2 FastEthernet/IEEE 802.3 interface(s)

1 Serial network interface(s)

32K bytes of non-volatile configuration memory.

16384K bytes of processor board System flash (Read/Write)

Correct Answer
Jon Marshall Thu, 03/20/2008 - 09:13

Benjamin

You have the IP/FW/IDS feature set and this does not support 802.1q trunking.

The equivalent IP Plus version c2600-is4-mz.123-3.bin needs 64k RAM so you couldn't use that on your 2600. You could go for a lower IOS version ie. 12.2 or 12.1 with IP Plus feature set.

Cisco have something called the Feature Navigator which allows you find software images with the right features.

http://tools.cisco.com/ITDIT/CFN/jsp/index.jsp

You need a Cisco login to use this.

Jon

Actions

This Discussion