Routing issue: 3750 in routing mode c/w static routes

Unanswered Question
Mar 20th, 2008
User Badges:

I have a cisco 3750 that is in routing mode. Here are the static routes:


ip route 0.0.0.0 0.0.0.0 10.9.1.1

ip route 10.10.0.0 255.255.0.0 192.168.99.14

ip route 172.17.0.0 255.255.0.0 192.168.99.14

ip route 192.168.99.8 255.255.255.252 192.168.99.14

ip route 192.168.112.0 255.255.240.0 172.16.1.21


There are two vlans:

interface Vlan1

ip address 10.9.1.10 255.255.0.0

!

interface Vlan2

ip address 172.16.1.10 255.255.128.0


The 3750 is acting as a dhcp server for the 172.16.0.0/16 subnet. As you can see, to get to 10.10 and 172.17, the default gateway is 192.168.99.14 which is another 3750 at the end of a wireless link. The subnet 10.9/16 (vlan1) and 172.16/16 (vlan 2) are on the LAN side of the 3750. Here is my challenge:

giga port 1/0/2 has an IP address, here is its config:


interface GigabitEthernet1/0/2

description LinkToWapasu

no switchport

ip address 192.168.99.13 255.255.255.252

service-policy input Qos-Tag

priority-queue out


Attached directly to this port is a Cisco 2960 that is acting as a Ethernet/Fibre transceiver. It connects by Ethernet to a DragonWave wireless modem and by fibre to the 3750. I want to be able to manage both the 2960 and the DW modem. How do I configure the IP information? I tried initially configuring the 2960 with: 10.9.1.41/16 and dg 10.9.1.1 (the dg of the LAN), but this didn't work. I also tried a dg of 10.9.1.10, no luck. I tried setting the 2960 with: 192.168.99.2/24 with dg of 192.168.99.13, but that didn't work. I tried telneting from the 3750 to the 2960. I tried pinging the 2960, but this doesn't work.


How should I configure the management interface on the 2960? Do I need to put a route on the 3750? It doesn't make sense to do that since the 2960 is directly connecte, i.e., there is no next hop.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Thu, 03/20/2008 - 12:22
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Hi


If i understand your setup correctly the problem you have is that the 2960 is attached to routed port on the 3750.


If you want to be able to manage the switch you will have to make some changes ie.


1) The connection between your 3750 and your 2960, gi1/0/2 will have to be made into a trunk.


2) You need to create another vlan for the link between your 3750 and the other 3750 ie.


vlan 3

ip address 192.168.99.13 255.255.255.252

service-policy input Qos-Tag

priority-queue out


3) Then you can configure the vlan 1 interface on the 2960 as


vlan 1

ip address 10.9.1.41 255.255.0.0


and set it's default gateway to vlan 1 interface on 3750.


Couple of things


1) This will introduce STP across the link

2) Not sure of how your QOS is working so it may behave differently on an SVI than a routed physical port.


The other thing you could do is run a separate connection from your 3750 to the 2960 with both ports in vlan 1. This may be a better solution for you.


Hope this makes sense


Jon

Richard Burts Thu, 03/20/2008 - 12:31
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Murray


If I am understanding correctly the 2960 and the DW modem are connected through interface Gig1/0/2. And interface Gig1/0/2 is configured as a routed port (no switchport) which means that it is not a member of VLAN 1. Which means that you can not get to the 2960 or the DW modem if you give them VLAN 1 addresses.


In fact given that Gig1/0/2 is a routed port with an address using a /30 mask means that you can not give the 2960 or the DW modem an IP address that is reachable since the /30 mask only allows for 2 host addresses.


If the 2960 and the DW modem are connected to Gig1/0/2 and you want them to be manageable then you must make the subnet on the routed interface at least a /29 to allow enough available host addresses.


If I have misunderstood something about your environment or your requirements then please clarify.


HTH


Rick

Jon Marshall Thu, 03/20/2008 - 12:34
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Rick


Think you understood better than i did.


Murray


The better solution would be to ignore my suggestion and go with Rick's.


Jon

murray-davis Thu, 03/20/2008 - 12:56
User Badges:

Thank you, Rick and Jon


Yes, Rick, I needed to go back to the basics. Of course, a /30 only has two useable addresses. Duh! Jon, your solution is also a workable one. We usually run at least two cables for any all runs, so your solution would be workable if we had done so in this situation. Of course, because another contractor other than our regular one did this work, they didn't install multiple cables. Also, we don't have any free ports on the 3750, so the best solution is Rick's, change the subnet mask. Again, thank you, gentleman.

Jon Marshall Thu, 03/20/2008 - 13:00
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Murray


No problem. One thing to mention, the vlan interface you create on your 2960 for management needs to be the same vlan as the port on the 2960 that the 3750 connects into.


Apololgies if that sounds really obvious.


Jon

murray-davis Thu, 03/20/2008 - 14:05
User Badges:

Thank you, Jon. One thing I just discovered is that there is a third option. Put a secondary ip address on the gig interface on the 3750 such as 192.168.200.6/248 and place vlan 1 on the 2960 in that subnet. I would then just have to set up a route to that subnet from my lan.


Regards,

Richard Burts Fri, 03/21/2008 - 11:23
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Murray


Yes the secondary address is a creative solution that sounds like it would solve your issue.


HTH


Rick

Actions

This Discussion