DHCP Configuration

Unanswered Question
Mar 21st, 2008
User Badges:

Hi,


I have a 3750G-E switch. When I tried configuring a DHCP server within the switch, it was not giving out ip addresses on all the ports. So, I tried configuring the ports to use VLAN 1, and it is now working.


My question is that, is there any way that I can create multiple DHCP server in a 3750G switch to cater to multiple VLANs (vlan 10, 20, 30, etc) other than vlan 1.


Thanks,

Ninoy

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Richard Burts Fri, 03/21/2008 - 03:51
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Ninoy


Yes you can create multiple DHCP ranges that correspond to multiple VLANs. You would create multiple DHCP address pools with subnets that correspond to the subnet addresses of the VLAN interfaces. Then when a DHCP request is received the switch looks at the VLAN interface it was received on and assigns an address from the pool that corresponds to that subnet.


HTH


Rick

optionstechnology Thu, 04/17/2008 - 01:11
User Badges:

Hi

should this work for voice vlan's ?

i don't seem to be getting a voice vlan dhcp address from the switch


ie

ip dhcp pool client-pc

network 192.168.250.0 255.255.255.0

!

ip dhcp pool client-voip

network 192.168.251.0 255.255.255.0

!

interface Vlan250

ip address 192.168.250.1 255.255.255.0

!

interface Vlan251

ip address 192.168.251.1 255.255.255.0

!

interface GigabitEthernet1/0/2

switchport access vlan 250

switchport mode access

!

interface GigabitEthernet1/0/2

description IP Phone Port

switchport access vlan 999

switchport mode access

switchport voice vlan 251


Can you help ?

thanks

-Paul


mahmoodmkl Thu, 04/17/2008 - 01:19
User Badges:
  • Gold, 750 points or more

Hi


U havent specified the default-router option for u r address ranges configure it and check.


Thanks

Mahmood

optionstechnology Thu, 04/17/2008 - 01:36
User Badges:

i've just snipped off some of config for clarity

the complet voice dhcp scope config is...


ip dhcp pool client-phone

network 192.168.251.0 255.255.255.0

dns-server 192.168.5.200 192.168.7.203

netbios-node-type h-node

domain-name xxx.com

default-router 192.168.251.1

option 150 instance 1 ip 192.168.200.10

option 150 instance 2 ip 192.168.210.10

option 66 ascii "phone"

lease infinite

Actions

This Discussion